View Full Version : Knoppix 4 DVD problem, OpenOffice can't load files

07-12-2005, 06:38 PM
I got the Knoppix 4.0 DVD and it works fine - except for OpenOffice. It is possible to create and save a new file with OOWriter, but trying to load it again seems impossible. OO starts to load and then hangs. No error messages.

I tried it with several types of files and on three different computers, with the same result. Is there a trick to get OpenOffice working?

07-14-2005, 07:56 AM

Actually I got the same problem. ANY part of Openoffice will hang when I try to load ANY filetype (openoffice 1.1 / openoffice 2.0 / or MS-filetypes)
The same Problem with Knoppix 3.9 -CD.
And: the Problem persists even if you install to HD, or create a permanent home-image.

Everything works fine on Knoppix 3.8, as it has the stable Openoffice 1.1.4 on board.
I have to go back to Knoppix 3.8 as the OS is useless for me without Openoffice, though 3.8 lacks other nice Software (like xmaxima)

07-14-2005, 09:18 AM
Thank God, I'm not alone :)

I don't think it's OpenOffice - I'm using 2.0 pre on SuSE 9.3 and there it works. I couldn't find any OO bug messages related to this problem, so maybe it is a Knoppix problem? A file that needs to be opened but is read-only due to being stored on a DVD?

07-14-2005, 01:12 PM
Its probably OO.org 2.0 beta which is causing the problem. http://www.knoppix.net/forum/viewtopic.php?t=19833

07-15-2005, 07:29 PM
I'm quite sure it is related to the beta, but only this Version of the Openoffice2 beta (1.9.079 I think). I already used newer versions (1.9.114 or so) on other OS and they worked fine. As I really like the rest of the DVD, espeacially the kernel and the nice usb-device detection-and-auto-mounting while the system is already up, I thought about making a HD-install, and replacing the Openoffice2beta with the Openoffce 1.1.4 stable.
kpackage works fine with other packages (add/remove/update), but it doesn't build a dependence-tree for any openoffice-related packages.

Hopefully I am just too stupid to use kpackage and someone can tell me how to get rid of the beta and install the stable version?
(without selecting and installing each single package by hand)

07-15-2005, 07:38 PM
I use synaptic instead of kpackage. I refreshed the on disk package lists (effectivly a aptitude update) and then CTRL-F and type in openoffice. It will show you openoffice-de (i think?). Uninstall that package. Then CTRL-F & again type openoffice and install openoffice.org 1.1.4-3.