View Full Version : Aghhhh fstab read-only!! Cant write to it whatever I do :-(

07-14-2005, 10:18 AM
Please can anyone help a n00b?

I've buggered my multiboot somehow, I dont know how. I did have a multiboot system with different distros on, with a Knoppix hdd install being my main system, also having XP on there (yak).

My system now boots to this kind of stuff below:

WARNING: Your /etc/fstab does not contain the fsck passno field

the superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

I've done loads of reading on here, but people seem to have had one the the following situations:

1. Had to format the disk.
2. Fixed it and not explained how.
3. Fixed it doing something that's completely over my head.

I've checked the 3 fstab's I seem to have on the different partitions, and one seems normal, one is blank (the knoppix primary one) and another is only half filled in and looks all wrong.

I've tried to edit the one on hda2 (the knoppix primary one) with the good one from hda6 (the right looking fstab) but whatever I try, I get nowhere. I keep coming up against the 'read-only' business.

I cant boot from the disk, so I've been booting knoppix on the live disk so I can see stuff. All the disks appear on the desktop, and then I go properties on them, set to full access, then mount them, but I still get read only permission errors when I try and edit fstab?????!

I've been trying from the terminal too, with my limited knowledge, changing over to root, but that STILL gives me read-only only errors for overwriting or editing this hda2 fstab, when I've given it full permissions before mounting!!!

I think if I can edit the fstab I might get somewhere, but I've got no idea how to do it!! :-(

Please, has anyone got an idiots guide??

Thanks in advance


07-14-2005, 09:16 PM
su vim /etc/fstab

Should work. You may run into permissions issues if you're doing this from one distro to another. Best bet is to boot the knoppix CD and try from that.

07-14-2005, 11:33 PM
That worked!! I mounted the drive from the terminal instead this time with the -w switch too and it lets me edit it! I had to learn how to use vim tho lol
NOT SO GOOD NEWS - I've doctored the fstab and the bloody thing still doesn't boot - fsck and superblock routine at boot......


07-15-2005, 10:09 PM
No one knew the answer, so I sussed it myself!!
Multiboot was the key - I edited the fstab on the bloody wrong partition!! hahahahaha
The one I needed to edit was hda4, I was editing hda2 hahahaha
I looked at the one on hda4 and it was blank!! I put a single line in to mount the partition and put it as ext3 and rw,rebooted, and viola, knoppix hdd install sorted itself out and rejigged the fstab for me to add all the other drives!!

I'll try and help out in future if anyone gets a problem like this!

Muchimus gracias