View Full Version : Error 17 with grub

07-14-2005, 08:27 PM
Hi. I have read a lot of posts here, but have seen nothing relevant to this problem. I have knoppix installed to HD and it works very well. A friends wants to install knoppix as well. We are both new to linux, though we both have a lot of experience with Windows (3.1, 95,98, and XP). Here is his situation:
hard drive C: (hda)(20 gig)is fat32 WinXP Pro. hard drive D:(hdb) (200 gig) has 4 partitions. hdb1 is NTFS WinXP Pro. hdb2 is fat32 for data and programs from hda1. hdb3 is linux partition (ext3 created by Partition Magic 8) hdb4 is linux swap (also created with Partition Magic 8) The reason for the 2 winXP Pro installations is that he is doing the online college thing, and he wants to keep his schoolwork and the required programs seperate (mainly so his kids don't mess with that stuff). He had the 2 win XP instalations working with a windows dual boot setup. We tried to install Knoppix to hdb3. It actually did install. Grub was also installed, and we made a boot diskette. Now when he tries to boot, grub won't even load to the menu screen. It exits after stage 1.5 with error 17. With the boot diskette, the menu screen comes up, but when either of the 2 linux options is selected, we get something like this "error 17 the partition could not be mounted". I am not sure if this is the exact wording. He can boot to the Windows bootloader by selecting the first Windows option on the menu. He says he also tried to install aLinux (used to be Peanut linux) and had similar results.

I did look at the entries in the menu.lst file on the boot floppy, and the Linux entries are looking at hdb3 for the kernel.

Any ideas on why this is happening, and how to correct it ?

Any help would be greatly appreciated!