View Full Version : Networking problem with WEP access point

07-27-2005, 10:40 PM
Hi all,

This is my first post but I have already done a search and tried just about everything that I've found here on my Gateway laptop with Intel's Centrino chipset. It has an Intel Pro 2200 wireless in it.

I have a Netgear router and while I can pick it up just fine in Windows with the proper encryption key, I am having problems with Knoppix.

My problem is that no matter what I've tried, etho does not seem to get a DHCP IP from the router. It sees the router and can connect to the router but it does not get an IP not can I ping the router or other systems on my network.

With that said, there are a lot of windows that pop open that ask me to fill in eth0 information in the wireless setup where I type in the encryption information.

Does anyone have any ideas on what I might be doing wrong?

I've tried the pump -i and the other commands for ath0 and i keep getting errors whenever i try that.

Thanks for any help or guidance that you guys can provide!

07-29-2005, 04:39 AM
here is a quick summary of where this stands thus far:

i have entered in the encryption information into the iwconfig ath0 and my kwifimanager can get a signal and get info from the router but when i configure the network card (eth0) to pluck an IP nothing works.

and i don't see any info in the iwconfig for dealing with ath0 and forcing an ip or using dhcp with it.

if i try connecting without encryption (WEP) everything works just fine. it's only when i turn WEP on that i cannot get an IP.

it's got to be user error but i can't figure out what i'm missing or doing wrong.

HELP! please? not knowing how to fix this has become an obsession with me.

07-30-2005, 04:42 AM
did i say something to offend someone?

am i asking a stupid question?

i don't get it. no one is even telling me to rtf(insert letter of your choice here).

i want to learn what i'm doing wrong and it's kinda hard to do that if no one will give you any guidance.

07-30-2005, 10:47 PM
well not like it matters but i turned off wep and now it works just fine.

i have connections limited to two and i have the router configured to only accept connections from this and my wife's nic macs.

i just don't understand why no one chose to ever reply to this.

07-30-2005, 11:04 PM
Many of us do not have wireless networks or wireless HW. I know alot but wireless is mostly outside of my knowledge range. You are asking for assistance with wireless & as compared to wired networks, it has a smaller userbase population.

07-31-2005, 12:24 AM
thanks underscore...err. groundskeeper willie.

i was thinking that maybe you folks thought my question too juvenile or stupid to bother with.

08-01-2005, 03:30 AM
Hi, I'm having the same problem here, I have WEP Encryption enabled in my router, and I can't turn it off because of security reasons. If anyone knows how to do this I would really appretiate it. Thanx

08-01-2005, 04:03 AM
well netgear's forum isn't much help either. my post about this problem has been looked at 16 times and no one has responded.

the best that the can offer is to turn off dhcp and assign ip's to each system with wep enabled.

my problem is that even with assigned ip's, there is no connection. for some strange reason netgear believes that there is a problem when wep is enabled and that's the only solution that they can offer.

now i know that's what they suggest for the wgr614v6. i cannot suggest doing this for any other make or model of router but i'm taking this hunk of junk router back to best buy and buying a different one.