PDA

View Full Version : NVIDIA quick install HOWTO



lars
04-21-2003, 07:16 PM
Download:
As for now, the latest driver:
http://download.nvidia.com/XFree86/Linux-x86/1.0-4349/NVIDIA-Linux-x86-1.0-4349.run
As root:
"export CC=/usr/bin/gcc-2.95"
cd into the NVIDIA file directory
"sh /NVIDIA-Linux-x86-1.0-4349.run"

Edit this file /etc/X11/XF86Config-4
Remove the following lines:
Load "dri"
Load "GLcore"
And add the following line under section Module (if it's not there):
Load "glx"
Finally change:
Driver "nv"
to:
Driver "nvidia"

Edit this file /etc/modules.conf
Add this line:
alias char-major-195 nvidia

Edit this file /etc/modutils/aliases
Add this line:
alias char-major-195 nvidia

Finsihed. Reboot.
[/i]

MichielioZ
04-22-2003, 06:00 PM
Shouldn't you've installed the kernel-headers for this ??
(Or are they already installed in the new versions ?)

VeeDubb
04-22-2003, 06:05 PM
either you don't need them or they are allready there in version 3.1 and above.

mourner
04-23-2003, 07:05 PM
lars, thank you very much for the help; it saved me time.

One minor comment, however:

Edit this file /etc/modules.conf
Add this line:
alias char-major-195 nvidia

Edit this file /etc/modutils/aliases
Add this line:
alias char-major-195 nvidia

You should not edit /etc/modules.conf directly, as stated in the file's header. Executing "update-modules" after editing /etc/modutils/aliases is sufficient. That's the Debian way. ;)

mourner
04-23-2003, 10:06 PM
BTW, if one does not mind the risk of breaking a fresh HD install, the following snippet automates lars' NVIDIA quick install. I called it "install_nvidia_drivers.sh". It worked when I ran it on a Knoppix 2003-04-18 DE from HD.



#!/bin/sh

if [ "$UID" -ne 0 ]; then
echo "Error: this script must run as superuser!"
exit 1
fi

export CC=/usr/bin/gcc-2.95

STARTDIR="`pwd`"
URI=http://download.nvidia.com/XFree86/Linux-x86/1.0-4349/NVIDIA-Linux-x86-1.0-4349.run
FILE=$STARTDIR/NVIDIA-Linux-x86-1.0-4349.run

[ -f $FILE ] || wget $URI
chmod 755 $FILE && $FILE

FILE=/etc/modutils/aliases
cp $FILE $FILE.bak
echo -e "\n# `date -Iseconds` added by install_nvidia_sh\nalias char-major-195 nvidia" \
>>$FILE
update-modules

FILE=/etc/X11/XF86Config-4
cp $FILE $FILE.bak
sed -e "s/Load.*\"dri\"/#Load \"dri\"/; \
s/Load.*\"GLcore\"/#Load \"GLcore\"/; \
s/Driver.*\"nv\"/Driver \"nvidia\"/;" \
"$FILE.bak" >$FILE

exit 0


If your host is connected to a LAN, there are a couple of glitches knx-hdinstall is not aware of. The DNS and MTA configurations are incomplete and thus have to be renewed, and the users root and knoppix lack a .profile or .bash_profile in their home directories. The text editor nano, which I happen to like and which is present in Debian woody, is missing. I have a script that addresses these issues, too, since I'm updating my Knoppix installation rather frequently. :)

theARE
04-28-2003, 08:48 PM
Thanks for the info, made it really simple to get the drivers installed. 8)

fearlessrogue
05-21-2003, 12:29 PM
Forgive the ignorance. I am a laptop user and these directions work great for x, but in the consol it semi messed up. Everything is viewable but not easily. It does not appear to be an issue with refresh rates from my experiece.

Thanks for any possible help.

Zagreus
06-19-2003, 05:43 AM
A quick note. A newer version of the nvidia drivers (1.0.4363) have been released. Update version numbers as needed for the directory and files. The script works very well overall and seriously should be added into Knoppix.

Crest
08-28-2003, 05:08 AM
I have tried several times to install the Nvidia drivers on Knoppix 3.2 (2003-07-25 Beta) with Kernel 2.4.21-xfs, but always without success. Also after following the instructions in this thread I still received the same error messages in the XFree86.0.log (Screen(s) found, but no usable configuration). Finally the solution was just to assign an IRQ to my Nvidia card. Normally I don't because lack of free IRQ's (pretty much cards in my machine + USB port in use) and Windows or DOS don't care about that. Now the card works under Linux even when I had to disable my parallel port for this moment to free an IRQ (one of my two serial ports is already disabled ;)).

Crest

bootmaker
10-11-2003, 08:29 PM
What about Knoppix 3.3 ??

Gnu Penguin
10-15-2003, 10:29 PM
-I just tried the install by the "lars" method as modified by "mourner." I am using Knoppix_V3.3-09-24-EN. The driver I am installing is NVIDIA-Linux-x86-1.0-4496.run (the very latest driver.)

My dinosaur computer is a K6-2 300 with an ALI p5A mobo and 256MB of PC100 SDRAM.

My dinosaur card is actually the oldest card supported by these drivers, a PCI Creative TNT Riva with 16MB SDRAM (CT6700).

The install worked, and I am now getting the "NVIDIA" splash screen upon starting X.
However, when I ran "update-modules" at the end of the install, I get the following message:


depmod: unresolved symbols in /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/gamma.0

Any ideas?
Except for some strange error messages at boot , the drivers appears to be functioning without any problems. I should note that I have yet to put the 3-D drivers through their paces.

Any help with the above error message would be most appreciated.

servant
10-20-2003, 05:17 PM
Lars,

I followed the instructions, and can't get an X server.

root@john# /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)

root@john# uname -r
2.4.22-xfs

The motherboard is Asus A7V8X-X. The CPU is AMD Athlon XP 2200+ and the memory is Kingston PC3200 256MB.

Installed using the Knoppix v3.3 Live CD dated 09-24-2003. This is second computer and we just want Linux running on it so we can throw Microsoft's junk in the trash can.

This kernel doesn't have the Nvidia GeForce4 driver so installed NVIDIA-Linux-x86-1.0-1.0-4496-pkg2.run from Nvidia site. This is how it was installed:

root@john# export CC=/usr/bin/gcc-2.95
cd into the NVIDIA file directory
sh NVIDIA-Linux-x86-1.0-1.0-4496-pkg2.run
cd //etc/X!!/XF86Config-4
removed these lines:
Load "dri"
Load "GLcore"
and added this line:
Load "glx"
changed:
Driver "nv"
to:
Driver "nvidia"
cd /etc/modutils/aliases
Add this line:
alias char-major-195 nvidia
root@john# update-modules
root@john# reboot

There was something Nvidia went to their ftp site and did something about the kernel. I don't remember, did not write it down (it happened too fast) and was all according to instructions. I searched at Google and Google/Linux and other forums and only answer is Google's and it looks like Spanish. I looked at the Spanish but can not read it. Here is the error log that my system said to report for help. Sorry it's so long - just obeying the message:


XFree86 Version 4.3.0 (Debian 4.3.0-0ds4 20030416150820 dstone@aedificator)
Release Date: 18 March 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-pre5 i686 [ELF]
Build Date: 16 April 2003
Before reporting problems, check XFree86dotOrg
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.22-xfs (root@Knoppix) (gcc version 2.95.4 20011002 (Debian prerelease)) #1 SMP Fr Sep 19 17:55:45 CEST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Oct 19 04:35:34 2003
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "PS/2 Mouse"
(**) |-->Input Device "USB Mouse"
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/truetype".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/share/fonts/truetype").
(WW) The directory "/usr/X11R6/lib/X11/fonts/defoma/CID" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/defoma/TrueType" does not exist.
Entry deleted from font path.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/75dpi,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/PEX,/usr/X11R6/lib/X11/fonts/cyrillic,/usr/X11R6/lib/X11/fonts/Type1,/usr/share/fonts/ttf/western,/usr/share/fonts/ttf/decoratives,/usr/share/fonts/truetype/openoffice,/usr/share/fonts/truetype/ttf-bitstream-vera,/usr/share/fonts/latex-ttf-fonts"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(**) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail" "true"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3189 card 1043,807f rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b168 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:10:0: chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:1: chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:2: chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:3: chip 1106,3104 card 1043,80a1 rev 82 class 0c,03,20 hdr 00
(II) PCI: 00:11:0: chip 1106,3177 card 1043,80a1 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1043,80a1 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:5: chip 1106,3059 card 1043,80a1 rev 50 class 04,01,00 hdr 00
(II) PCI: 00:12:0: chip 1106,3065 card 1043,80a1 rev 74 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0181 card 1048,0c9a rev a2 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xee000000 - 0xefefffff (0x1f00000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xeff00000 - 0xf7ffffff (0x8100000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] rev 162, Mem @ 0xee000000/24, 0xf0000000/27, BIOS @ 0xeffe0000/17
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xf8000000 from 0xfbffffff to 0xf7ffffff
(II) Active PCI resource ranges:
[0] -1 0 0xed000000 - 0xed0000ff (0x100) MX[B]
[1] -1 0 0xed800000 - 0xed8000ff (0x100) MX[B]
[2] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[3] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[4] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[5] -1 0 0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
[6] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[7] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[8] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[9] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[10] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[11] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xed000000 - 0xed0000ff (0x100) MX[B]
[1] -1 0 0xed800000 - 0xed8000ff (0x100) MX[B]
[2] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[3] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[4] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[5] -1 0 0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
[6] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[7] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[8] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[9] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[10] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[11] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xed000000 - 0xed0000ff (0x100) MX[B]
[6] -1 0 0xed800000 - 0xed8000ff (0x100) MX[B]
[7] -1 0 0xf8000000 - 0xf7ffffff (0x0) MX[B]O
[8] -1 0 0xeffe0000 - 0xefffffff (0x20000) MX[B](B)
[9] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[10] -1 0 0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]
[14] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[B]
[15] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[16] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[17] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[18] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols found
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(EE) LoadModule: Module nvidia does not have a nvidiaModuleData data object.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/X11R6/lib/modules/drivers/nvidia_drv.o

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to .


Thanks for helping. We want to be FREE from the Microsoft demons!


He Ming Dao

SuperDuper
11-02-2003, 04:57 AM
Hi all
I tried the latest drivers which Nvidia have changed and no longer distribute kernel sources and because of this no suitable kernel is found and the driver fails, the script in an earlier post in this thread works, this uses the earlier drivers which Nvidia supply the kernel sources for so when it does not find a suitable kernel module it actualy compiles one from those sources.

Use the script it works just copy the script from the post into a text editor ie kedit etc, save as nvidia-install.sh to the hard disk, open console su to root then change to the directory where you saved the nvidia-install.sh close down the xserver easy way logout then find the console button in the login splash screen (third button from left choose console) then type ./nvidia-install.sh make sure you have a network connection to the internet running if you use this method.

I have not tried downloading the drivers to disk then executing the script so can't comment on this method.

SuperDuper
11-02-2003, 05:01 AM
Hi all
I tried the latest drivers which Nvidia have changed and no longer distribute
kernel sources and because of this no suitable kernel is found and the driver fails
the script in an earlier post in this thread works, this uses the earlier drivers which
Nvidia supply the kernel sources for so when it does not find a suitable kernel module
it actualy compiles one from those sources.
Use the script it Works! just copy the script from the post into a text editor ie kedit etc
save as nvidia-install.sh to the hard disk, close down the xserver easy way, logout
then find the console button in the login splash screen (third button from left choose console)
log in as user su to root then type ./nvidia-install.sh make sure you have a network connection
to the internet running if you use this method.
I have not tried downloading the drivers to disk then executing the script so can't
comment on this method.

raduen
11-11-2003, 11:56 PM
I'm a newbie..
I tried everything on this formum, but still no succes.
I'm using knoppix 3.3:
uname -a give me this.
Linux rado 2.4.22-openmosix-1 #1 SMP Tue Sep 30 00:25:49 CEST 2003 i686 GNU/Linux

When a run de script mention above i gt an error saying no precomplied kernel, after this mine XF86Config-4 is 0 bytes.

I tried compiling a kernel, i can compile de NVIDIA_GLX-1.0-4191 without error but when i compile this NVIDIA_kernel-1.0-4191 i get error's: I changed the gcc to 2.49 , the ignore option to 1, stil error's after this mine XF86Config-4 get 0 lenght again.

I dit a agt-get update and ugrade. tried again still error.
Converted rpm to deb , no success....

Believe me , i tried everyting on this forum en other forums.

:cry:

isodope
05-09-2004, 06:57 PM
I have a fair amount of experience with Linux, but getting my Nvidia Geforce2 card to work was proving to be a challenge. The install_nvidia.sh script worked great! Thank you to the author and this really should be included with the release.

Rink
07-02-2004, 11:56 AM
I've used the script before and it works well.

I am now without internet access and would need to cut the required files to a cd instead of downloading them.

Can anyone give a list of the files which would be downloaded and also suggest ways of tweaking the script(s) to achieve this?