PDA

View Full Version : Problem with netgear wireless



cosmosgr
08-10-2005, 08:29 AM
I have knoppix ver 3.6.
I'm new in it and i'm trying to use a netgear 54 mbps wg311 v2 32bit pci network card but i don't have any network connection. Instead if i use a simple network card with a wire i have.
What's the problem. Should i download the new version?
Thank you very much

UnderScore
08-10-2005, 06:00 PM
What I am about to describe may very well be outside of your experience level. If it is then I apologize. This method is very technical but it works.

I have the same wireless network card. I have not yet tried to get it working with Knoppix. I have got it working with both Suse 9.3 Pro (a hard drive installed distro) and Whax (http://www.iwhax.net) (a Live CD distro).

The WG311 v2 is not identical to the WG311 v1. Netgear must have changed some of the chips on the card because the drivers & methods that were reported to work with v1 do not work as good (if at all) with v2. This means that we must use a driver wrapper called ndiswrapper (http://ndiswrapper.sf.net). It is a translator driver that makes a network card driver for MS Windows work on Linux.

Normally the progression of how drivers work looks like:
Linux kernel -> Linux network driver -> network card

With Ndiswrapper, it looks like:
Linux kenerl -> ndiswrapper -> Windows network driver -> network card

So now you see that it requires not 1 but 2 pieces, the ndiswrapper & the windows driver. Suse 9.x and Whax include ndiswrapper. Knoppix 3.8.x and up _may_ include ndiswrapper (i don't know). You can follow the generic ndsiwrapper installation instructions at http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation and there is WG311 v2 specific advice at http://ndiswrapper.sourceforge.net/mediawiki/index.php/Netgear_WG311_v2.

Much of this next set of info is pulled from: http://ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.x. The Windows driver for the WG311 v2 card is ftp://downloads.netgear.com/files/wg311v2_wpa_1_0_1_7.zip. Extract out only the Windows XP folder and its contents since the rest of the files are not needed. Use whatever to get the drivers, I've used wget as an example. You can use a webrowser. All the command must be done as root user (use command 'su -' to become root user).

wget ftp://downloads.netgear.com/files/wg311v2_wpa_1_0_1_7.zip
unzip wg311v2_wpa_1_0_1_7.zip
cd 1.0.1.7
cd Driver
cd Windows\ XP

Once your in the directory containing the .inf file install the driver using ndiswrapper
ndiswrapper -i wg311v2.inf

You can check the driver installed ok using...
ndiswrapper -l

Link the ndiswrapper to the wlan0 interface like so (puts an ndiswrapper file in /etc/modprobe.d/)...
ndiswrapper -m

Start up ndiswrapper using modprobe, this will then give you a wlan0 interface in the wireless config tools (iwconfig), (Don't try a modprobe without installing the drivers first, it just won't work!)
modprobe ndiswrapper

You can check that everything loaded ok by looking at the "dmesg" output
dmesg | tail -20

You should see something like this... (don't worry about the references to "kernel tainting", it's ok)
module ndiswrapper unsupported by SUSE/Novell, tainting kernel.
ndiswrapper version 1.0@050205 loaded (preempt=no,smp=yes)
ndiswrapper: driver wg311v2 (NETGEAR, Inc.,04/04/2004,6.0.2.23) loaded
ACPI: PCI interrupt 0000:02:01.0[[A]] -> GSI 19 (level, low) -> IRQ 185
ndiswrapper: using irq 185

This continues from the guide at
http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation#Configure_interface:

Configure interface:
Use iwconfig to configure wireless network interface. First, see if the interface is available, with:
iwconfig

This tool is not likely to be present on your system : it is part of the package (http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html), which you should install. This will print the wireless interface e.g., wlan0. In the examples below wlan0 is used replace wlan0 with the interface reported by iwconfig above.

You can scan for the Access Point using the command
iwlist wlan0 scan

You may have to set the network name before it can scan & find your Access Point. If the scan does not find your AP, replace ESSID with *your* ESSID network name, then try issuing the command
iwconfig wlan0 essid ESSID

before the using the command
iwlist wlan0 scan

The wireless configuration to be used should match what your Access Point AP uses. First, find out if you can see your access point (AP) with
iwlist wlan0 scan

If this lists your AP, you can continue. Otherwise, you may have one of two problems: Your AP doesn't broadcast SSID see the FAQ for more information or the radio of the card is off again, see the FAQ for details. If you see the AP in scan above, set the operating mode of the interface according to your setup. In most cases, it is Managed
iwconfig wlan0 mode Managed

If you use encryption WEP, set the key:
iwconfig wlan0 key restricted TheWEPKeyInHex

You can use 10 hex digits for 40-bit encryption or 26 hex digits for 128-bit encryption. You may need to use open security mode instead of restricted depending on the setup of your AP. If you want to write the key in ASCII use s: e.g. iwconfig wlan0 key restricted s:password. Set the network name
iwconfig wlan0 essid ESSID

Replace ESSID with the network name used by your AP.

At this point, check to make sure that ESSID is set in output of iwconfig wlan0. If you see the ESSID as you set, you can proceed to next step. If you see ESSID: off/any, then your card is not associated to AP. Check if WEP encryption is set exactly as used by AP and the AP broadcasts ESSID. See FAQ for more details. Until ESSID is set in output of iwconfig wlan0, you may not use wlan0 as network interface.
Now, setup the network parameters for the interface wlan0. This varies from distribution to distribution. Refer to your distribution's documents on how to do this. Once this is done, you can use network tools to bring up the network e.g.,


ifconfig wlan0 upor
dhclient wlan0or
dhcpcd wlan0

NuxIT
04-21-2006, 02:52 AM
Thanks Underscore , marked for later.

ola
06-19-2006, 07:29 AM
Hi,

worked fine till
"iwconfig wlan0 essid ESSID"

Thanks for the post. It really brought me a big step further.

Also one remark: There is a shortcut to the iw/ifconfig staff: It is netcardconfig as root.

Unfortunately I stick now at this one:

iwconfig wlan0 gives me this off/any back. Sometimes I see my ESSID and also tried open and restricted.

Can I get please a hint how to learn something about how to continue?
Some time ago I started Knoppix 3.8 or 3.9 on a Sony laptop with a WG511 and I had no problems at all to connect to my LAN. Now I have a Desktop and a WG311 and stumbling arround to get it run.

The scan works and finds 3 networks one is mine. So I assume that I have to learn something about the settings of the encryption or something like this.
But as I said, I had this done before with the laptop and afair I took the same settings and it worked.

Any hints appreciated!
Thanks in advance
Oliver