View Full Version : Running PPPoE config to access internet... need to be root.

08-11-2005, 05:01 PM
I've been using knoppix for a few weeks now, and it works very well, and two days ago i decided to install it to one of my empty hard drive partitions. The internet worked perfectly before and i had no problems with anything, but after i installed it to my hard drive, i can't access the internet thru any program in linux (gaim, firefox, konqueror). I thought i could fix that problem by running the PPPoE configuration to use my sbc yahoo dsl thru my speedstream router with a linksys wireless-g router, but it says i need to be root. I am aware that root has no password, so one must be created in console with sudo passwd root. When i try that, it says i am not a "sudoer". Also, only a few programs, like open office, and konqueror, will work without asking for root permission. I have never had these problems before. Thanks in advance if you have any answers.

BTW, it's not just a faulty or unplugged cable, because windows xp pro has no problem going online.

08-11-2005, 05:29 PM
What version of Knoppix did you install to the HD? What type of HD install (http://www.knoppix.net/wiki/Hd_Install_HowTo#Types_of_installation) did you choose?

08-11-2005, 06:13 PM
i installed v. 3.9, and i installed it under (debian-based system)

08-11-2005, 06:17 PM
A known issue with Knoppix 3.9 HD Installs in that it breaks networking. We have cautioned new users from installing Knoppix to the HD without first being aware that it might not work for them http://www.knoppix.net/wiki/Hd_Install_HowTo

The bug you are running into is documented as #15 http://www.knoppix.net/wiki/Bugs/3.9-2005-05-27 and can be resolved by entering the command as root user:
ln -s /etc/init.d/ifupdown-clean /etc/rcS.d/S18ifupdown-clean
Please try it & let me know if it solves your problem.

A. Jorge Garcia
09-07-2005, 12:36 PM
Sorry I can't help you with the hdinstall of KNOPPIX 3.9 as I haven't tried that yet.

However, I'm curious as to how you set-up your WirelessG since I just got 25 of these USB cards intalled in my classroom without any prior notice and I'm stuck on getting wireless up and running on the liveCD or hdinstall for that matter!