View Full Version : eth0 not working after 'fixing' loopback

08-15-2005, 09:28 AM
I have knoppix 3.9 installed and had some problems with lo configuring. I was able to fix per the documented bug here:
http://www.knoppix.net/wiki/Bugs/3.9-2005-05-27 (#15)

After rebooting if I perform ifconfig -a, my loopback is set up as it should, but now I cannot connect to my DSL.

In the past, I always had to type in pump -i eth0
and my connection to the internet would work.

Now I get a "failed operation" when I do that. I have also tried ifup eth0, and it reports back that it is an 'unknown' device.

Im lost as to what to do now, to get eth0 configured so that I can use my DSL.

Any pointers?



08-15-2005, 10:06 AM
Well, I rebooted several times, and for some reason I was able to use

pump -i eth1

and it worked.

eth0 did not work, I tried to ifconfig eth0 down, and then up again.

Not sure how to have eth1 configured on startup without doing pump.



08-15-2005, 02:17 PM
So you have 2 ethernet devices? Have you inspected/changed the /etcnetwirk/interfaces file at all?

08-16-2005, 02:29 AM
I only have 1 ethernet device (network card), I didn't know what to change, to just show 1.

I did take your cue and look into /etc/network/interfaces file, and this is what I have:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

Where else could I look to see about fixing this so I only have the 1 ethernet device?

Thanks for your help again UnderScore!