View Full Version : iPod mini with Knoppix

08-25-2005, 07:53 AM
After having some challenges getting USB sticks recognized with Knoppix 3.4 on a Toshiba laptop ( see http://www.knoppix.net/forum/viewtopic.php?t=20042 ) - which didn’t work after all, I got my hands on a new iPod mini and have good news to report...

My setup:
Toshiba Satellite M35X-S149
iPod mini 4GB (2nd generation model M9800LL)

You’ll find that there isn’t much info on Unix/Linux at apple.com; you would assume, however, that the mini is somehow supported, because, OS X is Unix after all.
For those not quite familiar with this little box, there’s some very helpful stuff written up by others that I’d highly recommend - before tinkering with the iPod mini (because, after all, choosing to do so is at your own risk, and may potentially invalidate the warranty):

1) http://www.cavecanen.org/linux/ipod/
2) http://people.csail.mit.edu/adonovan/hacks/ipod.html

For starters, it’s useful to know that the mini is little more than a small hard disk drive (with a –granted- nice design packaging); actually, a Hitachi MicroDrive
http://www.studio2f.com/misc/2004/02/25size_matters.php (but at $160 retail not a cheap source anymore ... ). That makes it a better choice than the Shuffle (which is flash memory and has limited re-write capability) as an external storage device under Knoppix. There are Mac and Windows versions of the device (I believe), with the basic difference being how it is formatted/file system. The Mac version is pre-formatted with HFS+ and the Win version with FAT32. My iPod mini was a Mac/Win version, which is pre-formatted with HFS+ (the Apple file system); it can be converted to FAT32 during iTunes installation ( I used v4.8 ) under Win, which I did, since I needed to keep XP on my machine anyway. I understand HFS+ to FAT32 conversion isn’t trivial under Linux either. After conversion, the iPod mini shows Format “Windows” under Settings>About near the bottom (also its model number etc and the software version it’s running, in my case v1.3).
Important: Win iPods have 2 partitions, the first one contains the firmware and the 2nd is the mountable one: sda2
Mac iPods have 3 partitions, partition one contains a partition map, the 2nd one the firmware, and the 3rd is mountable: sda3
Some iPods come with both Firewire and USB cables, mine just came with a USB cable, so I started again trying to talk to the mini with USB under Knoppix. BTW, before converting my mini to FAT32, I tried to mount HFS+ under Knoppix 3.4 (2.6.6 kernel) with
mount –t hfsplus /dev/sda3 /mnt/ipod
Nothing. Interestingly, it seemed to get power from the USB port, and showed the ‘do not disconnect’ message followed by the recharge icon on the iPod. So I let it get its initial charge for an hour. Then I moved on to FAT32 conversion hoping the filesystem had something to do with the mounting problem. Again nothing either with FAT32 via USB.
So I thought, a Firewire cable might do the trick- right so. There are a few other things that may or may not be intrinsic to my laptop setup, so more specifics are posted there http://www.knoppix.net/forum/viewtopic.php?t=20042 ). I understand firewire isn’t without its own problems (hotswapping etc see http://en.wikipedia.org/wiki/Firewire ), so I connected everything at the off state before rebooting my machine into Knoppix 3.4. (2.4.6. kernel) with the live CD. Note: I read somewhere it’s crucial to run the iPod in disk/manual mode - so it doesn’t try to sync and enables disk mode - so I’ve set it up that way with iTunes ( iPod Options > manually manage ... ) before booting Knoppix.
After reboot, the iPod woke up with the “do not disconnect” but no icon to see on the desktop. I figured it has to do with not being logged in as root.

So, as root (su) type:
mkdir /mnt/ipod
mount –t vfat /dev/sda2 /mnt/ipod

Voila. The pod is mounted (in a root shell launch/type konqueror) and I could see and write to the directory I had previously created. Very cool. And fast!
Here is a scary part. I read something about corrupted filesystems with inproper shutdown (a problem under HFS+ only?). Unmounting with umount /mnt/ipod worked in my case, but the iPod still shows the ‘do not disconnect’; so I decided (for now) to shut down Knoppix first before unplugging the pod - which BTW, also unmounts /dev/sda2 in the process, and makes the iPod return to the menu on the screen.

Has anyone info on safer ways disconnecting the iPod under Knoppix?? Reset? Worst case scenario, you have to restore (=reformat) the mini with the iPod Updater and loose all the data on it? I haven’t experienced any problems with the iPod, still plays music, transfers songs from iTunes etc... so far, so good.

08-27-2005, 03:35 PM
My daughter has been using an iPod mini (since Christmas, as it was her Christamas present from me) with a PC I chucked together from spares mostly just for this particular job. I formatted the iPod for use with Windows using a borrowed laptop from work and the Apple software. This seemed like a safer option that using Linux tools although I have read this has been done (I don't like risk, Windows is a fine utilty.....). I added a firewire card to the PC bought off eBay for less than £10, I had to make a couple of entries in fstab and then installed gtkpod, with a few changes to preferences, I basically had it working. Getting audio from CD is a case of using RipperX, but you need the lame encoder, not toolame (which encodes to mp2) - all in all, a good job, automount, auto backup and so far, no corruption to the iPod.

All of this was a better solution than buying Windows XP, or buying OSX upgrade for her mother's Mac..... both of which were options.

Let me know if you need more info' - most of what I managed to do was with help of other people and Google links.