View Full Version : Cannot mount LVM in Knoppix 4.0?

08-28-2005, 08:54 PM
I am trying to remaster Knoppix 4.0 down to a CD. The problem I am having is mounting the filesystem that I want to copy to. Its a LVM, ext3 in FC3. Everytime I mount it it says:

root@1[~]# mount -t ext3 -o rw /dev/hda3 /mnt/hda3
mount: wrong fs type, bad option, bad superblock on /dev/hda3,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Now if I run e2fsck:

root@1[~]# e2fsck -p /UNIONFS/dev/hda3
e2fsck: Bad magic number in super-block while trying to open /UNIONFS/dev/hda3
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

I try with the following command e2fsck -b 8193 /UNIONFS/dev/hda3 and get the exact same results.

I know the filesystem is good since this is my main linux machine and FC# boots, reads, writes to it with no issues.

Can anyone help?

08-31-2005, 02:38 AM
No love?

09-28-2005, 05:17 PM
looks like... I have the same problem over here: Tried the HOWTO of version 3.8.1, but did not help. Seems that knoppix does not have the LVM-tools (vgscan etc) installed......

What do the experts say??

09-28-2005, 06:05 PM
There is no LVM in Knoppix, but here is an LVM2-Howto which tells how you can install LVM2:


09-30-2005, 09:32 AM
Good point, thanks.

I wonder why LVM is not in by default - it is neither new nor unreliable.......