View Full Version : Knoppix 4.0 DVD HDD Install issue

09-09-2005, 12:10 PM
Hi Guys,

I am a Linux Beginner and had various installations of knoppix and kanotix on my machine before.
After a while my latest Installation did not work any more so I decided to install Knoppix 4.0 on a new 20GB Hdd.

I made a 18GB Linux and a 2GB Linux swap and Knoppix installs everything without a Problem.

On a reboot from HDD I get this:

Uncompressing Linux... Ok, booting Kernel

and then

Kernel Panic - not syncing: VFS : Unable to mount roof fs on unknown-block(3,1)

The PC is a Fujitsu 700mHz with 256 MB Ram

09-09-2005, 05:07 PM
I have excatly the same problem and cannot figure it out. I have tried all different ways and one time it did boot but could not find my ethernet connection. I am mostly using Mephis and debian and have no problems. The Knoppix live DVD works great but I cannot install it to the hard drive without the kernel painc happening. I have tried it on 2 different systems. I use sudo knoppix-installer.

09-10-2005, 05:38 PM
Boot from the CD, mount the partition that holds the Knoppix install and post the contents of the file /boot/grub/menu.lst (from the mounted partition, not otherwise). Most likely the entry in the configuration file points to the wrong partition.

09-11-2005, 04:31 PM
I had the same problem.

Try this.....It worked for me ....... I noticed that the boot sequence tried to detect my dvdrw as a hardrive and could not synchronize with it. I just changed the bios for my dvdrw to auto and removed the secondary slave hard drive.

09-12-2005, 08:52 AM
# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

# examples
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda1 ro ### isk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet vga=791

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=false

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.12 Default
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro ### isk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet vga=791
initrd /boot/initrd.img

title Debian GNU/Linux, kernel 2.6.12
root (hd0,0)
kernel /boot/vmlinuz-2.6.12 root=/dev/hda1 ro ### isk_size=100000 init=/etc/init lang=us apm=power-off nomce quiet vga=791
initrd /boot/initrd.img-2.6.12

title Debian GNU/Linux, kernel memtest86
root (hd0,0)
kernel /boot/memtest86.bin

title Debian GNU/Linux, kernel memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin


09-15-2005, 07:48 AM
I am having the exact same problem as pt-1. My menu.lst file looks identical to the one posted above.

I am trying to install Knoppix 4.0 as a VMWare Workstation 5.0 image.

PC specs are:

P4 3.4GHz HT

VMWare image is setup to use 512MB RAM, 10GB HD, and full processor power.

If anyone know how to remedy this, I would greatly appreciate it. Thanks in advance!

09-15-2005, 04:31 PM

ich habe fast die gleiche Fehlermeldung:

Kernel Panic - not syncing: VFS : Unable to mount roof fs on unknown-block(3,3)

knoppix ist auf hda3 installiert.

hier der auszug aus der menu.lst:

title Debian GNU/Linux, kernel 2.6.12 Default
root (hd0,2)
kernel /boot/vmlinuz root=/dev/hda3 ro ### isk_size=100000 init=/etc/init lang=de apm=power-off nomce quiet vga=791
initrd /boot/initrd.img

was ist denn falsch daran?

Bo 247
09-25-2005, 05:23 PM
So has any one actually found a solution to this problem yet

10-01-2005, 11:04 AM
Same problem here.

I have installed the knoppix CD to /dev/hda2
I also found that when I do the following I have no permissions to /dev :

mount /dev/hda2
chroot /mnt/hda2 /bin/bash

There is something wrong with /dev. I got a lot of messages which says it has no permission to /dev/null.
Also grub couldn't find a harddisk (also permission problem, I think) and lilo gives me also permission problems. Seems that the installer don't create the /dev directory correctly.

I have tried to link the original /dev to /mnt/hda2/dev. But that doesn't the trick. I also tried to chmod 777 en chmod root:root (as long I'm logged in as root) the whole /dev. But it wasn't a succes.

I'm also stuck... :(

10-03-2005, 07:59 AM
ich relebte auch das Problem "Kernel Panic - not syncing: VFS" mit KNOPPIX V4.0.2CD,
und eine Loesung gefunden. Habe gerade auch in einer anderen Stelle vorgestellt;


Einfach den Eintrag " ### isk_size=100000 ...usw." in /boot/grub/menu.lst umschreiben wie folgt:
"ramdisk_size=100000 ...usw."

Mir ist nicht klar, ob dieses "###" absichtlich eingesetzt wurde oder wegen eines Bugs in knoppix-installer.
Jedenfalls hat diese Loesung funktioniert, mindestens bei mir.
Ich hoffe es kann Euch helfen.

10-03-2005, 08:42 AM
Also same here, first I suspect I've a bad download, or the IDE controller problem, but I don't have such problem with the 3.9, so I think this is a bug. I think there should be a simple partitioning routine like the one on Debian, a newbie has no idea how to partition the HD, there should be a recommended system default to choose from.

10-04-2005, 01:20 PM
Boot your PC and wait until you get the Grub Menu

Then Press E on the 1st Entry
Then use arrow down to select the faulty Entry
Then press E again
Use arrow to the left until you get to the faulty entry (### ) and replace it with ramd

Press ESC

Press B to boot and be happy !!

10-04-2005, 02:04 PM
I got my Knoppix 4.0 DVD a couple of days ago. Liked it enough to contemplate a hard-disk install. (That's when my troubles started). Finally got it to work, only after a few attempts. Here are some notes, in case I need to do it again some day.

My hard disk: 80 G Western Digital, already had Windows on it (1st partition, 5G). So I tried to make it dual boot with Knoppix.

Booted up with Knoppix 4.0 DVD. Started a Konsole screen. Launch the hard-disk install with "sudo knx2hd" command.
The script complained about not finding the 8G space required for HD install. I pushed on with the Partition tool to format a 10 GB partition for Knoppix.

After partitioning was done, proceed with Configuration. Select the default Debian method (instead of Knoppix, which I tried a couple of times without success!).

Next step is Start the Installation, which took about an hour to copy all the files from DVD to hard disk.

I chose to write GRUB loader to the MBR in order to dual boot with Windows.

Finally I was able to boot from the hard disk instead of the DVD, but.. surprise, surprise

... I got Debian instead of Knoppix !

(Well , it's the next best thing , isn't it .)

My next task is to figure out how to get my cable internet to work with Debian. I could surf the Internet with Mozilla Firefox when booting from the Knoppix DVD, but not with Debian booting up from hard disk.

Win some , and lose some.


04-06-2006, 03:48 PM
i hope i can give you the solution to this problem.

it took me 5 attempts but it finally worked

when you boot from dvd, instead of just hitting enter at the BOOT: prompt, type "knoppix lang=us"

then do the hd install as you normally would

i have no idea why it causes a problem to install to hd when you select no options at the BOOT: prompt but there you go

i hope this helps, it worked for me

laters ;-)

05-13-2006, 03:48 AM

I just tried my new KNOPPIX 5.0 DVD, and I get the "Kernel Panic" message with any boot option I choose. I'm a newbie with Linux, and I don't know much about editing linux config files. I just wanted to try it as a live DVD, but it didn't work. I tried with boot option, and same thing happened. I also got "ran out of input data -- system halted" for m23 option, and "Invalid or corrupt kernel image" for memtest. I didn't even installed it yet. Could somebody help me with this issue?

Harry Kuhman
05-13-2006, 04:50 AM
I didn't even installed it yet.
You don't install it. It's a Live CD. See answer #2 (http://www.knoppix.net/wiki/User:Harry_Kuhman) for more details on this.

Sounds like you either have a bad image or typed in something wrong (more likely the former). testcd is normally the cheat code that is used to test the CD. memtest loads a copy of memtest86 and checks your system memory, but I guess if the disc is really bad then it might not be able to load memtest.

05-13-2006, 02:42 PM
Well, I know it is a live version. I just meant that as opposed to the main topic, my issue doesn't concern an HDD install.

My first attempt was to press enter without any option after the "boot: " prompt.
Then, after the restart, I pressed F3 to get the boot options. I tried failsafe, expert, knoppix with and without options.

I suppose the "Invalid or corrupt kernel image" message at memtest says it all. testcd is not a valid entry; I just tried it.[/i]

05-13-2006, 02:56 PM
testcd is not a valid entry; I just tried it.

You need to use knoppix testcd

05-13-2006, 09:52 PM
Unfortunately, that makes no difference ... I get the same message at the end.

Harry Kuhman
05-13-2006, 10:07 PM
Unfortunately, that makes no difference ... I get the same message at the end.
I have never heard of knoppix testcd giving "not a valid entry", but I have to think that either knoppix is typed wrong or the CD is indeed bad. Was knoppix in lower case? (case matters in Linux). testcd should be in lower case too, but AFAIK you would not get any error if it was typed wrong, invalid parameters should just be ignored. If you are using lower case, can confirn that you are typing the proper string, and using a language compatable keyboard, then I don't see how it could not be a bad CD.

05-14-2006, 12:34 AM
No no no! I got "not a valid entry" when I typed "testcd" alone, not when I typed "knoppix testcd". The first time I just didn't understand I had to put "knoppix" before "testcd". THEN I got the "kernel panic" message again. Thanks anyway for your concern ;)

Well, I do think it's a bad DVD. I'll try to get a new copy.

Harry Kuhman
05-14-2006, 01:00 AM
The first thing on the line has to be a program to be loaded. The rest of the line is parameters to pass to whatever was first on the line. To run testcd you need to say knoppix testcd because you load the Knoppix kernel and then you instruct it to run testcd. memtest does not need (or use) anything before it because memtest loads the memtest86 code and runs it independently of Linux. Some versions of Knoppix included both the Linux 2.4 kernel and the 2.6 kernel. To run the 2.4 kernel you would type knoppix or just hit return and take the default, to run the 2.6 kernel you would type knoppix26, which loaded the 2.6 Linux kernel instead of the 2.4 Linux kernel.

Why you are getting a kernel panic when loading knoppix I do not know, but that makes more sense than getting "not a valid entry", which should only happen if you try to load something that isn't on the disc.