PDA

View Full Version : Kernel panic - not syncing: VFS: Unable to mount root fs on



phillb
09-29-2005, 12:35 AM
The rest of the message is
on unknown-block(3,1)

I get the message when I install 4.0.0 or 4.0.2 to my HDD (/dev/hda1) the only system on the laptop.
It of course won't boot. I do not get this message with an older version like 3.9.
My machine is a Dell C610 laptop with a 20gb disk and 256mb of memory with a DVD reader.
I saw the other topic entry and it seems that there was no answer to the dilema.

Any ideas?!

I have the 4.0.0 version running and booting fine on a desktop machine, so I'm stumped!

Thanks all!

phillb
09-30-2005, 10:22 PM
Tried the 4.0.2 CD and it does the same ????? thing!
I even tried putting the grub boot in the partition vs the MBR.
However, 3.9 CD Hard Drive Install works on the same machine on the same disk.

Now I'm even more stumped!

djugem
10-03-2005, 04:07 AM
Hi, phillib

I experienced the same problem when I installed KNOPPIX V4.0.2 (CD) to my HDD
with the script "knoppix-installer". I chose "KNOPPIX CD Style".

Soon, I found a problem in /boot/grub/menu.lst. Please, boot yourPC fromCD again,
and look into this file. You will find lines just like these;

title Debian GNU/Linux, kernel 2.6.11 Default
root (hd0,5)
kernel /boot/vmlinuz root=/dev/hda6 ro ##amdisk_size=100000 init=/etc/init apm=power-off nomce quiet vga=791
initrd /boot/initrd.img
savedefault
boot

You can edit the 2nd line as follows (similar to the former KNOPPIX versions) ;
kernel /boot/vmlinuz root=/dev/hda6 ro ramdisk_size=100000 init=/etc/init apm=power-off nomce quiet vga=791

Save your changing and reboot your PC. That all.
Good luck ("Viel Glueck" in German)

lotech
10-03-2005, 03:19 PM
I have the same problem, but I can not write to the file because it is mounted read only, and I can't change the fstab, how do I mount the disk as read write ?
My menu.lst shows ## isk..... not ##amdisk....... I think I have a bad download or bad burn.

N!co
10-03-2005, 08:36 PM
Same problem here on the laptop. You can also edit the boot options in Grub. And after the first boot edit the menu.lst.

lotech
10-04-2005, 09:45 AM
But I can not write to the file.

muzica
10-04-2005, 12:41 PM
Thanks djugem, that work for me.

lotech, try :

sudo mount -o dev,rw /mnt/hda2
or
sudo mount -o remount,dev,rw /mnt/hda2

pt-1
10-04-2005, 12:52 PM
OK You are the man !!

Boot your PC and wait until you get the Grub Menu

Then Press E on the 1st Entry
Then use arrow down to select the faulty Entry
Then press E again
Use arrow to the left until you get to the faulty entry (### ) and replace it with ramd

Press ESC

Press B to boot and be happy !!

lotech
10-04-2005, 01:45 PM
Yes PT-1 I just find out that, and after a successful boot up, we must edit the file so that it will boot up normally next time, but this remain mystery that we have to do this after 1st install, this has to be fixed on next release.

pt-1
10-04-2005, 02:29 PM
I am just struggeling after succesfully booting the setting is back as described above.

After making the first change

Start a Terminal session

type su

type passwd

choose a new password

I choose root

then click on the K
Choose System
More Applications
File Manager Super User Mode
Use your new password
Change the file /boot/grub/menu.lst and save

phillb
10-05-2005, 11:47 AM
Thanks for all the insites.
It's good to see the system working (this one).
I'll give file an edit tonight (when I get home).
I do remember looking at the menu.lst file and I believe the ### is there; so maybe problem solved!

Thanks ALL!

phillb
10-05-2005, 10:15 PM
IT worked.....
You can edit the /boot/grub/menu.lst file right after the install is finished to eliminate the ###s.
You must set the properties of /dev/hda1 to read/write and the device to read/write also then mount it.
Then you can edit the file, save it and 'viola... IT BOOTS!

Many thanks again!

djugem
10-11-2005, 09:39 AM
Hi,
we, Japanese KNOPPIX user gourp (http://www.freeml.com/archive/knoppix@freeml.com), have
finally found out why this disturbance in the option line in /boot/grub/menu.lst was caused.
The installation script "knoppix-installer" has nothing to do with this error.

This error happens simply because the /proc/cmdline will be disturbed if you boot your KNOPPIX CD
4.0.2 WITHOUT ANY BOOT OPTION. After the booting, you can execute the following command:

$ cat /proc/cmdline
### isk_size=100000 init=/etc/init lang=us apm=power-off vga=791 initrd=minirt.gz nomce quiet BOOT_IMAGE=knoppix BOOT_IMAGE=linux

If you execute "knoppix-installer" under this situation, this error will be put into the /boot/grub/menu.lst.
However, this error will NOT HAPPEN if you boot your KNOPPIX CD WITH AN OPTION, e.g;
boot: knoppix
boot: knoppix 2
boot: fb1024x768
etc.

So, we strongly recommend you TO BOOT KNOPPIX 4.0.2 CD WITH AN OPTION, e.g. "boot: knoppix" if you
plan to install it to your HDD with the "knoppix-installer" script.

One member of us also has identified the cause of the disturbance in /proc/cmdline.
It was syslinux.bin from the package "syslinux 2.11-0.1". He has experimentally made a knoppix4.0.2 iso
image after he exchanged this file with a old syslinux.bin from "syslinux-knoppix 2.04-1".
He could check out that the error in /proc/cmdline did not happen when he booted the modified 4.0.2 CD.

The condlusion: This error of the HDD installation probably happens due to a problem in syslinux.
We hope sombody will fix this problem soon.

Thank you

djugem
10-13-2005, 02:07 AM
Sorry, there is a mistake in the preceding mail;


One member of us also has identified the cause of the disturbance in /proc/cmdline.
It was syslinux.bin from the package "syslinux 2.11-0.1". He has experimentally made a knoppix4.0.2 iso
image after he exchanged this file with a old syslinux.bin from "syslinux-knoppix 2.04-1".
He could check out that the error in /proc/cmdline did not happen when he booted the modified 4.0.2 CD.

"syslinux.bin" was a wrong file name. "isolinux.bin" is a correct one. So, I write once more:

One member of us also has identified the cause of the disturbance in /proc/cmdline.
It was isolinux.bin from the package "syslinux 2.11-0.1". He has experimentally made a modified
knoppix4.0.2 iso image after he replaced this file with an old isolinux.bin from "syslinux-knoppix 2.04-1".
He assured himself that the error in /proc/cmdline did not occur when he booted from his modified 4.0.2 CD.

I apologize for my mistake. :oops:

lp
12-09-2005, 08:46 AM
i have followed all the directions and when the system finally comes up there is a grub prompt
i am 100% new at this

whats next?

and thanks very much for the info that has gotten me this far

lp

SimonomiS
05-15-2006, 07:25 AM
Bumping this because I'm getting the same error and I'm clueless. Simple instructions anyone?

SimonomiS
05-22-2006, 03:40 PM
Bumping this because I'm getting the same error and I'm clueless. Simple instructions anyone?

Help someone?

Is there anyway I can just wipe my HD and start anew?

malaire
05-23-2006, 12:04 PM
Is there anyway I can just wipe my HD and start anew?

If you really want to wipe the HD, it's easy to do.

Quick way to do that is (Replace /dev/hda with something else if your HD isn't hda)


sudo dd if=/dev/zero of=/dev/hda bs=512 count=1

That will overwrite first sector of HD, which should be enough, as it will overwrite partition-table.
To wipe-out all data from whole HD you can use


sudo dd if=/dev/zero of=/dev/hda bs=1M

SimonomiS
05-25-2006, 12:43 PM
Hmm, but I can't even get that far.

It gets to the boot promt, any booting command gives me the not syncing; VFS etc error, and for other commands it gives me "kernel image sudo (or whatever it I try) not found".

malaire
05-25-2006, 05:52 PM
Hmm, but I can't even get that far.

It gets to the boot promt, any booting command gives me the not syncing; VFS etc error, and for other commands it gives me "kernel image sudo (or whatever it I try) not found".

Sorry, I didn't realize you were unable to boot at all. That command I gave can only be used in konsole, after a successfull boot.

SimonomiS
05-25-2006, 11:34 PM
Hmm, but I can't even get that far.

It gets to the boot promt, any booting command gives me the not syncing; VFS etc error, and for other commands it gives me "kernel image sudo (or whatever it I try) not found".

Sorry, I didn't realize you were unable to boot at all. That command I gave can only be used in konsole, after a successfull boot.

Ah ok. Is there any emergency command that can rewrite the HD? Or another program that can do that? (I read Grub somewhere in this thread). If I can get over this, I think I'll choose something other than Knoppix as a HD based Linux distro heh.

TheRoach
08-27-2006, 09:52 AM
OK You are the man !!

Boot your PC and wait until you get the Grub Menu

Then Press E on the 1st Entry
Then use arrow down to select the faulty Entry
Then press E again
Use arrow to the left until you get to the faulty entry (### ) and replace it with ramd

Press ESC

Press B to boot and be happy !!


I've gotten that far, how do you save your settings once you've edited ### isk to ramdisk?

Jonah
05-21-2009, 01:51 AM
Ok, I have Adriane Knoppix 6 installed to my second SCSI drive. I got the same error when appending the Adriane to the /boot/grub/menu.lst which was already working for me.

This is the menu.lst generated by 0wn..


default 0
timeout 30
color cyan/blue white/blue

title KNOPPIX
root (hd2,1)
kernel /boot/vmlinuz root=/dev/sdb2 lang=us keyboard=dvorak apm=power-off vga=791 nomce loglevel=0 quiet lang=us keyboard=dvorak rw

title Windows
rootnoverify (hd0,1)
chainloader +1

This is the /boot/grub/menu.lst generated by TeenPup Linux and with the 0wn generated entry for Adriane appended.

And highlighted.



# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Sun May 17 02:59:55 2009
#
# Start GRUB global section
#timeout 30
color light-gray/blue black/light-gray
# End GRUB global section
# Linux bootable partition config begins
title Linux (on /dev/sda1)
root (hd1,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal
# Linux bootable partition config ends
# Other bootable partition config begins
title Windows (on /dev/hda2)
map (hd0,0) (hd0,1)
map (hd0,1) (hd0,0)
rootnoverify (hd0,1)
makeactive
chainloader +1
# Other bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/hda3)
root (hd0,2)
kernel /boot/vmlinuz root=/dev/hda3 ro vga=normal
# Linux bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/sdb2)
root (hd2,1)
kernel /boot/vmlinuz root=/dev/sdb2 ro vga=normal
# Linux bootable partition config ends
title Install GRUB to floppy disk (on /dev/fd0)
pause Insert a formatted floppy disk and press enter.
root (hd0,2)
setup (fd0)
pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/hda3)
root (hd0,2)
setup (hd0,2)
pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)

This is the boot message I get when booting either variant...


"[ 0.499891] dca service started, version 1.4
[ 0.558761] pci 000:01:00.0: BAR 6: Can't allocate mem resource [0xfe000000-0xfdffffff]
[ 0.572854] alg: cipher : Test 1 failed on encryption for aes-asm
[ 3.319802] IO APIC resources could not be allocated.
[ 4.044099] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

First partition is Knoppix 5.1

Second is M$ Windoze 2000

Third is Puppy Linux.

/sda1 is Freespire

All of them boot OK.

Jonah
05-22-2009, 08:01 AM
SCHEISSE...

I declined to install grub... this last time...

and installed Grub from Puppy linux.

Didn't have the "quiet" option.

SCSI.

At the last part, hundreds of lines of error messages... finally it comes to that.

(hd2,0) is a SCSI drive.

If I recall correctly there's a cheat-code to force recognition of SCSI.

It listed available partitions to boot, but all on IDE.