View Full Version : After Booting and loading my screen goes Nuts

10-01-2005, 02:50 AM
I am new to linux and am running the Knoppix 3.8 Live Cd well it starts off by giving me a (You passed undefined mode number....press enter to see video modes available, space to continue) after it boots I don't do anything so it continues to boot. seems to be doing well until it gets to the starting X11 and flashes on a few times and then goes to a strange screen that looks like a tv with no reception all scrabbly........u can tell the screen changes a few times but it is still really scrabbled and that is where it sits. The video card is 82810 CGC (Chipset Graphics Controller) It has windows ME. Could someone please tell me what I have done wrong and how to possibly fix this problem.......I know it is probably a simple fix and Ill feel really dumb but I am just stumped. I looked and looked to find the answer but didnt. Any help would be appreciated.

*Cheryle* :cry:

10-01-2005, 03:00 AM
Welcome to Knoppix.net
First, did you follow the download & verification & burning instructions at http://www.knoppix.net/wiki/Downloading_FAQ ?
When there are problems with Knoppix, we begin with the physical CD itself. The FAQ has some real must reads tips & suggestions that will help you make sure you have downloaded and burned a good working Knoppix CD.

On the video problems:
The "You passed undefined mode number" error. You can ignore it. It is annoying but not dangerous or bad for the PC.

As for the rest of video, it sounds like knoppix is doing the best it can at autodetecting the video hardware (perhaps getting it wrong) & then setting a resolution & refresh rate that is beyond the capabilities of the hardware. Try booting knoppix with some Cheat Codes (http://www.knoppix.net/wiki/Cheat_Codes), such as:
knoppix screen=800x600 xvrefresh=60
knoppix screen=640x480 xvrefresh=60

I hope this helps.

Harry Kuhman
10-01-2005, 03:09 AM

10-01-2005, 03:25 AM
I chose to put it here because I thought it was the best place for it but obviously not. I thought it would go here because it wasn't Booting and I thought it was a hardware problem with the video card......sorry

10-01-2005, 03:35 AM
I followed the download instructions and also used the cheats......it is still doing the same thing is there any other ideas u may have?

Harry Kuhman
10-01-2005, 04:04 AM
I chose to put it here because
Look at the subject line I used! My post had nothing to do with where you chose to post.

10-01-2005, 04:18 AM
I thought u were pointing out that it was put in the wrong forum......please accept my apolizes for misunderstanding........I have redownloaded and re burned at 4x and am still having the same problems. After reburning I used the cheat commands. It is still giving the same result. From what I have found and read I don't think it is a compatibility problem with windows ME. Is there a problem with my video card that is prohibiting me from running the Knoppix? I am totally stumped and am open to any suggestions.

Harry Kuhman
10-01-2005, 05:00 AM
You have told us about your video controler (one I had not heard of so I'm not clear on how well it is supported by Knoppix, hopefully someone else knows). It very likely may help to give us the make and model of your video monitor. And, if you know the specs, what frequency ranges it supports and what resolutions it supports at those frequencies. It could well be that the video system is trying to operate at frequency ranges beyond what your monitor will support. See the cheat codes for parameters that you can use to try to establish a resolution and frequency range that will work with both your monitor and video card.

10-01-2005, 05:25 AM
The video card is 82810 CGC (Chipset Graphics Controller)
Welcome to Knoppix.

I quickly searched the forums for "82810" and got a bunch of hits. Unfortunately, there are a lot of questions and some suggestions of things to try, but no one seems to have found a solution. Or if they did find a working solution they did not bother to report back what worked.

For your case, let's try the quick-and-dirty -- try booting with this:

boot: knoppix xmodule=i810

If you also want avoid the "undefined mode number", you can add a vga= cheatcode:

boot: knoppix vga=0 xmodule=i810

Please let us know if that works. If not, we can then try a few other cheatcodes (http://www.knoppix.net/wiki/Cheat_Codes).

- Robert

10-01-2005, 05:56 AM
what I am getting now is where the screen would have been going nuts.....instead it goes back to the start screen where it is loading everything is has
starting X11.....
Retrying with Server XFree86(vesa)
Retrying with Server XFree86(fbdev)
Error: No suitable X-Server found for your card.

I think I kinda get the jiff of what that may mean so I take it I am just out of Luck?

10-01-2005, 01:58 PM
I think I kinda get the jiff of what that may mean so I take it I am just out of Luck?
Not yet. I'm not that familiar with how the video portion of Knoppix works. But as far as I can tell from reading the code Knoppix is guessing what kind of card you have, trying it out, realizing it doesn't work, and then guessing again. Knoppix appears to try this three times and then stops.

Some options you have:
1) boot using expert mode:

boot: expert

2) boot into text mode and then run xf86cfg:

boot: knoppix vga=0 3

xf86cfg -textmode -xf86config /etc/X11/XF86Config-4 > /dev/console 2>&1 </dev/console
That last line was lifted out of /etc/init.d/knoppix-autoconfig

Let us know how it goes.

- Robert

10-02-2005, 03:52 AM
It still didnt work so I am thinking about just giving up on it until I can get a new video card maybe..........Thanx but if u do think of anything else please let me know :)