View Full Version : nForce4/Athlon X2 - Network craps out after a few minutes

10-04-2005, 07:37 PM
System info:
ABIT AN8 Ultra (NVIDIA nForce4 Ultra chipset) with built-in gigabit Ethernet (uses forcedeth driver)
Athlon X2 3800+ Dual-core CPU
2GB RAM (2 x 1GB PC3200)

I've tried Knoppix 3.9 and 4.0.2CD with the same results. Everything works fine for a few minutes, but then (usually during heavy network activity; in my case, attempting to check out a large CVS repository), the network dies and I am unable to connect to any host. Trying ifdown/ifup on eth0 doesn't fix it (I get an uninformative "failed" error message when I try). In fact, rebooting the system doesn't fix it. I actually have to turn it off at the power supply and then turn it back on before the network will work again.

I've run for days at a time under Fedora Core 4, so I don't think it's an incompatibility with Linux or the forcedeth driver. Also, if I run Knoppix in single-user mode, the network seems to work indefinitely (I was able to get my CVS repo that way after it failed four times under the GUI).

Any ideas how to track down what's killing my network?