View Full Version : unable to boot knoppix from external ieee 1394 dvd/cd-rw drv

10-05-2005, 08:43 AM
I have a travelmate 3000 series laptop. I have tried to use a variety of live cd's to boot it but all fail. The issue I think is related to the external firewire drive. It seems to be unable to find the drive after boot. I have tried to run knoppix with the failsafe option and it ends with "can't find knoppix filesystem". The display is a little unique in that it is optimized for 1280x800 but I doubt that is the issue. It can boot other wise I would not get the knoppix boot screen however it can not go any further or not much further. I tried running in "expert" mode but the screen goes blank soon after the intial kernel attempts to load just like when I try to use the failsafe option.

any ideas?

10-07-2005, 07:08 AM
any ideas?
I have a ton of ideas. The first thing we need to do is verify that your files and discs are good. that does NOT mean that they seem to work in some other system, It DOES mean that you need to follow some guidelines to help ensure success. It may sound like some extra work, but if you did not downoad via BitTorrent, you need to check the MD5Sums of your files. It is a good idea even if you did use BitTorrent. You need to burn the discs at a slow speed. THAT fact has been proven time and again to be a solution for many boot issues. I just can't believe how someone who spent the time to download a DVD sized file will not take a few extra minutes and burn the disc slowly. Just because a drive and media are rated for 16X, does not mean it will be the best solution. The best drive compatibility is from burning at SLOW speeds, PERIOD. You also need to use media that is compatible with your drive. Look at the downloading FAQs located here: http://www.knoppix.net/wiki/Downloading_FAQ Look over the procedure and realize that there may be no shortcuts to success. Some media has been known to cause readability or burn issues with certain drives. Check the drive manufacturers site for compatible media and go with their recommendations. Check for a firmware update also.

One other thing that has come up on occasion. If you have a Plextor 740 or Benq 1640 series drive, they seem to need the "Knoppix DMA" cheatcode to enable DMA required for these drives to function properly. DMA is OFF by default on the later versions of Knoppix. Look at the section on Cheatcodes here: http://www.knoppix.net/wiki/Cheat_Codes
I'm not sure how one of these drives on a 1394 connection would act regarding the DMA issue, but it's worth a shot.

Please post back and let us know how you make out.

10-08-2005, 04:09 AM
well I am sure my media is good because I have used it on other machines sucessfully. In fact at present just so that I could prove it would even run on this laptop I installed vmware and booted the knoppix disk within that environment and it work beautifully. The laptop screen is wide compared to most and the resolution is really only any good at 1280x800 which is sort of a shift from the norm. Here is a link to info on this model if it helps: http://tinyurl.com/bl3cv

The drive is just listed as an Acer combo drive.

So, excellent link for cheat codes thanks!

Anyway, I had tried to use the nodma option before but it failed. I tried failsafe but it failed also. I tried to enter the path for my cdrom but that didn't work either...

I now just tried boot: knoppix vga=0 and it also failed, the screen just hung.

however, trying the boot: knoppix acpi=off pnpbios=off noapic noapm takes me the furthest, it hangs after starting to probe for agp modules. If I hit enter I am returned a command prompt. Trying startx results in knoppix loading which is excellent. I have further to go but it is good to know it almost works..... I really want to end up with a dual boot if possible.


10-08-2005, 08:01 AM
well I am sure my media is good because I have used it on other machines sucessfully
This is usually a meaningless test. I have had discs that work in many systems fail in another because of a compatibility issue. It may not be a "Bad" disc, but one that cannot be read well by the drive. Have you tried the "testcd" option on bootup? It may reveal a read or media issue if it fails. Your drive is listed to be compatible with most CD media and with BOTH DVD-R and +R, but it may actually not be at all. I have a Sony Laptop with a QSI combo drive that will NOT boot from -R media of any type, that work flawlessly in other systems. It will boot from most +R media without a hitch. The drive is listed to support both formats and reports the same in hardware inspection programs I have used. It also dislikes certain CDs of two specific manufacturers. I think it relates to the dye color/type, since the problem discs appear to be of similar dye type and color. I would try to eliminate the Media/Burn methods as a possibility, since it often results in symptoms such as those that you report.

I believe I suggested that you try the "Knoppix dma" cheatcode, not the "Knoppix nodma" cheatcode since DMA is OFF by default in the later versions of Knoppix. Using the "Knoppix nodma" is redundant and just ensures that it IS turned OFF. You certainly want to try with it ON and not OFF! You mentioned trying the "Knoppix nodma" cheatcode in your reply.

Since it works well for you in VMWare, it may be something other than media or DMA settings. Since it is an external firewire drive, it could be something about the way that Knoppix loads it's 1394 support. It could be that Linux might NOT be compatible with the embedded controller in the Laptop. Running in VMWare under Windows may eliminate the issue allowing the disc to be read properly while using the 1394 support from Windows instead of Linux. Since you have stated that you have tried several other Live CDs with no happiness and joy, it would lead me to believe that it could be the issue. I just don't have much experience with troubleshooting IEEE1394 in a Live Distro since it rarely, if ever, causes me any trouble. I just have not had the need to boot from an external 1394 drive often. It appears that you might not have much choice since it is the way the unit is supplied. My usual experience with 1394 in Linux is that it usually works, or it doesn't at all. I have not yet encountered a situation where it did work, but not well. That certainly does not mean that it is not possible.

The fact that Knoppix works under Windows VMWare simply could appear to show that the issue may have been eliminated by Windows' settings and support for your hardware to the extent that it can while running under VMWare.

You should continue to experiment with the various cheatcodes, especially those relating to video like "noagp" or also trying to load a specific video driver that corresponds to your system. I have had numerous issues with Intel Imbedded Graphics, although I have not yet tried to use the one listed for your system. The same comments I made previously about 1394 support in VMWare could also apply to the Graphics Controller. Also, If you are using an older version of Knoppix, you might want to try the latest. If you are using the latest, you might want to try an older version. I would assume that since the hardware is fairly new and current, that the later versions would probably have better support for it than the older versions. It could be that support is not yet there for it in Linux.

It might be a good idea to list what Version of Knoppix you are working with and what type of media you are using also (Manufacturer, CD-R, CD-RW, DVD+R, DVD-R, etc.). If you can, try to list the IEEE1394 Controller chipset/type if you can see it properly in the Windows Hardware Device Manager. I would hope that someone might be able to put a spotlight on the issue for you and see if it could be the 1394 controller, video configuration, or offer another suggestion in order to pinpoint the problem. It may very well be that there are multiple issues that you have encountered.

I really want to end up with a dual boot if possible.
One BIG issue here. Knoppix is intended to be a LIVE Linux Distro AND it is NOT intended for HDD installation. A much better idea would be to look for an appropriate distro that is intended for HDD install, like Debian or one of it's derivatives such as Kanotix. All you need to do is look/search through the posts and see how many issues there are concerning the HDD installation of Knoppix, to decide it is problematic and not a good idea. ESPECIALLY IF this is your primary system! Look in the "Hdd Install / Debian / Apt" category of this forum. Make sure you back it up FIRST and have all of the recovery discs/tools/info available. If you want to experiment, an inexpensive used/new PC can be had for very little money, and can be wiped clean and redone at will without risking your primary systems integrity. I do just that myself and have learned that lesson from experience. I have multiple PCs set up and running, using a KVM to switch between them, or they are off by themselves with dedicated peripherals. When I mess one up, it gets wiped clean and redone in the flavor of the week and I don't have issues with losing something I needed, or blowing up my primary system. (I have so many running now, I really don't have a primary system anymore and I keep redundant backups of the important stuff just in case, anyway.)

Another area to look/search through might be the "Laptops" section of this forum. There is a lot pertaining to specific issues with Laptops that do not seem to appear with other hardware.

If you do get it resolved, please post your solution so it may help others in the future.