View Full Version : How can I get sl-modem to work in knoppix 4.0.2?

10-08-2005, 09:27 AM
I installed knoppix 4.0.2 and tried to setup my smart link modem to work. I install 2 packages; sl-modem-source and sl-modem demon. But do not know how to generate the driver from sl-modem-source. Can someone help?

In Kanotix there is a prebuilt driver but for kernel 2.6.11 not 2.6.12. Is there any prebuilt drivers for Knoppix 4.0.2?

10-08-2005, 11:44 AM
Is this Smart Link modem? http://www.smlink.com/content.aspx?id=132

The file contains the installation instructions. Installation instruction can be viewed also http://www.smlink.com/objects/Linux_instruction.txt

10-09-2005, 08:22 AM
Thanks. I had this package did the following:
make install

but the drivers are installed in /lib/modules/2.6.12-386 and not in /lib/modules/2.6.12. So I copied them to /lib/modules/2.6.12/extra and did:
depmod -a
I tried to modprobe them and got the following:
root@box:/usr/src/modules/sl-modem/drivers# modprobe slamr
FATAL: Error inserting slamr (/lib/modules/2.6.12/extra/slamr.ko): Invalid module format

I think this because the linux-headers package is for 2.6.12-386 and the kernel come with knoppix 4 is 2.6.12. I could not locate the kernel headers for 2.6.12. Do you know where to find it?

10-10-2005, 04:42 PM
You might want to try Kanotix (Knoppix based)... The SLmodem support is built-in and just needs a simple script command to start. MEPIS is even easier -- the modem is already configured when you start it up.

10-11-2005, 08:45 AM
Thanks alot Jone C. I have tried Kanotix and it does as you said. However, I am doing a remaster of knoppix 4.0.2 and trying to have sl-modem to work as a default modem exactly as in Kanotix. I have installed linux-source-2.6.12 package and compiled it. Then I did the following at the top of the folder /usr/src/linux-2.6.12:
make-kpkg modules-image
and got the following package:

I installed it and it did work. I connected to the internet. But, after rebooting my PC, the sl-modem-deamon dies imeadiatly. I tried to retart it several times. It retsarts but dies again. I checked the /dev/modem and /dev/ttySL0 links. Both are there but not linked to any other device. I hope some one can help here.