View Full Version : Knoppix 4.0.2 won't boot completely

10-11-2005, 02:12 AM

I've downloaded the latest Live-CD version of knoppix (4.0.2), burned it as an image
(slowly) on a CD, but when I try to boot from it, it shows the boot screen, and
right after the first penguin appears in the upper left corner of the screen, it freezes.
The CD-ROM stops spinning and it won't continue with the boot.
I've tried burning on other CDs - still nothing.
I've tried booting with knoppix 3.8 - no problems there.

I should download only the big file (700+ MB) and burn it as an image, right??
Please help me... :roll:

Harry Kuhman
10-11-2005, 02:26 AM
I should download only the big file (700+ MB) and burn it as an image, right??
No. You should download the ISO and at least the md5 file. (You will get this and several others if you use BitTorrent.) You should confirm the download with the md5 checksum before burning the ISO, particularly if you used a mirror rather than BitTorrent, since it is well know that the mirrors frequently deliver corrupted downloads (BitTorrent doesn't). You can still go back and get the md5 checksum to determine if you have a good download or not. Details are in the downloading faq, which you can find by following the documentation link near the top of this page.

Harry Kuhman
10-11-2005, 02:36 AM
By the way, if the ISO is 700meg + then it is absolutely corrupt. The actual 4.0.2 ISO is 694 megs.

10-12-2005, 05:58 PM
So I've downloaded the "official" release over the Bittorrent, checked the MD5 file successfully,
burned again (as an image), but still it freezes exactly where it did before. What am I doing wrong ??

10-13-2005, 09:09 AM
but still it freezes exactly where it did before. What am I doing wrong ??
One other piece of advice about burning your disc. Be absolutely sure that you burn the disc at a SLOW speed. It is IMPERATIVE that you do so. I see that you said you did in your first post, but I just had to mention it anyway.

You have not provided ANY information about your system. What type/brand of drive are you using? Is it ATA, SATA, SCSI, Tin cans and a string? What CPU, How much memory? What Graphics adaptor? ETC, ETC, ETC! It is difficult to diagnose something that remains unidentified, since some specific hardware may have unique issues with Knoppix/Linux.

A quick guess could be that you are having some difficulty reading the disc, or some hardware configuration issue. Here is a link to some information that could help you. : http://www.knoppix.net/wiki/Cheat_Codes

One cheatcode that has proven effective with some CD/DVD drives is "Knoppix dma". Some drives require DMA to be enabled for them to read/write correctly. Two of note are the Benq 16XX Series and Plextor 740 series. They are far from the ONLY drives that are so affected, but have been problematic. If the dma cheatcode works for you, be sure to look out for other issues related to drive access on ALL drives in the system. DMA has been disabled by default on later versions of Knoppix, but used to be enabled in the earlier versions. I am not sure which version this change was made for, but it may be around Version 3.8, so it could very well explain why 3.8 works and 4.0.2 fails to completely boot. The cheatcode just re-enables DMA. I'm sure that there were enough issues with it being turned on to cause it to be defaulted to off. That is why I advise you to look for other issues with it re-enabled.

Let us know how you make out and if you need further assistance.

Good Luck!

10-17-2005, 07:49 PM
O.K, so I've tried several times to boot with the cheat code you told me - dma,
BUT STILL NOTHING.... It always keeps freezing in the same spot....
Maybe something else??

P.S: This is my system:

Intel P4 2.8Gh
1024MB RAM
Windows XP SP2

10-18-2005, 06:08 AM
Maybe something else??
I would start to experiment with different cheatcodes. You appear to have SATA drives and if the optical drive is also SATA, it could possibly cause some issues. Not too certain of that since I have only hearsay to guide me there. I somehow feel the need to be careful not to say anything without disclaimers since the Gods appear restless these days and possibly in dire need to make the switch to decaf. I would try to load the specific NV drivers at startup (xmodule=nv), also try noapic, nodhcp, noswap, noagp, toram since the cd will apparently fit in your 1G RAM, and so on. Just follow the conventions detailed in the cheatcode documentation and have at it. Make note of any error mesages, or displayed text on the screen at the time it locks up. I would also be sure to give it ample time to complete the boot. If it goes for a half hour, I would assume it's long enough and it actually is locked up. I can't tell you to check your drive cables and jumper settings, since it could cause certain people to have a rash, but if you wanted to, you could just double check. I also shouldn't suggest that you might try a "known good" drive cable for your optical drive. There was one individual recently with some hard drive issues that resolved his concern by swapping out the cable. If you disconnect and reconnect the cables on occasion, it might be good advice, but certainly not if it comes from my direction. I also will not mention to check your system/cpu clock speeds and memory settings to see if they are not too aggressive.

I apologize for the cryptic references I have made here about not making recommendations, etc. The environment has apparently become toxic for me in this forum at the moment. Please let us know how you make out. If you don't get it resolved, please post here again so someone might be able to assist you further.