View Full Version : Knoppix 4.0 freezes during boot process when detecting wlan

10-12-2005, 11:06 AM
I have a problem with an FS Amilo Notebook and a RT2500 wireless adapter (built-in). The system freezes during boot when recognising eth1 (DHCP).

I have read somewhere also that Knoppix 4.0 does not work with that configuration at all.

It was recommended that the last version working was Knoppix 3.9. With my Notebook, however, the WLan adapter is recognised and the system boots properly - but the touchpad does not work with that version.

So it seems to me (the last version I used successfully on a desktopp was 3.1) that KNOPPIX is reaching its limits. Itīs sad, but
it seems to be the case. It was a good idea, but without appropriate support for modern hardware its quite useless.


10-14-2005, 12:05 AM
I have an Averatec 3250 notebook and have the exact same problem. 3.8.1 thru 4.0.1 run with a cheat code or two. 4.0.2 hangs when it gets to the Wireless ethernet. Is there any way, a cheatcode maybe, to skip the wireless?

10-14-2005, 12:35 AM
You could try cheatcode nodhcp to bypass dhcp for the wlan card. It worked for my system and the system booted properly. But you should not try to configure your wlan afterwards ... then it will crash as before. Itīs really sad, that such an interesting system like KNOPPIX canīt cope with common things like wlan - on the other hand a one man show such as knoppper cant provide all this support.

I try now Suse 9.3 for wlan support. It looks promising.


12-19-2005, 11:22 PM
I also have FS Amilo A and have the same problem. I can boot knoppix (4.0.2) with 'nodhcp' cheat code but I cannot make it working after that (when it boots, eg. like here: http://www.knoppix.net/forum/viewtopic.php?t=22260&highlight=ralink+unknown+device+2450 and here: http://www.knoppix.net/forum/viewtopic.php?t=21670&highlight=ralink+unknown+device+2450) I tried the solution that "ggeller" tells about but it doesnt work on my laptop. It hangs for ever... :cry:

If you find any solution of this problem, please let me know.

12-26-2005, 06:34 PM
I would like to preface this post with this, I am no expert, I have minimal unix/linux training, however I have been working with Linux since 1999. I was a hardware technician for a small company, I took donated 386, 486, and low-end pentiums (Never faster than 450mhz, and that was a prize at the time). I tried many distributions, however on the type of systems I was working on, Debian was the only solution (Potato at the time, the machines were minimalist) to get a nice graphical desktop with web browser and other important things. My first experience with Linux period was with RedHat 7.1. I will only say one thing: I am surprised it did scare me away from Linux permanently (I don't know if that has changed, I am still building up the courage to find out).
I have recently decided to start presenting linux to one of my clients (he is a Novell fan, so I presented SuSE to him since , SuSE 10 seemed to go over rather well. Suse 10 seems to be a very nice package (and they nixed the whole home/professional deal, replacing it with one set of CD's that will run you around $60 after taxes in the US). I have also always been a Debian and have been trying to use Knoppix.
As far as WLAN cards on concerned, I have had some really odd experiences with both Knoppix and SuSE. On knoppix, I can get it to recognize the 108 mbps DLINK card for the laptop to work for a short time (usually about a day). It then sees the card, yet ceases to communicate properly (I have tested this with also Windows 2000 and SuSE 10, both of which have the same problem). DLINK seems to be designing their higher end cards to work in XP (I have not tested in XP however, I do not wish to burn $300 for such a useless product). Strangely enough, the DLINK 10mbps (DWL 650, PCMCIA card) I know works well in Windows 2000, off and on in SuSE 10, and isn't even recognized by Knoppix (version 4), it is as if it doesn't even exist. The last version of SuSE I tried before 10, was 9.1 . Version 9.1 has very poor wireless card support (both desktops and laptops.). The only wireless card that I found worked properly and stayed that way, was a Zonet 58 mbps internal PCI card. That worked very well with SuSE 10 and I was told by my friend that he has gotten to work in prior versions of Windows all the way back to Windows 98. My suggestion at this point for Knoppix, is that you will have to play around and see what works, I am still looking for a wireless that works decently in it for any length of time. SuSE 10 seems to be happy with the Zonet card (communicating with a DLINK DWL-7100AP Wireless Device). Strangely enough, I actually find that DLINK 108 mbps wireless cards seem to work well with cheap HP Pavillions (I cant remember the model, however I believe they had 2 Ghz Celeron processors). However, the on board sound card for those systems was not even recognized.
I apologize for the novel, however I have had a lot of experience with this (both new and recycled systems, I don't believe in throwing away what could possibly be of use). I have SuSE 10 doing an excellent job on my personal system (which is connected via CAT5, not wireless). If anybody is interested in learning more, please send me an email listed with my profile. I also use GMail messenger (ecobear on there as well).