View Full Version : Internet through USB on KNOPPIX for BlueAngel Board0x4 EVDO

10-13-2005, 03:54 AM
These instructions are written for people who have the HTC Harrier CDMA cellphone (for Blue Angel GSM PDA see post by FaRiS) manufactured by HTC and rebranded as various names around the world (o2) (imate PDA2k) etc.
Note that the example i show is for verizon wireless in the u.s. on a CDMA harrier. Global GPRS users should use the method described by FaRiS. This requires that you have the Wmodem.exe application running on the phone and the phone connected to your PC via USB cable.

boot knoppix 4.02 or later DVD into X-Windows

from a shell do:
sudo insmod /lib/modules/2.6.12/kernel/drivers/usb/serial/usbserial.ko
sudo insmod /lib/modules/2.6.12/kernel/drivers/usb/serial/ipaq.ko vendor=0x0BB4 product=0x00cf

sudo vi /etc/ppp/options
set the value to 0 for the following:
lcp-echo-interval 0
lcp-echo-failure 0

in x-windows do:
click on the knoppix tux on the kde bar then highlight "network/internet"
scroll up and to the right then click on "/dev/modem connection setup (serial/USB/IRDA/Bluetooth)"
click to highlight the radio button next to "usb: USB connector" then click OK.
scroll down the list and then click to highlight the radio button next to "ttyUSB0: USB Serial 0". Click Yes when prompted to set the symlink for /dev/modem to it.
Click on the knoppix KDE icon on the kde menu bar, highlight "internet" then select "KPPP (Internet Dialup Tool)"
Click on Configure.
You will start under the Accounts tab. Click New.
Click Manual Setup.
Type "EVDO" in the connection name box.
Click Add to add a phone number.
Enter the phone number: #777 (including the pound symbol).
Click the scroll-down for Authentication and select PAP.
Click OK.
Click on the Modems tab then click New.
You will start under the Device tab.
In the Modem Name box type HTC.
Click on the Modem tab. Click "Modem Commands".
Erase "ATZ" from the "Initialization String 1" box.
Enter "ATV1E0Q0&C1&D2S0=0" into the "Initialization String 1" box then press Enter.
Click OK on each to close the open configuration box(es) until you return to the beginning menu.
At the KPPP beginning menu make sure that "gprs" is selected in the scroll-down next to the "Connect To:" field. Enter XXXXXXXXXX@vzw3g.com into the Login ID field, where X's are your cellular phone number.
In the password field enter "vzw".
Run the WModem.exe program on your HTC Harrier and make sure you select USB from the dropdown menu and have it connected to your PC. If necessary disconnect your data connection if it is up on your BlueAngel when you first run the WModem.exe program, then reconnect it while WModem.exe is running.
Click "Connect" on the KPPP beginning menu to bring up the internet connection to your PC.

I suggest downloading and using the newest DVD version (as of this posting) as it fixes some bugs and doubles your speed. Additionally the new release includes the sleuthkit package which will allow you to perform forensics on the hard disk of the computer you run it on. (Although i would only do that on windows shares, EXT3 and reiserfs will change their checksums just by mounting them to read).

I used the embedded verizon authentication 'credentials' as an example in this post, you can really use anything though, or use however your provider has embedded or 'expects' your device to connect through EVDO to the internet.

03-07-2006, 08:11 PM
I tried your advice using my Knoppix 4.0.2 CD and the Kyocera KPC650 on the Alltel network. There were some problems I ran into:

I had to use the following vendor/prod codes: vendor=0x0c88 product=0x17da

Your instructions read:
vi /etc/ppp/options
set the value to 0 for the following:
lcp-echo-interval 0
lcp-echo-failure 0
I can't seem to save these settings: it keeps complaining that this is a read-only file. How do I work around that?

Using the init string you mentioned, I can attempt to connect and see the following:
Modem Ready
Initializing modem
Dialing #777

Then KPPP errors out with a return code of 16.

Any suggestions?

07-09-2006, 02:05 AM
Hi Brian,

The Kyocera KPC-650 is a PCMCIA card as far as i know. The instructions i posted are over USB. There is a linux driver for the Novatel Merlin S620, but i don't know anything about a Kyocera driver. You may want to look around though.


09-24-2006, 05:20 PM
Nice how-to ParMaster, I have a xv6600 and may use the info later. I know this is an old thread but I thought it would be a good place to post my successful use of Knoppix 5 and a v620 aircard (Verizon) to connect to the net. A simple set-up with kppp.