View Full Version : configuring a wg111v2 usb to connect to a netgear dg834g...?

10-25-2005, 10:47 PM
hi there,

if anyone could spare a little time to help me out here i'd be extremely greatful.

i have a wg111v2 usb dongle and i seem to have managed to successfully extract a windows driver and run it with ndis wrapper.

i am now trying to get this to connect to my netgear dg834g. i have set network essid and so forth and i seem to be able to 'half connect', but when i run the knoppix wifi gui (sorry, i forget the name, i'm back in windows now) i do not actually connect to an access point, although it detects that the wireless network is there if i scan and also that i have 100 for signal strength. the picture i have is a laptop with a blue card.

i think it may be a problem with the ip settings i am giving it when i run netcardconfig. here are the settings of my router currently:

Router Status

Account Name
Firmware Version V1.05.00

MAC Address 00:0f:b5:b7:ed:05
IP Address
IP Subnet Mask
Gateway IP Address
Domain Name Server

LAN Port
MAC Address 00:0f:b5:b7:ed:04
IP Address
IP Subnet Mask

ADSL Firmware Version
Modem Status Connected
DownStream Connection Speed 1152 kbps
UpStream Connection Speed 288 kbps
VCI 38

Wireless Port
Region Europe
Channel 11
Wireless AP enable
Broadcast Name enable

i can ping but if i try to ping the router ( i get all time outs.

can anybody offer me some advice of what to do next? i am at the end of my second full day of trying to get this install up and running and although i have made progress and am starting to really like the linux way of doing things, i am pretty much stuck now :(


10-26-2005, 09:20 PM
okay, i've made a little prgress i think. i now run these commands when i login:

modprobe ndiswrapper
iwconfig wlan0 essid xxxxxx
iwconfig wlan0 mode managed
iwconfig wlan0 key open xxxxxxxxxx
if config wlan0 up
ifup -a

i have edited my /etc/network/conference file to:

auto lo wlan0
iface lo inet loopback
auto wlan0
iface wlan0 inet static

after doing all of this i can ping and (both local to my machine) - but if i try to ping the router, on nothing happens and i have to <control-c> to get out...

if anyone could cast an eye over this and help me out i'd be very greatful and i will hang around here and try to help others out once i am up and running,

many thanks,