View Full Version : Can't Install To HD, Because Drive Is Read-Only.

10-26-2005, 12:49 AM
Hello. This is my first time here visiting the forum, and I must say I really like what I've seen trying out with the Live Knoppix cd.

However I have a small problem. I am using VMWare to instal knoppix to the "hard drive", because I'm afraid I will mess up my real hard drive, now onto the problem.

Here are the steps I take, I followed the flash tutorial made by IronGeek to get to the point I'm having the problem in. I will list step-by-step instructions on what I've accomplished so far.

1. Click the Knoppix penguin, then open up a root shell.
2. Type in knoppix-installer press enter.
3. Click ok on first few dialog boxes that appear on screen.
4. QTParted starts up, I right click on my Windows partition (I have Windows 98 on my virtual machine), and choose delete.
5. Right click on free partition and choose Create.
6. When dialog box appears I make a Swap-partition with 128 mb of ram, I really have 448 mb of ram, but the virtual machine handles up to 128.
7. Right click on partition that I just created and choose create again.
8. Now I set the root partition by typing in a backslash in the label input box.
9. I go to file > commit, then file > quit.
10. Knoppix-installer gives me the same screen as in step number 3 before i did the whole QTParted process, saying it needs a swap partition and primary partition.

Then I notice something on the details area that it says the drive is in "readonly" state, can I get access to the drive by doing something special, or can I not get access to the drive?

I appreciate anyone who responds in advance :)

BTW I am new to Linux, and this is my first distribution that I tried out.

10-26-2005, 01:44 AM
follow my advice here

10-26-2005, 03:12 AM
I tried the nofstab noswap trick, I still get brought back to that first screen, maybe I'm doing something wrong?

10-26-2005, 10:00 AM
just tried it myself....

What I had was the 1 HD with 2 partitions 1 for swap and 1 for the OS. THere was currently NO OS installed

First time I ran the knoppix installer I got a siilar error... I was missing something that was preventing knoppix installer from working. I then ran it again with the following options

IGNORE_CHECK=1 sudo knoppix_installer

so far so good. Installer started and its happily formatting my partition as reiserfs. THis was farther thatn I got the first time.

10-26-2005, 04:16 PM
Hey thanks for the response UnderScore, and opbz. I tried UnderScores' method first, it helped some but it didn' work, then I tried your method about the IGNORE_CHECK=1. I finally got it installed and it is working just fine.

Thanks again for your help you guys :)