View Full Version : Dlink

11-01-2005, 03:56 AM
Ok I truely tried to read the forum for 1 week trying to figure this out but i can't get it to connect... I activity lights are on say it reads the router but i can't connect. I have a Dwl-g620 wireless card. If you need anymore info just ask. Oh yeah i can i am tryiing it on knoppix 4.0. PLEASE PLEASE try to help Thanks... Peace

11-03-2005, 03:26 PM
When you say it read the router, are you saying you are associated with it?

Using Wifi you have to have 2 layers of connection in order for things to work (there are 7 layers total but for the sake of simplicity we'll focus on 2):

1) First is the wireless layer, which it sounds like you already have.

2 ) Then you have to get an ip address from your access point or specify one for your interface.


Can you ping your access point?

If not make sure you getting an ip address from it... ifconfig or if you set a static addy the double check it. then try to ping again

11-30-2005, 06:52 PM
hi, i have a d-link DWL-G650 and after spending 4 hours reading on how to get this thing to work on knoppix. I've tried ndiswrapper with the cdrom that came with my card and no luck. when i try to use the network setup in knoppix that didnt work either. the card say it is connected but i cannot surf the net. anyhow what this boild down to was that it is connected but no ip address so what i did was find a way to set up a static ip, and that worked like a charm.

my solution:

1. open konsole
2. change to root with the "su" command
3. type in netcardconfig
4. select "No"
5. just fill in the require information, ie. ip address, net mask, gateway address, essid, encryption, etc.

so i hope this will help other who is having problem getting their dlink to work with knoppix.