View Full Version : Deleting CMG leaves Files behind?

11-04-2005, 01:41 AM

I'm talking about Klik on this week's GNU/Linux User Show. I installed Kid3 (an MP3 tagger) and it worked just fine. However, it asked me for my root password after the download and then when I was done with it and deleted the CMG, I was left with this list of files on my system:


I understand that the /tmp file are of no concern, but why does it leave so many files behind in the /mnt directory?

I'm confused because I thought that the beauty of Klilk packages was that I didn't have to be root, and that removal was done by simply deleting the CMG file.

Can you explain for me what's happened here?



11-06-2005, 03:47 AM

I'm going to finish recording this show shortly and if I don't have a response as to why these files are being left behind, that will affect what I have to say on the show regarding my opinion of Klik.

Is there *any* reason why I had to become root and could not fully uninstall the Kid3 Klik application?




11-12-2005, 11:26 PM
"it asked me for my root password after the download"
*Which* download do you mean?

The klik client download+install

wget klik.atekon.de/client/install -O -|sh
may indeed ask for the root password, on that one occasion, to be able to add the 7 mountpoints to your /etc/fstab. After that, no more a klik-induced root password is asked! However, if the application run via klik would ask for the root password in "normal" installation mode too, this also happens with klik, and is quite normal. I am not familiar with Kid3 to comment more.

This is documented in various recent publications about klik. I suggest you to look at these resources, before talking in public about klik:

--> http://klik.atekon.de/wiki/index.php/User's_FAQ
--> http://dot.kde.org/1126867980/
--> http://www.kdedevelopers.org/blog/418

11-12-2005, 11:36 PM
why does it leave so many files behind in the /mnt directory?
This can happen, if for one reason or another, the application is not cleanly terminated, and the .cmg file not unmounted.

Do this to get rid of the files:

1. find out which process keeps the mountpoint occupied:

lsof /mnt/app/1
2. kill leftover process IDs found in step 1:

kill <pid>
3. umount the .cmg:

umount /mnt/app/1
4. remove all files left underneath, plus the mountpoint itself:

rm -rf /mnt/app/1

It looks you have tried to run Kid3 twice with the same result, because /mnt/app/2 is affected in the same way.

11-13-2005, 01:13 AM
Great, thanks for the info!