View Full Version : X doesn't start anymore

11-11-2005, 12:54 PM
X was working perfectly.
nvidia drivers were installed.
And the next day, it was not working anymore. We didn't change anything in the configuration.
when we make startx, it starts, but cannot launch KDE or fluxbox ; we just have rescue xterm.
What is strange is that we don't have any error message. Only the normal warning about fonts.
We tried to remove nvidia in the XFConfig-4 (by replacing nvidia by nv, commenting glx et uncommenting GLcore and dri), but it doesn't want to start (cannot load GLcore).

What is really strange is that we can launch startx without problem as root.
with the 2 users, it doesn't work.

Does anyone has a clue of something.
We can provide more informations about the configuration if you need

thanx a lot

11-17-2005, 08:29 AM
To me this sounds like a permissions foul up in the users desktop preferences files.
I would create a new user; either use the GUI Kmenu>System>user&groups or do adduser as root.
Then see is the new user can get a graphical login. Let us know how that goes.

11-17-2005, 11:51 AM
^^ yeah, in text mode log in as root... then use the code

startx to startx... and from there creat new user... tada... :D:D

11-26-2005, 10:46 AM
thanx a lot, :D
it was a good idea to create a new user because actually it worked.

It was then quite easy to discover that the problem came from files ~/.xsession and ~/.xsessions-errors
they were empty, but, by deleting them in user directory, the problem is solved.