View Full Version : Clock/Timezone error

11-21-2005, 12:12 AM
I'm running the HD-install "boot like the CDROM" version of Knoppix 4.0.2 to provide a fileserver for the other machines on the network. Almost everything works as it should (just a few challenges left to sort.)

However, I have a timezone glitch. The machine knows that I'm in England (calls it London, but hey), and that I use GMT. Stuff it pulls off the other machines or off the Internet that's time-based displays right. BUT the clock on the PC is 5 hours ahead. If I reset it, it's fine but it will be 5 hours ahead again when I restart the machine. It seems convinced that it's somewhere 5 hours behind GMT. If I forget, I get some wacky timestamps on files.

Anyone have any ideas how to get to work in real GMT and not add 5 hours at boot?

11-21-2005, 06:39 PM
I had this problem - set the timezone to 'local' and see what happens.

11-21-2005, 10:45 PM
Yes - it's on "Local", but screws up the clock on every reboot.

I have a suspicion the "system" stores something in a read-only file somewhere, which forces it to treat the systemn clock as being in EST on bootup, regardless of other settings.

11-24-2006, 10:23 AM
it likes to live on New York time
mine too

make sure I know when we find the prob

12-17-2006, 09:37 AM
godammit !!! SUCCESS !!!!!! ;-)

only taken me all day, and i don't usually last that long with the looking and researching and constant rebooting
to check things
while you forget what you were checking
and go and do something else


right, we need the timezone set AND the clock

doing the
will show you what you need to put somewhere, namely
thats a file in the home directory, not a directory
and it needs to be setup from the user dosshell too
i did one from the root dos shell, and the permissions on the file weren't right for the user to read it

but if you then set the clock and reboot it puts that danged New York time where you just were and then sets the TZ set zone relative to New York

well, looking at the link further up....
change the
UTC=no to yes
and reboot
and set the time
and reboot
and check it
and reboot
and feel very satisfied
and smug
and i'm currently doing my 6 other systems to check
but so far
I feel good, nananananana
I knew that I would now

07-02-2007, 05:37 AM
I found a workaround... see