View Full Version : No .cmg files run anymore.

11-25-2005, 06:22 PM
All .cmg files stopped running; result was dialog about adding lines to /tmp/app. Found no /tmp/app; created one and added prescribed lines. Same result. Reinstalled klik. Downloads are OK, but nothing runs. Nice quiet failure - no dialogs or errors. Tried running from a terminal; got error: "/tmp/app/ exosts but is not a directory". All a bit disappointing, especially since I can install directly from a Debian repository.
Best regards;
hotrodg (Hal)

After the complaint, figured I owe you an update. Created a /tmp/app directory and put app file in it. Tried to run a .cmg file. Result: complaint that /tmp/app was not writable. Changed permissions and tried again. Some apps now run. How did this happen? I did not change the klik installation, at least not intentionally. What the **** is going on? Is there a clear explanation of how this all works somewhere? As a programmer, I'm used to guesses and trial&error, but I'm getting weary...


11-26-2005, 12:07 AM
hmmm... I don't really understand what could happen on your system, but the only reason I see why cmgs might stop working is when you run too many (more than 7 actually) at the same time.

Do mount command to see how much klik images are mounted. (and possibly kill some unneeded klik processes)

11-26-2005, 03:10 PM
mount command looks ok - no cramfs line if no .cmg file is running; cramfs line present in a .cmg file is running. also, /etc/fstab contains the cramfs descriptor lines. Hope you saw my update. The .cmg files run now. The problem was apparently a missing writable /tmp/app directory. How it went missing I have no idea. One observation: Isn't this a weakness - having a (quasi) system directory that can be written (or possibly deleted) by a user process? In any case, everything looks ok now. Thanks & best regards. --hotrodg