View Full Version : After HDD install, can not access internet through ADSL ?

11-26-2005, 10:23 AM
I tried Knoppix 4.0.2 running from the CD and everything seemed okay and I was able to browse the internet with no problems.

I did the HD install and that went fine without any hassles with my Dual Boot set up (XP)

So my first bootup all is well except that I now have no Internet connection and I can not get things to work.

I have a Netgear FA310TX card.

Went back and booted from the CD and its ok.

As a Linux newbie help !!!!!!!!!!!!!!!!



11-26-2005, 03:46 PM
If you already ran "netcardconfig" you can try "ifup eth0" followed by "pump -i eth0"

11-26-2005, 04:06 PM

Wow thanks.............

I typed in


it did a DHCP broadcast, all is okay and I am now browsing and replying on this forum

So do I need to do this everytime I boot up Knoppix or is there a config file I need to edit ?

Thank you

11-26-2005, 04:10 PM
No, once should be enough.

Harry Kuhman
11-26-2005, 04:11 PM
The problem of the network cobnnection stopping working after a "hard disk install" of Knoppix is one of the oldest problems in Knoppix and has been going on for over 3 years now (http://www.knoppix.net/forum/viewtopic.php?t=25). If you didn't expect this to happen after a "hard disk install", then I have to wonder if you looked at the hard disk install issues much at all before deciding that Installing Knoppix was a good idea.

01-16-2006, 03:27 PM
... is there a config file I need to edit ?

Good question! Maybe the answer can help my issue. I have an 3.4 installation with "beginner install.." option...etc. My eth0 was reconized by default at first boot. Days ago I've disabled the network with 'ifconfig eth0 down' and after that everytime I reboot the pc I need to run 'netcardconfig' or 'pump -i eth0' to restore my network, no_more_recognised_eth0_at_boot_by_default :cry:
/etc/network/interfaces looks ok:

auto lo eth0
iface lo inet loopback

iface eth0 inet dhcp

Any suggest will be apreciated, thanks!

Solved!!! ...this whay: update-rc.d networking defaults :D :D :D