PDA

View Full Version : LILO not using new config



nibl
12-02-2005, 03:24 AM
I have changed lilo.conf, but the new config does not show in my LILO boot menu.

Here is the output of lilo -v -t. It shows the newly added kernel "/boot/vmlinuz-2.6.8-2-386", but this does not appear at boot time. I boot from hda, so the error about hdc should not be of importance, or does this error prevent LILO from actually writing the boot sector?

I hope somebody knows what is going on.

LILO version 22.6.1 (test mode), Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2004 John Coffman
Released 17-Nov-2004, and compiled at 20:01:15 on Sep 29 2005
Debian GNU/Linux

Reading boot sector from /dev/hda6
Warning: Kernel & BIOS return differing head/sector geometries for device 0x81
Kernel: 59560 cylinders, 16 heads, 63 sectors
BIOS: 1024 cylinders, 255 heads, 63 sectors
Using BITMAP secondary loader
Calling map_insert_data
Mapping bitmap file /usr/share/lilo/contrib/debian.bmp
Calling map_insert_file

Boot image: /boot/vmlinuz -> vmlinuz-2.4.26
Mapping RAM disk /boot/initrd.img -> initrd.img-2.4.26
Added Linux

Boot image: /boot/vmlinuz-2.4.26
Mapping RAM disk /boot/initrd.img-2.4.26
Added Linux(2.4)-1

Boot image: /boot/vmlinuz-2.6.5
Mapping RAM disk /boot/initrd.img-2.6.5
Added Linux(2.6)-2 *

Boot image: /boot/vmlinuz-2.6.8-2-386
Mapping RAM disk /boot/initrd.img-2.6.8-2-386
Added Linux(2.6.16)

Boot other: /dev/hdc1, on /dev/hdc, loader CHAIN
Added Windows(hdc1)

Boot other: /dev/hdc2, on /dev/hdc, loader CHAIN
Fatal: First sector of /dev/hdc2 doesn't have a valid boot signature

Thanks,

nibl

sakiZ
12-02-2005, 04:27 PM
After you modify the config file you have to open a terminal and run Lilo.

It sounds like you have not done that yet.

sakiZ

nibl
12-03-2005, 04:09 AM
I have run /sbin/lilo numerous times without the changes taking effect at boot time.

sakiZ
12-03-2005, 01:42 PM
Call in the reinforcements.

sakiZ

OErjan
12-03-2005, 02:07 PM
it seems like you are putting lilo in hda6 which might be too far from the beginning of the disk for the bois to handle.
where did the original lilo get installed?
have you tried mbr on hda? or would that mess things upp,

TopFarmer
12-04-2005, 03:37 AM
Boot other: /dev/hdc2, on /dev/hdc, loader CHAIN
Fatal: First sector of /dev/hdc2 doesn't have a valid boot signature

I do not know any thing about lilo but if you are trying to add hdc2 , likely till you fix the boot signature there will be no success. The program is not dumb enough to add a non bootable partition, ie: no valid boot signature, and may not modify if there is any errors any where.

I could be way off as my linux knowledge is poor yet.

sakiZ
12-05-2005, 06:40 PM
Warning: Kernel & BIOS return differing head/sector geometries for device 0x81

I just noticed this in your message output.

This may be your clue.

sakiZ