View Full Version : [Help] Knoppix locks up on boot when detecting LAN card.. :(

12-10-2005, 04:35 AM
Hi! :)
When I try to boot Knoppix, it does everything ok until this message... :shock:

Network device eth1 detected, DHCP broadcasting for IP. _And then the cursor stops blinking and it freezes up... :cry:
Do you know what the problem is and how can I fix it? :?

"eth0" should be my Realtek PCI Ethernet card and it seems to be ok (LAN cable attached to it), and "eth1" is probably my on-board LAN nForce4 built-in Gbit MAC (Marvell 88E1111 PHY) that came with my motherboard (no LAN cable attached to it)... :roll:
I tried disabling it on the BIOS, but it still gets detected anyway! :P

Can someone please tell me what to do to be able to boot Knoppix normally? :(

12-10-2005, 10:36 AM
if you use the cheatcode

knoppix nodhcp
it should boot without locking up.
then when you get into knoppix do

sudo pump -i eth0 to get ipadres.
if this does not work let us hear.
you type that in a console

12-11-2005, 04:42 PM
I'm sorry for the mistake, but I forgot something... :oops:
I also have a Wireless PCI card! So, the on-board Ethernet card is disabled correctly afterall... :P
Therefore, my configuration is this one...

eth0 - Gigabyte WPKG PCI WLAN Card
eth1 - Realtek RTL8139 Fast Ethernet NIC
eth2 - nForce4 built-in Gbit MAC (Marvell 88E1111 PHY)
Anyway, I did what you said ("sudo pump -i eth1") and it worked fine! :D
Thanks man! ;)

When I run KWiFiManager, it shows Interface eth0, so that's my wireless PCI card...
But when I start the Network card configuration tool (netcardconfig) and select:
> "eth0 Netzwerkkart_0" (small translation error here!!!)
> "Use DHCP broadcast?" (and click "Yes")
It shows this message and then it completelly locks up Knoppix like on the boot sequence... :cry:

Sending DHCP broadcast from device eth0
When I boot normally, the 2 messages that appear are:

Network device eth0 detected, DHCP broadcasting for IP.
Network device eth1 detected, DHCP broadcasting for IP._And then it locks up... So I though the problem was on the eth1 card, but it's in fact on eth0... :roll:
It's some sort of problem when getting the IP address from the Wireless card, that shouldn't be happening... :(

Still... it's kind of annoying having to type that "knoppix nodhcp" command everytime I want to boot Knoppix... :?
Will this problem be fixed on next versions? :?:
If you'd like, just tell me what I have to do and I can try to help you discover a solution for this! :)