View Full Version : Getting Apollo Fast Ethernet Card to work KNOPPIX 4.0.2

12-17-2005, 01:12 PM

I'm trying to get my 'Apollo Fast Ethernet PC Card' on my laptop to work under KNOPPIX 4.0.2. I know I have used an older KNOPPIX cd a year ago or so and had no problems.

During boot KNOPPIX detects the PCMCIA but doesn't start any eth0 or trying to receive any ip via DHCP. When the system is booted all the lights are lit on the network card just as they are in Windows when working. Even the ACT(ive) light flashes now and then, just as if everything works. However, I can't ping any host anywhere... Ifconfig only gives me 'local loopback' or something like that.

First thing I try is 'ifconfig pump eth0 up'. I then receive a flag error since no such device can be found.

Then I tried loading (when prompted by knoppix) the driver 'pcnet_cs driver' manually with modconf but the system refuses to recognize that an ethernet card is connected to the computer.

So, anyone got any idea what to do? I'm pretty new to LINUX so I'm quite lost.

12-21-2005, 06:53 PM

Couldn't at least someone give me a hint on where to look? I've tried posting this question at three different, mayor linux forums but no one seems to be able to help me... Problem is I can't get eth0 to show up as a device. I tried booting with nodhcp and when I try 'ifconfig eth0 up' I get: 'eth0: ERROR while getting interface flags: No such device'.

Any help would be greatly appreciated.