View Full Version : cdecord and kernel 2.6?

A. Jorge Garcia
01-23-2006, 09:02 PM
What's going on with cdrecord. I have to leave the PCs that I use to burn CDs in KNOPPIX 3.7 as ever since kernel 2.6 arrived, I can't use cdrecord. cdrecord --scanbus won't work, even as root. cdrecord won't work even as root. I used to be able to issue the command line:

cdrecord speed=16 dev=0,0,0 *.iso

but I get a "device 0,0,0 cannot be found" or some such error! And without scanbus, I can 't even find the dev....

Am I missing something here? I'd really like to upgrade those PCs using the KNOPPIX 4.0.2CD but how do I burn CDs without cdrecord (or K3B for that mater). Can I get cdrecord working under KNOPPIX 4.0.2 as a hdinstalled box (dual boot) running Kernel 2.6 or is there someother way around this?

Please help! I am flumoxed!!

Thanx in advance,

01-23-2006, 10:37 PM
I've never had to use the bus, et al for the device. cdrecord dev=/dev/cdroms/cdrom0 always works fine for me with Lunar-Linux.

01-24-2006, 02:35 PM
i can use /dev/hdc just fine to burn CD's and DVD's, try it, as 2.6 kernels and newer cdrecord support it quite well without scsiemulation even.

A. Jorge Garcia
01-24-2006, 02:45 PM
OK, I can't believe I've been stuck on using --scanbus all this time. When I first started using KNOPPIX, cdrecord would not work without that.

Now all I had to do was look-up /etc/fstab to see which dev to mount for the cdrom and I'm all set:

cdrecord -v speed=16 dev=/dev/cdrom *.iso

Thanx for all the help!


PS: Now, what if I want to mount a burnt cd for audio or to read data? How do I go about this, I always have problems with CDs ever since 3.7....

01-24-2006, 02:53 PM
a simple
mount /dev/cdrom /mnt/cdrom
should work in 90% of cases

A. Jorge Garcia
01-24-2006, 03:38 PM
OK, that's what I thought. I haven't done this in a long time, but the last time I did I couldn't get my audio app to work with that mount point (xmms) and I couldn't manipulate data files (knoqueror).

Let me try again....


EDIT: OK, with 4.0.2CD hdinstalled I was able to burn CDs with cdrecord and read a mounted data cd with konqueror. I don't have an audio cd handy right now, I'll try that at home (in the office now). Thanx!

My problem is that in older versions of KNOPPIX, the user couldn't mount these drives, only root could. So I didn't know how to mount the cdrom drive for reading data or playing music. I'm root on all my boxes, but my users I thought would be at a loss. Now, I remember that users were allowed to mount /dev/fd0 somehow, so I thought there was some complicated procedure for cdroms. Apparently, these devices are automatically mounted in fstab during boot up now. Silly me....

A. Jorge Garcia
01-25-2006, 02:40 PM
OK, I reinstalled all my boxes with KNOPPIX 4.0.2CD using knoppix-installer to a hdd partition (dual boots don't ya know).

As a user, I was able to auto mount /mnt/floppy and /mnt/cdrom. And I was able to burn CDs. I tried to mount a data CD, I didn't try to mount a music CD or a CD-G but it should be the same, no?

That was yesterday, now I tried to auto mount a CD and I get an error:

file:///mnt/cdrom does not seem to exist anymore

I got a similar error yesterday while trying to switch floppies, but somehow I got that error to go away. I can't seem to get this CD error to go away though.

Am I missing something basic here? Please help an old linux fossil, I'm not used to all this new fangled auto mount stuff! I'm used to the old fashioned root mount. In fact, until recently, I had several boxes hdinstalled with KNOPPIX 3.3, 3.4, 3.6 and 3.7 just so I could things the old way. Now I reinstalled everything - am I screwed?