View Full Version : Unable to boot from usb cd-rom

02-07-2006, 05:07 PM
I have a Compaq BL10e blade that I need to boot to knoppix. I have tested the CD in other servers without an issue, so I know my media is good. The server boots to the CD, but I get the dreaded "Can't find knoppix filesystem, sorry!" message. I tried failsafe, and text mode without any luck.

I'm trying to avoid buying a usb floppydrive, a coworker can bring one in next week... too bad I need to get this fixed asap. then again I suspect i might have the same trouble with a floppy drive. For the same reason I haven't emptied out my usb drive.

I suspect i just need to mount the cdrom, but I'm wicked rusty on my unix commands. any suggestions while I try to find more RAM to try booting "toram"?



Harry Kuhman
02-07-2006, 06:39 PM
I have tested the CD in other servers without an issue, so I know my media is good.
You do not know that your media is good. All you know is that it booted on other systems. If it was a high speed burn it could and likely is a marginal burn that works on some systems and not others. Sometimes CD drives become marginal too and have problems booting (and this shows up even more if the disk was burnt at high speed). I would suggest trying another CD burnt at slow speed or even a CDRW (changing to CDRW also changes the gain of the amplifer in the read circuit which sometimes can help work around optics issuers).

This is not a mount command issue.

02-10-2006, 09:09 PM
ok I reburned the CD on 4x with media i trust, not the crappy stuff here. - no luck. both cd's work fine on any other hardware, just not the bl10e.

I have also tried the boot floppy, no go.
I also "borrowed" another USB cd-rom with the same results.

I can boot to the bl20p blades without any hassle, it's just the bl10e's. Any ideas?


02-11-2006, 09:18 AM
USB booting can be problematic. I've had some serious problems getting my new Toshiba Portege R150 to boot, and that's with the stupidly expensive Toshiba brand USB DVD-RW (the only way it'll boot from external sources besides PXE).

There's a known problem regarding how some distros mount the USB drive after a certain point of the boot process. The only stable "live" distro that I have found to work (and has been confirmed by others) is UBUNTU LIVE. There's also a GENTOO LIVE "experimental" distro (dated November '05, I think) that you should be able to find from any Gentoo mirror under the x86/live/experimental branch (I think that's the path).

This Gentoo distro was the result of a nice long bugfix chain I found on their support website (gentoo.org) that one of the distro devs put together. He specifically said it WASN'T going to be distributed to the main boot CD chain (dunno why...), but the LIVE cd still gets me in far enough to (at this moment) install Gentoo on a HD partition

I'd rather start with using Knoppix, but the boot sequence hasn't been corrected yet. FYI, it's under the following link (anybody in the distro admin wanna make a similar Knoppix fix?):

Hope this helps somebody else out there!

08-30-2006, 09:51 PM
Has this been fixed in more recent Knoppix releases? I'd really like to be able to boot from an external USB CDROM. It seems to me that this is would be a fairly common way to boot Knoppix for people who want to use it as a repair OS.

Other distros that *will* boot from an external CDROM (at least on my Thinkpad T43 with a Targus DVD-CDR external USB drive:

- Finnix (a Knoppix derivative, stripped down for sysadmins; use "bootusb" option) www.finnix.org
- Gentoo Live CD (can't remember if a special boot option is needed; probably so)

I haven't found others that will allow the extra time for the OS to properly i.d. and register the external USB CDROM. I don't think this is rocket science, but it would require a bit of tweaking to the boot sequence.

Can anyone share other helpful info? Thanks.