View Full Version : OpenOffice 2.0 Install: No Fonts!!

02-10-2006, 02:59 PM
Ok, I bit the bullet.

Even though I can run the Windows version of OO in my setup via OpenOffice, I downloaded from the OO website 101.5 megs of OpenOffice install files. I get it unpacked to discover the package is dozens of rpms.

Ok, I "alien" that. I finish the install.

It seemed to go fine with no errors. Now here is the rub:

Fonts do not appear. Little dotted rectangles show up in place of each letter.


If I run OO as root, fonts work. I can see text in menus and documents, but not anti-aliased. They look crappy but at least I can read them.

So, does anyone know what I can do? Is there some permissions change I need to do? An additional file to download an install?

I looked at some websites that deal with OO font issues, but nothing seemed to apply to me.


02-11-2006, 04:23 PM
Flying blind with no menus to guide me I did manage to open a document in user mode. (The menus being just little rectangles where letters are supposed to be.)

Hey, I could read the document!! Well, that narrows the problem.

So, apparently this problem is affecting only menus in all the apps in OpenOffice when I run as "user".

I have read of a similar bug in OO, but it was version 1.01.

At least everything is usable if I set OO to open in root.

It's just annoying to have to type in a password everytime I want to use it. Do I have to "settle" for that?


02-18-2006, 03:07 AM
Well this was a very simple fix. It just took me a while to think of it.

After exhausting all the OO possibilities with the helpful folks in the OO forums, I began to ponder the suggestion that the problem was a "font" problem on the Debian side.

I began to ponder how logging in as root and logging in as user you get two completely different desktops. "Root" is totally unconfigured in my system. Interestingly enough it has only been recently that I had found a hack that let me log in as root.

Anyway, root looks just like it did the day I installed the OS. My user desktop is highly tweaked and looks very different.

I thought "What if....the font preferences in the two desktops are different and the user one is incompatible somehow?

This seemed highly likely.

So, tonight I logged in as root and looked at the font preferences. "Menu" fonts were set to Helvetica 12 pt.

I immediately exited and re-logged in as user. Those menu preferences all used "Clearly PUA". Menu fonts were set at "Clearly PUA 13 pt".

So, I changed the Menu font prefs to Helvitica 12 pt. and fired up OO.


I got my pulldown menus.