View Full Version : problem in fixing grub after windows reinstall

02-27-2006, 01:35 PM
Hello All..

Mr Underscore ..

i read ur thread ::
sudo mount -t ext3 /dev/hda2 /mnt/hda2

We should probably make sure the grub boot menu.lst file exists.
ls -l /mnt/hda2/boot/grub/menu.lst

You will chroot into the /mnt/hda2.
sudo chroot /mnt/hda2/ /bin/bash

If that is successful then then run grub-install & apply grub to the MBR.
grub-installer /dev/hda

If that is successful, type exit:
when i tried to mount is stated that the mount point is busy..
when i typed the "ls" command it showed the file...
when i chroot .. the shell crashed .. and typed many lines having " access denied.." or something like this .
so when i tried to grub-install .. it did not find anything..

please help me .. my grad project is on the knoppix .. and it dissapeared.. after XP re-install !

Thanks is advance..

yours ,

02-27-2006, 06:22 PM
If you are booting from a knoppix livecd, do _not_ click the icon on the desktop that indicates your knoppix partition.

Now open a terminal window and type the command: su

Once you press "enter" you are root.

Follow the previous instructions to reinstall grub, but, without the sudo command.

02-27-2006, 10:45 PM
Sure MR. nad..

you are correct.. thanks a lot..

i did not click the hda2 partition.. made the procedure..

worked great.. im running on Knopix again..