View Full Version : Getting wireless network adapters working

05-08-2003, 04:38 PM
I was trying to get my internet working yesterday after doing my hdinstall, but I wasn't successful. I have a microsoft wireless usb adapter and router, which my dsl modem connects to. I noticed that after the hdinstallation the device was not listed in the Info Center under USB adapters, however it was recognized when i ran from the CD. Also, when I used the DSL configuration tool (after the hdinstall) it found the ethernet device wlan0 (which i figured meant wireless lan), but then when its trying to set it up, it gives me several "network is down" errors in the shell and finally tells me that "Access Concentrator of your provider did not respont or another pppoe process which controls the modem is running"
Can anyone offer advice?

05-08-2003, 07:45 PM
Getting wireless to work from a hd install is not hard per se, but I haven't had any experience with wireless usb adapters. I'm curious to find out if it will work though.

Let's start with this and see if it provides any information that others can use to help.

Do you get any error messages when you run "dmesg |less"

Also does that reveal any info regarding your adapter.

Do you see it when you run usbview.

Have you searched google regarding this issue and your device (try "linux + wireless usb adapter" and possibly specify your manufacturer and model)? You may get some information that way that is worth bringing back here for others to look at.

05-09-2003, 04:17 AM
thanks for your reply,

dmesg doesn't give any error messages regarding usb (only hd errors, related to a queue)

when i run usbview i don't see it, in fact when i execute usbview from the shell it gives me an error message saying it
cannnot openfile /proc/bus/usb/devices
verify that you have USB compiled in your kernel, have USB core modules loaded, and have the usb devfs file system mounted.
So i guess i have to get that fixed also, but i don't think that's the only problem, because I tried booting from the cd again and it recognized the adapter in usbview, but the dsl configuration tool gave me the same error.

I had done a search on google but i wasn't very successful, only thing i found out remotely useful is a review on the adapter (about a year old) saying linux support wasn't yet possible, but should be in the future (as in now :) ) since it uses the same chip as many other wireless devices (forgot the name). Good suggesstion though.