View Full Version : writing to new hard drive

03-26-2006, 10:22 PM
knoppix is currently saving my arse from a windows induced data hostage situation... now i am trying to convert this un-cooprative windows box to debian... windows 2000, currently accessable through knopix 4, on its way to debian sarge... but first i want to get some data to a safe place.

under knoppix i installed a big ol' 160G Western Digital HD (IDE) as a slave to the existing 80G maxtor... i want to copy the old data to the new drive and then set up debian on the old drive.
(also on the machine is a SATA Maxtor HD... NTFS so i'll just leave it out of this)

i've created and formatted three partitions on the new HD using fdisk and mkfs: hdb1 (ext2), hdb2 (ext3), and hdb3 (also ext3)
here's the problem: i mount the new partitions and try to set the permissions to write (tried the Actions->change read/write mode as well as chmod)

>chmod 777 /mnt/hdb1
chmod: changing permissions of `/mnt/hdb1': Read-only file system

it won't let me write to the new disk... can't copy files to it... tried to save straight from vi... no luck.

it lets me chmod & write to the master drive... but not this new one.

maybe missed a step in the partitioning or formatting?
i am new to knoppix so appologies if this is a silly question... but i don't know where to go from here,
any help would be much appreciated.
nathan epp.

Harry Kuhman
03-26-2006, 11:08 PM
It is not a permission thing, it's that Knoppix mounts the drives ar read only by default. See answer 6 (http://www.knoppix.net/wiki/User:Harry_Kuhman).

Also, while you certainly can save the files to an ext3 partition, have you given any thought on how you are going to get them back to a Windows system? Depending on what you are going to do I might have made them FAT partitions, which both Knoppix and windows can read, rather than ext3.

03-27-2006, 12:30 AM
thanks much for the quick response,

mounting -rw from the command line allowed vi to write.
but the kde still couldn't save.

not just an answer 6 issue... maybe 6.1 : )
ownership... the new drive was owned by root... while the old drives belong to 'knoppix'

chown -R knoppix /mnt/hdb1

did the trick.

thanks for the help.

p.s. thanks for the ext3 caution... but windows had its chance... never again will it preside over a computer of mine.