View Full Version : newbie in difficulty: can't use the CD or internet after HD

04-12-2006, 12:24 PM
I have been using Knoppix (ver 4) from CD very happily for a month, all day every day, to see if it worked for me. It did, so I decided to move to HD install. I used the knoppix-installer script, and chose the Debian option- which seemed to work fine. At the end of the process, it said "Everything worked fine." and for all of the rest of that day I used the computer happily including internet and both CD drives, and switched off.
When I rebooted the next day, problems: I can't use the CD drive or the CD R/W drive; neither are visible. Both were automatically recognised and mounted when I loaded from CD but now they have disappeared. And I can't connect to the internet or to my local network (I have 3 other PCs running windows connected via an ADSL router at

I'm missing something, surely; but after two days of trying to find Debian documentation (which all either assumes I know absolutely nothing, or else absolutely everything) I'm frustrated and need urgently to get back to work- whi I can't do if the damn PC doesn't work!

Can anyone point me in the right direction?



04-17-2006, 07:36 PM
had a similair pb whith adsl

ther was a lin in /etc/network/interfaces missing
# The loopback interface
# automatically added when upgrading
auto lo eth0
iface lo inet loopback
iface eth0 inet dhcp

for yuor CD pb
try to mount them in a console type

mount /dev/cdrom

and have a look in man mount