View Full Version : Extremely Slow Booting

04-15-2006, 06:23 PM
When I insert the CD into a CD drive and boot, it boots extremely slow. I moved the disc to another computer and it boots fine. I've tried enabling DMA, failsafe, tried setting the home directory to a different drive. I KNOW its not the CD because I have the same problem with ANY version of linux I try to install on this computer. The DVD-rom drive is brand new. The primary master drive is NOT brand new....could it be possible, that even though I denote a different drive to be home, that this drive could be the reason it takes forever to boot up?

Harry Kuhman
04-15-2006, 06:42 PM
I KNOW its not the CD because I have the same problem with ANY version of linux I try to install on this computer.
My first question is what speed did you burn the CD at? No matter what you think you know, we have seen many many cases of the CD booting slow (http://www.knoppix.net/forum/viewtopic.php?p=78583#78583) or not at all when the CD is burnt too fast. If the CD was burnt at a slow speed then it could be a drive issue, the age of the drive is not proof that it is not, but it could also be a media quality issue (my first step after a slow burn before trying a different drive would be to burn slowly on different media, a 700 meg CDRW would be a good choice for several reasons). It would also help if you would define slow. See the above link for some real world examples, and how much more useful a conversation can be when moved from the abstract to quanitive measurement.

04-15-2006, 07:11 PM
And YES I read your posts before I posted this out about booting slow. Ok....so let me be more specific....burnt at 4x. Tried different media, even put the CD drive that it boots fine in...into this computer and it boots slowly still.

Harry Kuhman
04-15-2006, 07:14 PM
it boots slowly still.
Define slowly. Time from pressing enter at the boot prompt until the Knoquror window is up and ready to use at the least, other times might also help so that we can see where the difference is. And, of course, it would help a lot to know what your system specs are. Knoppix will boot (and run) very slowly on an old Pentium 90 with 64 megs of memory, for example.

04-15-2006, 07:20 PM
First off....its a P4 2.53GHZ 1GB Ram. 1.2 TB disk space. Matrox Dual Head Video card. I think its more than adequate enough. As far as how slow....after loading kernel...it takes 5 minutes. Then after autodetect its takes 4 minutes 33 seconds. When X starts, the screen goes blank just before the logo is SUPPOSED to come up. I've waited over 20 minutes and nothing. Yet its not frozen. I haven't yet seen this computer boot into knoppix.

Harry Kuhman
04-15-2006, 08:16 PM
OK, now we are starting to communicate. Yea, that machine should squak by on the Knoppix requirements. I don't think I would just say it boots slowly, I would discribe it as booting slowly and never finsihing. Here are some things to try:

Cheat codes noscsi and/or acpi=off, as in knoppix noscsi, knoppix acpi=off or even knoppix noscsi acpi=off.

You say that you tried enabling DMA. Once again there is a key piece of information that I can't find in your posts: Which version of Knoppix is this? It matters because some versions have had DMA off by default bit some had DMA on by default and it needed to be disabled on some systems and some optical drives. I'll assume that you are talking about 4.0.2, in which case trying to enable DMA is the proper thing to do. But if it is an older version such as 3.7 then try the dma=off or nodma code. And try the DMA settings again with this different drive if you have not already done so.

It does not seem likely to be a CD issues at this point, but you might want to use the testcd cheat code anyway, just to see what this might tell you and to further rule out CD reading issues. And you might want to boot the CD and type in memtest (not knoppix memtest) to run a memory test, just to be on the safe side.

04-18-2006, 06:12 AM
memtest all passed. Zero Errors. CD is ok. Tried your recommended cheats. Nothing improved. Oh and for the record...yes I do have 4.0.2.

04-22-2006, 03:08 PM
I'm still waiting on an answer....It still takes forever to boot.

04-25-2006, 09:30 PM
Try http://www.alpha.co.jp/ac-knoppix/index_en.html

maybe that helps speed up things a bit?


04-27-2006, 01:42 AM
Even with Accelerated Knoppix....it has taken over 5 minutes from INIT: version 2.78-knoppix booting to AGP bridge deteced and its still just sitting there. Any more ideas?

04-27-2006, 01:46 AM
System Specs

Intel P4 2.6 GHz 1799 MHz 512 KB Cache
1294764 kB RAM

1.2 TB drive space
Matrox Millennium G400 AGP dual head card