View Full Version : SiS 740/961 (SiS900) problems on Desknote

05-10-2003, 11:29 PM

I recently bought a Desknote A929 (notebook/desktop hybrid - well actually just a heavy Laptop without internal battery, which takes standard desktop CPU and RAM!! very nice too...)

Anyway, it came with "ThizLinux" which had no problems connecting to my Lan and the internet using the SiS 900 driver. I dont like ThizLinux, so wanted to install Debian, but even the 2.4.x kernel CD installer didn't have the modules for SiS network chips. SO I decided to try Knoppix, and it recognised my Ethernet device as SiS 900 allowed me to set up the network interfaces using netcardconfig. BUT I can't get the network to be seen. I am fairly confident I know what setting I need and they are in any case the same as I entered in the ThizLinux distro, which worked, so I assume its the SiS 900 not being quite right for the SiS 740/961 chips even though they should work.

Has anyone got any idea of how I can debug this problem. I did read somewhere -but can't find it again!! - that there is a patch for the modules to get the SiS 900 modules to work with the SiS961 chip properly. Unfortunately I am not an expert, but if someone can put me in the right direction, I would be gratefull.



07-24-2003, 05:00 PM

I have also a A929 and for your luck, solved this very problem.
try using the following parameter in lilo:


I didn't tried this in knoppix, I used a distro based on knoppix, but should be the same...

If it works, please, reply this message saying so.


10-31-2003, 05:43 AM
noapic cheatcode works for me on my a929


10-31-2003, 11:04 AM

Works for me too!
The problem was after installing to HD.