View Full Version : pcmcia card lockup MORE info

05-12-2003, 06:33 PM
I have confirmed this happens when running off the Knoppix 3.2cd not just after a hd install. Should i try a different driver from somewhere?

Running iwconfig eth1 says

Warning driver for eth1 has been compiled with version 14 of Wireless Extensions while this program is using version 15.
Some things may be broken.

eth1 IEEE 802.11-DS ESSID:"shopwireless" Nickname:"Prism I"
Mode:Managed Frequency:2.462GHz Access Point: 00:30:AB:1F:14:9F
Bit Rate:11Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:86/92 Signal level:5/153 Noise level:117/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

The laptop is a Toshiba S103 I had Mandrake 9.0 working with a custom kernel and newest pcmcia-cs. After doing a Knoppix 3.2 knx-hdinstall my Netgear MA401 wireless card only works if its inserted before booting. If removed after booting or inserted after booting the machine hangs solid no ctl+alt+bkspc no ctl+alt+del. I have to hold powerbutton in till it dies then reboot. Any idea how to fix this?

05-17-2003, 04:46 PM
Toshiba 1115-S103? I have one of those.

I've had mixed results when inserting/ejecting an 802.11b card under WindowsXP as well as Linux (under XP, I'm not seeing any tools for safely shutting down/ejecting the card, and simply ejecting it under power causes an immediate system freeze). Under Linux, I've been able to safely shut down and eject the card using Klaptop, but cannot reliably restart wireless networking services without rebooting, though the card itself seems to start up automatically upon insertion.

I am using kernel 2.4.20 (from kernel.org, not Debian) patched with PCMCIA-CS 3.2.3 and a newer ACPI. Had tried PCMCIA-CS 3.2.4 but the Orinoco drivers seemed to be broken in that release.

05-20-2003, 04:33 AM
Hum I have not had any problem insert/ejecting in winxp with the two cards I have tried, a cisco and a Netgear. I agree there is somthing wrong with the PCMCIA-CS 3.2.4 I compiled that in mandrake and it would not work for me either. I am not sure what Klaptop is I will have to look into that.