View Full Version : Keyboard after boot not working.

06-25-2006, 10:58 PM
Hi All,

I recently tried the latest knoppix (KNOPPIX_V5.0.1CD-2006-06-01-EN.iso) and cooked a CD so I could run Linux on a machine that has windows (ugh) on its HD at present. It got to the boot prompt and I could type "stuff", but once booted the mouse would not move and no keypresses had any effect (even the numlock key LED).
Even failsafe mode did not change the behaviour.

I googled for this problem but didn't turn up any results.

The machine is powered by an AMD 64 Athlon Dual core. Mouse and keyboard work fine with windows so I don't presume the hardware is faulty, The thing is its PS2 for both so I would have thought this should work out of the box!

Any advice?


Harry Kuhman
06-25-2006, 11:16 PM
Yes, it certainly should work. Got any spare keyboards to try? You might want to check you BIOS and see if anything looks like a good canidate to change. I would also try booting in expert mode and taking notes to all of the questions that you answer (at least as long as the keyboar works to answer questions). See the wiki section on cheat codes for other things you might try.

06-26-2006, 01:07 AM
Well that's the thing.. The keyboard and mouse run through a KVM switch. There are 2 computers connected to the same keyboard and mouse through the KVM switch and I'm typing on _the_ keyboard at the moment on a PC that is running Xandros. The other PC (the one with Windows on the HD that I'm trying to run knoppix on) is where the keyboard isn't working - so I really can't see how it is a keyboard thing, or a KVM problem really.

I don't have a spare to try but I could plug the keyboard direct into the knoppix PC I guess, that may eliminate the KVM switch.

I'll look around at the cheat codes and the expert mode. Ta.

06-26-2006, 01:14 AM
Direct connecting the keyboard didn't help.
In expert mode I got to loading which scsi modules and the keyboard was not working at that point (but was when I typed expert).

Will look at the cheat codes.


Harry Kuhman
06-26-2006, 01:28 AM
Direct connecting the keyboard didn't help.
In expert mode I got to loading which scsi modules and the keyboard was not working at that point
Even though it does not seem to me like the problem, I would leave the KVM switch out of the puzzle until I knew something. Nothing else in line with the ps2 plugs that you didn't mention, is there, like a digital joystick interface, or 3D Glasses interface, or the good old Cue Cat? Anything drawing power for the ps2 port could very well be the issue.

No alternate keyboard? Even an old marginal one? Or an alternate mouse, even one with a dirty rubber ball inside?

If you couldn't answer the scsi question, what was the last question that you did answer and what answer did you take?

06-26-2006, 01:56 AM
Keyboard and mouse connected straight to the PC in question. There was/is nothing else inline .
The mouse has no balls - it's optical. It's a USB mouse with a USB to PS/2 converter plug.

Interestingly in failsafe mode I noticed a message:
PNP: No PS/2 controller found. Probing ports directly.

Still no keyboard action.

The scsi question in expert mode was the first I was presented with.

I shall steal a keyboard from someone else in a minute and try with that!

06-29-2006, 07:58 PM
One question: after the KB and mouse lock up,
does the clock on the toolbar keep time?
If not, a new KB or mouse won't help - a full lockup would more
likely be a 2-cpu issue.
(BTW I tried a KVM and Cue Cat and USB optical mouse w/o trouble. YMMV.)
Have you tried Knoppix 4 on this machine?

06-29-2006, 10:54 PM
I don't think it is a CPU lockup problem - unless by hitting a key locks it up.
Booted in "normal" mode by pressing enter at the boot prompt gets the expected X running and KDE.
Before and after key presses the clock is still running.

I've not tried a Knoppix 4, I've been trying KNOPPIX_V5.0.1CD-2006-06-01-EN.iso.
What's the difference? Earlier kernel?

You don't think it has anything to do with "No PS/2 Controller found."?


07-02-2006, 12:35 AM
since you can type at the boot prompt, the hardware is likely ok.
I have however once had a ps2 kb with a usb adapter stop responding at the boot prompt after one keypress; this happened only with Knoppix v5.

you could try typing at boot prompts
knoppix 2
knoppix 3
knoppix 4

to give more info on when Kb quits. If it does NOT quit,
then Xorg may be to blame (it is new in Knoppix v5)
so far Knoppix v5 has had more problems than Knoppix_v4.0.2_(whatever).iso
I think v5 has a newer version of the kernel. (2.6.17)
you could try the v4 iso, BUT it tends to lock up on my dual CPU (Xeon)
under heavy disk I/O load

07-03-2006, 06:04 AM
I just downloaded, burned and booted knoppix 4.0.2 and it works fine! (yay).


When I booted 5.0.1 in expert mode, before X had run there was no keyboard, so it's something very early on in the kernel IMHO.

Anything I can do further to narrow the search?

07-03-2006, 06:12 AM
FWIW, with 5.0.1 I just tried "knoppix 2" at the boot prompt and where it comes to a prompt the keyboard is not working.

I'm guessing the '2' is for run level 2?

Certainly X is not running at this stage and the keyboard doesn't work so I'd say it's a kernel bug.