View Full Version : still trying top get linksys wmp54g to work

06-26-2006, 09:20 PM
I posted once before witb much less information. Essentially, I'm trying to get a linksys wmp54g wireless card to work with knoppix. I've tried a few things and read several forum posts. I'm still lost. It may be I just don't know enough.
- - - - - - - - -

When I try to start knoppix 5.0.1 (CD - KNOPPIX_V5.0.1CD-2006-06-01-EN.iso) and it reaches the networking part, it says:

eth0 detected
dhcp broadcasting for ip
udevd - event[3258]: wait for sysfs: waiting for 'sys/class/net/eth0/device/driver' failed

Nothing seems to happen after that. I'm stuck.

- - - - - - - -

I tried starting with the nodhcp cheat code.

It goes a little further, but the last thing I see is this

probing/loading agp modules udevd_event[3391]: wait for sysfs: waiting for '/sys/c;ass/net/eth0/device/driver' failed.

- - - - - - - - -

So, I downloaded version 4.0.2 (CD - KNOPPIX_V4.0.2CD-2005-09-23-EN.iso)
It also hangs if I start without the nodhcp code. Instead of returning an error, it just goes off and never returns.

It does start with nodhcp.

I tried some things I found in a forum

I then run iwconfig eth0 essid "my ssid"
That seems to work.

iwconfig returns this

lo no wireless extension

eth0 RT2500 Wireliess ESSID: "My ssid"
Mode managed Frequency=2.412GHz Bit Rate: 1mb/s
RTS thr:off Fragment thr:off
Linkquality 0/100 Signal level=-120dbm noiselevel: -256dBm
Rx invalid nwid:0 Rx Invalid crypt:0 Rxinvalid frag: 0
Tx Excessive retries:0 Invalid misc:0 beacon:0

I try pump -i ath0.
It hangs. No error. Nothing.

I also tried configuring the network card from the knoppix menu to no avail. That ends up hanging.

The relevant (I think) output from lspci -v is

Network controller:Ralink Ralink RT2500 802.11 Cardbus Reference Card (rev 01)
Subsystem:Linksys:unknown device 0032
Flags:busmaster, slow devsel, latency 32, IRQ=11
memory at ea000000 (32 bit non prefetchable) [size=8k]
capabilities:[40] powermanagement version 2

07-10-2006, 06:54 PM
I have the same problem with WMP54G.

A friend gave me a CD of Knoppix 3.9 recently. This is the Linux distro that operates entirely from the CD. It boots my PC, etc., but I can't reach the Internet. This is probably because I'm on a wireless setup. I CAN reach the Net if I plug into the router by cable.

My wireless card is a Linksys WMP54G and the router is a Linksys WRT55AG.

I went to some of the Knoppix forums which recommended some scripting, but since the OS isn't installed on the hard drive, but remains on the CD, you can't write any changes.

I posted on Linksys' own forum, but no answers so far.