View Full Version : Anyone having success with wireless networking and 5.0.1?

Harry Kuhman
06-27-2006, 07:32 AM
Of course, most of what we see in these forums is people posting of their problems. When something is working properly people don't usually post about it. But I've been playing with wireless all evening and I'm pretty sure that Knoppix 5.0.1 will not support my wireless card, at least not with encryption enabled. I plan on doing more teste with encryption on the router disabled, but that will have to wait, and is not an acceptable way to run the router anyway. The thing is, this card worked fine in the last few releases of Knoppix. I can get it to work under the current release canidate of Mepis. But although the green lights come on under Knoppix 5.0.1, it keeps claimng it can't find the router, even though I think I have the encryption configured properly.

Reflecting back on this, I don't remember seeing any reports of good wifi results in this new release. So I'm hoping that some of you will at least post reports of sucess and that there isn't a major problem. If you could give the make and model of your wireless NIC, if you are running with or without encryption, and any special steps that you took, that would be welcome too. And please consider adding your results to the Wireless Networking (http://www.knoppix.net/wiki/Wireless_Networking) section of the wiki.

06-27-2006, 10:40 AM
I didn't manage to get knoppix working with my Atheros AR5005G wireless interface. But I got Ubuntu 6.06 and grml to work with it.

06-27-2006, 01:22 PM
I have an Enterasys (former Cabletron) PC-Card (which is the same as Orinoco silver) working on KNX 5.0.1 CD-Version without problems. It uses 64Bit WEP encryption and its speed is 11Mbit.

Harry Kuhman
06-27-2006, 03:42 PM
Thanks posmanet, it is good to know that at least some cards work. Could you share with us what steps you take to saet it up? I think I'm doing everything right, and I had my card working back in 3.7 and 3.9, but I sure can't get it going now. The software has changed a bit so maybe I'm missing something, but I doubt it.

06-27-2006, 04:04 PM
Here's my set up:

- boot you linux
- as root, type: wlcardconfig and set up your wireless parameters (i.e.: essid and key)
- as root, type: netcardconfig and set up your lan parameters (local ip, gateway, netmask, defaultroute, nameserver)

You can also start netcardconfig first, because for wireless devices it automatically starts wlcardconfig afterwards. But you will experience problems when you have an encrypted WLAN and want to use DHCP. The WLAN parameters, especially the key has of course to be set up _before_ you try to get an ip over DHCP. (So, if you use static IP, thats manually set up, its enough to start netcarconfig - wlcardconfig will be showing up automatically.)

good luck!

06-27-2006, 04:40 PM
I too have not had any success getting my broadcom wireless to work with 5.0.1, where it worked flawlessly with 4.0.2.

I just saw a note in a different forum (quantian, which is a knoppix derivative) that may shed some light from a little different perspective.

The bottom line to the comment was that there was a gcc incompatibility between the kernel (5.0.1 version) and some of the modules / drivers that was causing the modules to not work.

The note went on to say that they took specific steps to rebuild the modules explicitly specifying gcc 3.3, and life was good after that.

Now, in my case, I did check the broadcom bcm43xx driver and strings bcm43xx.ko | grep -i gcc reports that the gcc used there was version 4.0. I am thinking that I might dive in and work through that, when I get a little more time.

This may well not be your specific problem, but perhaps worth a quick look.

Best Regards,

06-28-2006, 02:54 AM
If you have a Broadcom Wirless card read this forum post (http://www.ubuntuforums.org/showthread.php?t=185174) and check which model your card is.

If you have the Broadcom 4318 card then go here (http://www.ubuntuforums.org/showthread.php?t=190177) .

Eventhough this for Ubuntu it doesn't matter because when you get down to it it's Linux and the command shell.

I had nearly given up on Knoppix 5.01 on my laptop then then I discovered the two links above.

06-29-2006, 03:44 PM
Harry ..
With your help and others I was finally able to get my Presario laptop [windows xp pro - sp2] [router dlink 524 using WEP, Broadcom 4318 in the laptop] working with Knoppix 5.0.1 and FWcutter using the bcmwl5.sys that was in the driver section of the laptop **note: had to set nodma to get live cd to fully work .. [In V4.02 i had to use ndiswrapper and the bcmwl5.sys in the original disks] ...
The only thing now [in fact just posted about this] is that the Wireless connection is running at between 8-11 Mbps rather than then normal 45-54.
Interestingly, in 4.02 the wireless connection ran at the normal 45-54 Mbps.
But, in answer to your initial comments, I found that, the more you read the comments in the forum, the more knowledge you get, [sounds simple doesnt it !] and the easier it gets to get things done .. although I had played with Unix many yrs ago, like a foreign language if you dont use it you lose it ... !

06-30-2006, 07:41 PM
harry ..
as promised here are the stpes I took to bring V5.0.1 [using live dvd] online for my Presario ze 2000 series laptop

1, got original Broadcom Presario bcmwl5.sys driver from hp cd [it may already be on your hd in the Windows system32/drivers file]
2. copied bcmwl5.sys to fwcutter directory [which I 'un tared' and put in a directory on the hd prior to booting Knoppix up]
then from root used fwcutter to generate the *.fw driver files in the same directory
3. then still in root copied *.fw from fwcutter directory to /lib/firmware directory
4. then did a dir /lib/firmware/ to check that file were copied properly
5. then modprobe -i bcm43xx [to install]
6. then lsmod [to check]
7. then ifconfig eth1 up [it was eth1 for me but might be something else for you or ath or ..]
[**note at this point my laptop wireless light came on]
8. turned on Kiwi .. it showed green
9. then iwlist eth1 scan [once again to check to make sure all is ok] then config network and lan cards

at this point it showed system working at 11 Mbps and I could connect to web ..
I then tried iwconfig eth1 rate 54M and got it to work but just for a few seconds .. it seems that the ieee802.11_softmac area of the driver section will not permit the higher speed .. and shuts down the wireless system .. I have not been as yet to find a command that works to disable this portion of the driver system

as an aside, in further testing today something real freaky happened, went thru all the steps, everything seem to be working and showing OK [iwconfig,dmesg and ifconfig] for the wireless BUT when I try to do a scan it tells me that eth1 is non existent and there is no network and I cannot ping out either to router or anywhere else .. so the wireless is working BUT it isnt .. spent the better part of the day trying to square this out .. removing WEP and anything else I could figure but still nothing ..
system works fine under windows ..

thats it for now ... any thoughts are welcome

08-05-2006, 12:04 PM
i too have a lot to say on this, but it's late, i am tired, and i have only been with linux for 3 days :p.

Here is a fix to your problem greywolf19:

rmmod bcm43xx
modprobe bcm43xx
ifconfig eth# up

Then you should see AP again via: iwlist -i eth# scan

I have gotten wpa to connect to router.

My hardware is acer ferrari 4005wlmi