View Full Version : List of Successful Laptops

05-13-2003, 03:52 PM
It would be most useful to those of us in the market for a laptop to have a list of machines that people are successfully running Knoppix on.

I now grub V3.2-2003-04-23-en from the HDD of a desktop along with W98. Since all new laptops come with XP, experience with XP is particularly desired.

05-13-2003, 04:22 PM
In general Knoppix should work on laptops listed here: http://www.linux-laptop.net/

If you can boot from the CD, hdinstall should work fine. Since this is the case, perhaps you should take a knoppix CD the store and try it out on the laptop before you buy. Most stores won't have a problem with this. If they do, just explain to them what a live CD is and that you want to see if this computer is linux compaible before you buy it. If they still object, tell them that you will be taking your business elsewhere.

Make sure to have a good look around once you get Knoppix up and running.

You'll want to do a "dmesg |less" as well as "lspci |less" and look for any errors. An easy way to check for compatibability is to open kinfocenter. Finally just make sure that the sound card is properly detected and works. You might need to try the ALSA drivers for some laptops though. To do this just boot with this option: "knoppix alsa"

Hope this helps.

05-13-2003, 05:28 PM
Since all new laptops come with XP, experience with XP is particularly desired.

Bah!- Please be advised that you DO NOT have to buy an OS with any computer. If the sales person tells you so then I'd bet that they also think AOL is a great service and is also the OS for Macintosh.

BTW- many new computers ship with Linux on them everyday. I do like the idea of having a list of functioning laptops tho- I'll add the wife's as soon as I can have a look at what it is. Of course we don't tell her that it boots Knoppix like a dream do we? (windows users.........)

05-13-2003, 05:29 PM
Good advice, Thank you. I've looked at linux-laptop.net and it seems to have mostly older models, not those currently in stores.

By the way, my last paragraph question about XP is answered at

05-13-2003, 06:00 PM
Until recently the only way that windows users with ntfs who wanted to dual boot with Knoppix were able to make room for a linux partition was to use some comercial application like Partition Magic. You had to shrink the ntfs partition and create an ext2/3 and swap partition with Partition Magic. The most recent releases of Knoppix include a Partition Magic like tool that should be able to do this. All you need to do is run qtparted (as root) before you run knx-hdinstall and shrink the ntfs drive. You can then just run knx-hdinstall and create ext3 and swap with cfdisk. This SHOULD work, but be advised to back up any data on your ntfs partition before you try it though.

05-20-2003, 06:59 AM
All right then- boys night out with the wife's win2k laptop. She's gonna cry when she sees Linux from RAM is faster than M$ from hdd. Anyway- Morphix booted w/ no codes on an IBM Thinkpad 2647 4MU

morph@Morphix:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 11
model name : Intel(R) Pentium(R) III Mobile CPU 1133MHz
stepping : 1
cpu MHz : 1132.403
cache size : 32 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips : 2260.99

morph@Morphix:~$ free
total used free shared buffers cached
Mem: 255296 136620 118676 0 3560 86880
-/+ buffers/cache: 46180 209116
Swap: 0 0 0

05-22-2003, 07:00 PM
It would be most useful to those of us in the market for a laptop to have a list of machines that people are successfully running Knoppix on.

I've got a fujitsu lifebook P-2120 I like a lot. It's running KNOPPIX v3.2 20030418 installed on the hard drive.

I need to pass the options ide0=ata66 ide1=ata66, but it's well documented on the linux-on-laptops site.

Since the machine has ACPI, you need to recompile a kernel to get battery statistics, and I don't have suspend to disk or suspend to RAM working.

This machine came with Windows XP, and a mini partition magic from fujitsu, so repartitioning is a breeze.

My biggest complaint is that the whiteglass cursor theme is almost invisible. You can use

sudo update-alternatives --config x-cursor-theme

to change to another cursor theme.

Does anyone know of a simpler way to change the cursor in KNOPPIX?

05-23-2003, 08:48 AM
Knoppix 2003-05-03 runs OK on Dell Latitude C-640 (also using a docking station) ... sound, video, network, all fine.


Steve Cronje
05-24-2003, 02:48 AM
Running 3.2 with no problems on my HP Pavilion xf328.

No ACPI, but APM is ok, so I can suspend from the CLI.

DVD / CDRW, networking, multimedia all OK. Have not tried modem yet, as I use highspeed connection. "Scrollwheel" on the pad is not working, but I have not made much effort to fix that, as I mostly use a USB mouse most of the time, anyway.

Most of this ran out of the box, and I did a HDD install, so I guess I can no longer call this Knoppix, but its Knoppix that made it so painless!



05-27-2003, 11:48 AM
I bought the NEC. I can run knoppix failsafe, otherwise it hangs during boot trying to find a DHCP server (whether a cable is connected or not)
The sound isn't right - it plays two seconds and repeats it endlessly needing 'kill 466' or 'killall oss' for peace.
Because I've booted in failsafe I can't use any USB devices.
a Knoppix noeth option would help me.
I have 4 distros on this laptop and not one works perfectly. Each one has bits that work well and bits that don't work well. One partition is my 'home' and another partition is swap.

05-28-2003, 12:03 PM
hp pavilion ze4360ea is running

05-31-2003, 08:40 PM
My Knoppix runs on a Siemens Lifebook S-4572.
The wheel of my touchpad doesn't work, and the modem (Lucent WinModem) most probably won't work as well, but everything else works flawless.

06-01-2003, 01:41 AM
I have run Knoppix on the Compaq 2105CA with some success. If I have a Symobl Spectrum24 WiFi card in it, the boot up stalls out, but other than that this model works fine.

06-03-2003, 07:04 PM
Sony PCG-GRZ660 seems to work fine. Auto detected the network settings and internet connection right away. Haven't tested any wireless connectivity or cardbus compatibility.

06-03-2003, 08:47 PM
I've got my HP pavilion ze4125 running wonderfully under Knoppix.

It's amazing how knoppix got everything up and running without hassle. Well, I did have the prob with my natsemi nic. That was fixed with a quick:

ifconfig eth0 up

mii-tool -r


Suse 8.2 did a good job of setting up the hardware too but the viewable desktop was about half the size of the actual screen.

I haven't got the power management going yet which brings battery life to around an hour.

After playing with the fstab file and rebooting the keyboard failed to activate once. I worked around that by repeatedly hitting the TAB button during startup as I had to do to get other distros to recognize it during set up. Don"t know why it works, but it does.

All in all, this is a god-sent for those having probs with their laptop config. And the forum could give Gentoo forums a run for its money one of these days.

Now if I can just get that location bar to work in Mozilla :?

06-05-2003, 06:59 AM
Inspiron 4100 1.0Ghz Pentium IIIm
3com 3c920 (3c905c clone)
16MB Radeon Mobility
i810 series audio (830m technically but the driver is the same)

Synaptics touch pad has not worked since Nov/Dec versions of knoppix, even with nowheel. So I have to use an external Logitech Optical Wheel mouse.

06-06-2003, 07:24 AM
Sony Vaio fx501

Boots great from CD
Brilliant HD install, great update / upgrade

Only problem seems to be the modem (not a problem for me) which I can not get going (us windows types!)

Sound not as loud as it was under XP.

Now if I could only get Evolution running .............

06-07-2003, 04:03 PM
Thanks for all the advice.

I bought a Toshiba Satellite 1135, under $800 after rebates.
Knoppix 2003-05-03-en worked in the store.

QTPARTED worked like a dream. As expected, I was unable to get the built-in modem to work. Bought a Hawking PN612 PCMCIA modem which was detected an worked out of the box.

Changed BIOS to try CDboot before HD which boots to Lilo.

06-16-2003, 07:03 PM
Knoppix 5-16-03 boots very nicely on a Toshiba 490CDT w/ 160M RAM. It even found the Belkin pcmcia NIC no problem.
Very fast with the Icewm desktop.

Harry Kuhman
06-16-2003, 08:30 PM
HP Pavilion Ze4240, Knoppix booted fine and recognized all hardware.

However, after several weeks of good network connectivity, something changed and suddenly I couldn't get to the network with the default boot.
I suspect it was the Windows XP "security update" that I had put off and finally accepted right before this happened, so far can not prove that. If you're using any notebook, but particularly a HP or Compaq notbook, I urge you to go to Scyld (http://www.scyld.com/diag/atlantic.html) and get the diagnostic for your NIC chip and save a copy of the eeprom settings before you have network problems, so you can recover leter.

06-18-2003, 03:44 AM
I have successfully completed a hdinstall of the KNOPPIX_V3.2-2003-06-06-EN.iso on my Compaq Presario 12XL125, no problems whatsoever. Specs include:

AMD K6-2 533 MHz
192 MB (PC100 SDRAM)
Trident Blade AGP 4 MB (Shared)
13.3 in. TFT active matrix (1024x768 @ 24-bit)
Via Onboard Audio

07-04-2003, 11:40 AM
Acer TravelMate 234 LC is running Knoppix 3.2 (danish version from 'tyge.sslug.dk/knoppix' from april) when booting 'knoppix noapic'.
Hd install also ok - then the linux boot entry in lilo.conf must contain the noapic kernel option.

Have not not tried USB and modem yet. The rest works ok.

Knoppix is really a nice thing. Just tell your pc vendor that you won't buy before he has booted the machine successfully with the latest knoppix :-)


07-08-2003, 09:03 PM
I've got a Compaq Presario 710US, 1GHz, 256mb, Ethernet, DVD, running Windows XP. I want to dual-boot with Linux, and was originally going to use Red Hat, but someone suggested Knoppix. Anyone know what problems I might face or willing to give me some extra info?

07-08-2003, 10:19 PM
I've got a Compaq Presario 710US, 1GHz, 256mb, Ethernet, DVD, running Windows XP. I want to dual-boot with Linux, and was originally going to use Red Hat, but someone suggested Knoppix. Anyone know what problems I might face or willing to give me some extra info?

Enter your machine model number into G4L (http://www.google.com/linux) and see what you can learn. Enter it here in the search field too. Then you pretty much just need to boot Knoppix and see what happens. That's the beauty of Knoppix- you don't have to install anything before you try it. Compaq's can be a little temperamental as I understand it.

07-10-2003, 01:54 PM
With a Compaq Evo N1050v, Knoppix works fine

07-12-2003, 11:48 PM
Just setup a dual boot Knoppix/XP laptop on a Averatec 3150HS Notebook computer.

The sound isn't working, but I'm sure I can fix that. AND, I'm glad that QTParted came with Knoppix because Partition Magic wasn't doing its magic with NTFS.

Here is a URL that has more info about this laptop


07-14-2003, 01:03 AM
It works fine for me on KDS Valiant 671XH, 20 GB HD, 512 MB RAM, DVD/CD-RW (I haven't yet tried to burn any CD's), but I can't figure out how to get a password to change the date and time; nor how to make my wonderful Logitech Trackman Portable (3 button; PS/2) work!

07-14-2003, 03:18 AM
I have a Toshiba Satellite 1415-S173 and Knoppix works right off the bat. I just have to change:

xkbset bouncekeys 20
xkbset slowkeys 20
xkbset -bell

and set up my orinoco wifi card.

After that, everything works fine!

07-15-2003, 06:13 AM
For whoever is compiling a list:
Compaq Presario 1700N
- 700MHz PIII
- 128MB RAM

Toshiba Satellite 1555CDS
- 380MHz AMD K6-2
- 190MB RAM

These two work, no codes; you may want to manually set the res on the Toshiba to 1024x600, just because it has a weird display adapter.

Powerbook G4 550MHz (For the guy who mentioned Mac. ^_^)
- 550MHz G4
- 1028MB RAM
- Virtual PC 6 Emulator

Erm. See my post on this one. It's trippy, but it works.

07-17-2003, 09:54 PM
:shock: hay it work with my toshiba . :D

07-23-2003, 06:44 AM
Fujitsu i-book 4177
500mhx celeron
4mb ati rage 128

I run win2k and redhat 8 on the hard drive.

I boot with the codes
knoppix fb800x600 xvrefresh=60

Someone asked how to change cursor themes earlier. I made a ~/.icons directory and put the folders of a silver cursor theme in there and it worked fine for that user. Here's the theme I used from kde-look.org


I also had to edit /etc/X11/XSession.d/45xsession and add .icons to the list of inital profiles copied to the $USER's home before x is started for it to work in my remastered cd.

07-27-2003, 05:15 PM
Works fine on Compaq EVO 1020V
knoppix noscsi
code on Dell Inspiron 2650

08-04-2003, 11:49 PM
Used v3.2-2003-07-26-EN on Dell Inspiron 4000 without problems (512 Mb RAM, 8mb ATI Mobility 3 video card).

08-06-2003, 07:50 PM
:D Knoppix 3.2 runs great on Compaq 2811EA.
Some minor problems:
- Xmms freezes. It seems that sound isn't working. But it works on FrozenBubble game.
- Microsoft Explorer mouse work, but it clicks even when i'm not using it. Very strange.
- Touchpad works! :)
- My cablemodem works! :)

08-06-2003, 07:52 PM
- Xmms freezes. It seems that sound isn't working. But it works on FrozenBubble game.

Try in a console window ps xa | grep arts find the number it returns for the artsd sound daemon and then in the console window kill number_of_process and XMMS should now work.

08-07-2003, 02:21 PM
Try in a console window ps xa | grep arts find the number it returns for the artsd sound daemon and then in the console window kill number_of_process and XMMS should now work.[/quote]

I'l try that later. Thanks.

08-14-2003, 09:15 AM
Toshiba Tecra S1 (centrino)
works fine, find everything, no real problems except wireless, then again, we all know that intel is /supposed/ to come out with drivers for linux for it. pesonally iswitched to knoppix to be able to experience some linux, and wardrive/wep crack with better tools. and was dissapointed the the most nessicary component doens't work. no one's fault (possibly intel's) but i'm gonna go pick up a orinoco gold and external antenna instead.

usb thumb drive to store my home...had some strange issues with it, but reformatting it fixed it(although i lost some config's)

~Eric Betts

08-14-2003, 06:19 PM
my compaq presario 900 laptop got linux running without a problem.
it was impossible to install redhat but as soon as i tried knoppix everything worked. booting off the cd i had to use the nousb cheat but thats about it.

the only complaint i have is that there is no 3d accelleration for my ati mobility UI vidcard.

08-17-2003, 12:33 AM
my compaq presario 900 laptop got linux running without a problem.
it was impossible to install redhat but as soon as i tried knoppix everything worked. booting off the cd i had to use the nousb cheat but thats about it.

the only complaint i have is that there is no 3d accelleration for my ati mobility UI vidcard.

I too got Knoppix working with the nousb cheat on my Compaq 900Z - then I actually got the conexant modem working after a hard drive install - no If I could just get 3d acelleration, I'd dump winblows forever! Any ideas when #Da will be available?

i r n00b?
08-17-2003, 02:06 AM
I have IBM T40 with the Intel Pro/Wireless card it boots into Knoppix jsut fine but the wi-fi doenst work. If anyone knows how to get that to werk THANK YOU!!!!


08-22-2003, 11:46 PM
- Xmms freezes. It seems that sound is n't working. But it works on FrozenBubble game.

Try in a console window ps xa | grep arts find the number it returns for the artsd sound daemon and then in the console window kill number_of_process and XMMS should now work.

Stephen, sorry for the delaz.
I still can't listen to my mp3 with knoppix :( XMMS still freezes...

Thanks for the help


08-23-2003, 01:59 AM
I still can't listen to my mp3 with knoppix :( XMMS still freezes...

Thanks for the help


Try using lsof /dev/dsp to see which process is using the sound device and kill it off. You may also want to see which output device is being used by XMMS go to options then preferences look at the output plugin and it should be using OSS.

08-25-2003, 04:43 PM

knoppix installed without ANY trouble,
but you need to hack a bit for optimising your system ...
see http://rzr.online.fr/linux.htm

Remaning questions are :

* Kernel : what is your /usr/src/linux/.config and /etc/modules for 2.6* ? what are needed modules for touchpad and keyboard ?
* Graphics : did you build the patched release of kernel & X for dri (3d) ?
* What other os are working on it (including windows beside preinstalled fujitsu edition of win XP home)
* Modem : how to make it work ? which driver to use ?
* Sound : midi ?
* Power Management : how to optimise this ? how to toggle screen on standby (acpi) ?

# lspci
00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab0 (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc U1/A3 AGP Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:03.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem]
00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:06.0 Bridge: ALi Corporation M7101 PMU
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0a.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:0b.0 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 01)
00:0b.1 CardBus bridge: ENE Technology Inc CB1420 Cardbus Controller (rev 01)
00:0f.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1

08-25-2003, 08:24 PM
I've got my HP pavilion ze4125 running wonderfully under Knoppix.

I've tried pming you but the page is down(404 page not found error), Could you PM me if you get this message???

I was having problems with my nic (same exact laptop), but it works fine now but my wireless...its a microsoft card, yeah I know, but its got the prisim-32 chipset and I think that's all I need to be good to go, but when it boots, it sees the card,and then boom freeze on the loadup right when it recognizes the card.


08-26-2003, 10:20 PM
I still can't listen to my mp3 with knoppix :( XMMS still freezes...

Thanks for the help


Try using lsof /dev/dsp to see which process is using the sound device and kill it off. You may also want to see which output device is being used by XMMS go to options then preferences look at the output plugin and it should be using OSS.

After several hours trying to hunderstand a bit of this i finally got it!
In XMMS preferences i putted the right audio device>/dev/dsp1 (it was /dev/dsp)
Ißm listening to the Crystal Method mp3 album right now :)
Thanks a lot! :D

08-27-2003, 10:03 AM
Compaq presario 1020 - 120mhz pentium, 32mb ram, 4.8gb hdd

Knoppix 3.2 seems to run fine when booted from cd. Everything looks like it's working but is unable to detect my pcmcia 3com 10t etherlink III card. Anyone have any ideas on how to get my lan card working?

08-29-2003, 11:22 PM
Ran the CD and the install on an HP 4325. No big problems.

With the kernel provided by the cd the cpu ran hot and the fan was at full blast. Best thing to do is to download and compile the 2.4.22 kernel which has acpi built in and gives you a chance to change from the generic cpu settings to Athlon. Nice speed increase too after setting the cpu correctly. You just have to be sure to say yes to all the elements that you want for acpi. Now it runs much cooler and quieter and I can see my battery monitor automagically.

Best thing for booting and boot to install is to set the video to fbdev. It seems to look better than vesa.

Sound works fine, video is fine, the nic is fine, acpi is good, and the modem works too after some tweaking. Not a bad experience at all and forget about having to turn off Legacy or pcmcia. That's for other people to deal with.

Well, I'm off to get some work done on my new Linux laptop.

Tom Tiger
08-30-2003, 11:35 AM

I'm not sure who is compiling a list but here is what I've
tested Knoppix on. (except for some wireless problems, internal 10/100mb networkcards all work) For some models with the GEforce
you will have to use the cheatcodes to get a full screen.

Knoppix version used, 3.2 exp iso 06-06

Toshiba notebooks,

Satelite pro 4200 (all of the series 4270 ect.)
Satelite pro 4300 ( all of the series)
Satelite Pro 4600 (all models)
Satelite Pro 6000 (all models incl. 6050 and 6070)
Satelite Pro 6100 (all models)
Satelite Pro M10

Tecra 8000 (all models but no sound)
Tecra 8100
Tecra 8200
Tecra 9000
Tecra 9100

Tecra S1
Tecra M1

Satelite 40x0 series (4030 to 4090)
Satelite 4100

Satelite 5000, 5100 and 5200

I'm running it at home on a Satelite Pro 4270 and 4280

Hope this helps, Tom

09-06-2003, 07:03 PM
I have a SAGER 5650 and EVERY version of knoppix works with it and I got version 3.1 installed along with XP PRO and I had to configure only the WI/FI I now have version 3.2 and that installed great the only problem I got is that it don't shutdown correctly so I have to do a shell reboot.. but other than that It works great...

just for info...

CPU: P4 mobile 2.2Ghz
RAM: 512MB PC2100
HD: 40Gb
Video: ATI Radeon Mobility 7500
Screen: 15"

09-09-2003, 07:50 AM
Here all working laptop


add yours if not in the database.

webmaster -> Could be good to work together with our database.
join me be e-mail.

09-10-2003, 02:10 AM
At work I have run knoppix on Compaq n600c, n610c, and e500 I did not see the 600 at the above site. Also on a Toshiba satellite 1805-s154 at home.

09-23-2003, 08:48 AM
I installed knoppix on
Compaq Armada 1570, no sound but everything else is fine
Toshiba Portege 3020ct, I had to deinstall sncdconfig and install the woody version to get the sound to work, but now everything is great.
HP Pavillion Ze4500, resized NTFS using BootitNG, installed everything straight away. (note OEM XP home crashed twice in two weeks before the knoppix install, great promo for knoppix)

I am not allowed to install on
Dell Inspiron 4000, CD Knoppix works.
Compaq Armada 4000, CD Knoppix works.

I'd love an interactive tool for wireless configuration instead of the jumble of tools at this point.

thanks Klaus and everybody else involved

09-23-2003, 12:20 PM
Running Linux on several laptops here, plus I have installed it on plenty of others.

IBM Thinkpad 600E
You need to flash the BIOS to an updated version since the original will NOT boot Linux (or even Windows 2000) because of a flaw in the original BIOS. After flashing everything went extremely well. Although it's only a 366MHz/192MB model it is fully adequate for running most stuff. I run Fluxbox because it's nice and responsive on low end systems.

Dell Inspiron 800i
No problems, I had to recompile the kernel to get support for the special features but no other issues. 1600x1200 resolution in X is awesome. :-)

Dell Latitude CPi300XT
No issues at all. This baby was born to run Linux. It's a bit dated and I had it replaced by the TP600E but it's still very usable.

Macintosh PowerBook G3 WallStreet
This baby ran just fine. Both Yellowdog and Debian-PPC installed flawlessly, but you need to specify some options for the framebuffer module in the bootloader, otherwise it won't look pretty at all. :-)
I have one problem with this computer: It's got ONLY ONE FRIGGEN MOUSE BUTTON! Arrrgh! LOL


09-24-2003, 01:07 AM
v7-26-03 on Dell Inspiron 3800, Bios A09, 700MHz, PIII M, 512MB Ram, 8MB ATI Rage Mobility, ESS Maestro 3i..........All worked great except modem. Installed Creative Lab v90 pcmcia modem and have had no problems since. I need to mention, I haven't tried the cd burning stuff.

09-26-2003, 04:03 AM
Tom Tiger, you stated that basically everything worked for the Toshiba Satellite 5000 series. I'm curious to know how you got the sound to work, as I am currently having trouble with that. Thanks very much for your input.

09-26-2003, 11:09 AM
If anybody gets it running on a Dell 300m let me know. I'm having problems getting it to boot. It seems like the docking station cd-rom isn't recognized and it cant find the knoppix files

Tom Tiger
09-28-2003, 02:17 PM
Basicly nothing, I just ran the cd and it picked up the sound
card without a problem. On one of the 3.2 exp iso's I did have
to use the cheatcode ALSA, but I don't know which one that
was. 3.2 iso 06-06 doesn't have a problem with it.

Did you get a soundserver error?

L8tr... Tom

Tom Tiger, you stated that basically everything worked for the Toshiba Satellite 5000 series. I'm curious to know how you got the sound to work, as I am currently having trouble with that. Thanks very much for your input.

09-30-2003, 05:09 AM
Tom Tiger,
Thanks for helping me out. I tried the ACPI and ALSA cheat codes, but unfortunately neither of those will get me any sound. Everytime I always get some error sayin how my IRQ is not set, or something like that.

I think it's also interesting to note that sound works with SuSE live eval 8.2.

I found a .diff patch file that might solve my problems at http://sourceforge.net/projects/acpi

but I have no idea how to apply this patch. Can somebody help me? Thanks.

Tom Tiger
09-30-2003, 11:36 AM

Please check your bios and make sure that the 5000 is running
in boot mode and not in resume mode. Also look in the bios
if the system is set to setup by OS or not.

L8tr... Tom

10-04-2003, 04:59 AM
Compaq EVO N620C has been fine for some time. Only a small intermittent IRQ sharing problem. :lol:

10-05-2003, 07:42 AM
I did a hd install of Knoppix on a Gateway 400 SD and it works great. I have two issues, first I have to use the noscsi cheat code and i have to shutdown in a shell or it will hang. Other than that it works great.

10-05-2003, 08:11 AM
and i have to shutdown in a shell or it will hang.
Try either noapm or noacpi to see if that helps.

10-05-2003, 11:42 AM
I have installed Knoppix 3.2 on a ECS Desknote A907 (with Transmeta processor)
Runs fine. Very cheap laptop : I have paid 516,- euro

10-20-2003, 05:37 AM
Knoppix 3.2 works well on the Desknote 901A (http://desknote.net/a901.html). There is a sound problem with the trident driver (possibly caused by interference from the CD-ROM?) so using the nosound cheatcode at bootup is recommended. The problem does not affect hard drive intstalls.

10-31-2003, 01:57 AM
ACER TM661: (CPU Centrino 1.4 GHz, RAM 512 MB, 14" Display)
Works OK with Knoppix 3.3, even the BM440 10/100 ethernet card.

PS: I have not tried the IR and WiFi connection.

10-31-2003, 09:03 PM
I just got it working on my new ECS A929 desknote.

had to use the cheatcode

knoppix noapic

or else the sis900 NIC would not work.

11-01-2003, 12:46 AM
I installed Knoppix 3.3 on my Acer Travelmate 800lci, and it works great!. I even got the Centrino wireless network card using the Linuxant driver loader, and the suspend to disk using the swsusp patch.

Great job guys!

11-06-2003, 06:39 AM
Hp Pavilion ze5385us

Knoppix v3.3 CD boot.
All but ACPI works..... and eh... who need a battery monitor if I'm booting off the cd? (Well, I do. But I can't complain!)

11-12-2003, 03:13 PM
Compaq Presario 700/710/722US (three seperate laptops, only difference is onboard ram and processor speed, go figure)

Knoppix itself works perfectly from the get-go, no cheatcodes. Only problem is lack of acpi, since these laptops are 100% acpi.

That means no battery status (it says On AC, no battery all the time,) it runs really, really hot, and the fans run at full speed constantly.

I assume if you install it to the hd and get the kernel acpi diff, it will work (or so I've read)

My laptop is a Presario 710US motherboard with slower proc (friend ran over hers with a car, I got it for parts and made mine better!) so the specs are:

AMD Duron 900 M, 64K cache
512MB of ram with 16MB shared for video (love the 710 motherboard :D )
20GB hd
Onboard realtec nic
Onboard HCF 56K soft-modem

I'll be installing it to the hard drive probably later today (have to get a friend to download and burn 20031103, i don't have broadband :( ) and I'll report back with my success or failure with acpi!

11-17-2003, 10:23 PM
Completly new to Linux as of last week sunday.

Over 2 weekends I did various HD installations with Knoppix 3.3 on a couple of very old laptops, a Gateway solo 9300 (433Mhz celeron [Mendicino], 288M ram) and an IBM 770 (233Mhz, 128M ram).

The 770 was from a friend and had the original Modem ripped out so I couldn't test that.

The Solo has a built in winmodem So I needed to by a new PCMCIA modem.

Other than that I had no problems at all. Pretty much everything is supported (You need to start the IBM with the fb1024x768 cheat when booting from the cd).

I still haven't tested Firewire on the Gateway though.

While I was installing Knoppix on the laptops I thought I would give RH 9.1 a run on my desktop PC. It took all of 30 minutes for me to delete that install Knoppix over there also.

12-03-2003, 12:30 AM
Installed 3.2 on a Toshiba p15-s409......quick, simple install. Everything works, except the integrated 802.11g, and I'm sure my lack of knowledge or lack of time, lately, is adding to that. I've tried the madwifi driver and have looked at the linuxant driver, but I think that it is the wrong chipset. I guess that I will give it time. Otherwise....Knoppix is great.....it is the 4th distribution I put on this laptop.....and the first with which I'm entirely pleased.

12-30-2003, 06:28 PM
installed knoppix 3.3 (updated with script from http://kano.mipooh.net/kernel/ to include ACPI and taking to kernel 2.4.23), it works in my system: IBM Thinkpad R40e.
but now, the special buttons do not work (it worked properly in the original version of Knoppix 3.3, i.e. kernel 2.4.22 but no ACPI)

: :?

01-05-2004, 12:08 PM
:D I got Knoppix 3.3 11-14-2003 working on a thinkpad 770x. I had to use 1280x1024 to get the exact lcd settings. Alsa sound does not work.I got OSS sound using the CS4232 driver with this settings io=0x530 irq=5 dma=1 dma2=0 . I alsa installed it successfully. APM suspend works . I could hibernate using redisafe feature of thinkpads.

01-06-2004, 10:30 PM
Just a quick note about my success so far with Knoppix 3.3 on Acer Travelmate 230XC.

After changing the default allocation of memory for the video (in BIOS) from 1MB to 8 MB, it boots cleanly, no cheatcodes necessary, to 1024x768 resolution.

With these two exceptions, everything else works

Realtek 8139 NIC not working (although it seems to know it is there)
i810 sound is detected, but fails to load (similar problems with alsa as well)

01-09-2004, 03:39 AM
Just a quick note about my success so far with Knoppix 3.3 on Acer Travelmate 230XC.

After changing the default allocation of memory for the video (in BIOS) from 1MB to 8 MB, it boots cleanly, no cheatcodes necessary, to 1024x768 resolution.

With these two exceptions, everything else works

Realtek 8139 NIC not working (although it seems to know it is there)
i810 sound is detected, but fails to load (similar problems with alsa as well)

Update: realtec 8139 NIC works fine if I add the 'noapic' cheatcode when booting

antonio fratucello
01-09-2004, 06:41 PM
working on a ecs desknote A928 - 15" lcd, p4A 1,6ghz 512kb cache (overclokked)@1712mhz :shock:

no problem at all

Li Gwai Lo
01-15-2004, 05:46 PM
I am posting this from an Ace TravelMate 340T with 128MB, using a USB keyboad, currently running Knoppix 3.3 2003-11-03-EN. :)

On boot, it behaves a little oddly -- I just hit the enter key at the boot prompt, but it tells me that I have entered an invalid video mode and demands that I tell it whether it should boot up 80x25 etc., ignoring that and hitting enter a few more times makes it bring up X11 correctly. Ethernet is working, sound is working, so is USB. (The regular keyboard works fine as much as it ever would, but the spacebar is broken, which is why I'm using a USB keyboard instead.)

It has a built-in winmodem, don't know if it would work or not (I may try it in a few weeks when I have more time).

01-24-2004, 03:37 AM
I've got Knoppix 3.3 working on a Toshiba Satellite 2710XDVD, PIII-500 with 192MB memory.
The only needed cheat is vsync=60 to get from 800x600 to the full 1024x768 screen.
It recognised the PCMCIA network and memory cards fine.
Still have to test the USB Freecom CD burner

01-29-2004, 12:00 PM
perfect on an HP XE3 Celeron.. everything works w/o any cheat codes..
audio, modem, video, dvd, usb, tv out etc..

Happy hacking,

01-29-2004, 12:51 PM
Nothing to say except everything WORKS!!!!
no cheat codes needed !!!!
How I wish I had USB2 !!!

02-05-2004, 02:16 PM
I've got a Dell Inspiron 2650, Pentium 4-M 1.7GHz, 512 MB, 20GB HD, 32MB NVidia GeForce2Go and I originally had a problem loading Knoppix. It would stall out and not load after the initial install list. I used the cheat code "noscsi" and damn if it didn't work. I've had no problem since then have have been able to setup a home directory on an external USB hard drive.


02-07-2004, 02:57 AM
I'm using an ibm t30 with a netgear ma401 pcmcia wlan card and a jetflash 128MB usb memory stick. No problems whatsoever. The wlan card was automatically configured and got a DHCP address from my FreeBSD AP.

I have an encrypted hard disk, so there is no possibility for swapping there. I also have 768MB RAM, so that's not really a problem. Booting knoppix toram worked, but I was unable to start X. Now, I'm just running from the CD.


02-10-2004, 05:27 PM
Works and (HD) installs on an Acer TM803LMi, 1.6GHz centrino, 512MB ram, ati radeon 9000 with 64MB of ram, dvd-r writer, 15" 1400x1050 resolution, broadcom NIC.

Clearly wifi doesn't works out of the box.
Still have to try the nDisWrapper project,

02-12-2004, 07:53 PM
Gotta Micron Transport XPe p166, 32 Mb RAM 2 Gb Hdd to run Feather Linux. Needed to noscsi to get it to go. Used zero at the video foolishness that comes before running the kernel. Other options in Feather were VESA, 800x600, 16 bit depth. Haven't gotten sound to work yet.

Tried full knoppix but it hosed up my video and ran too slow. Feather is adequate for my needs

02-14-2004, 11:40 PM
Works great on both of my Vaio's.

PIII 1 Ghz, 512 Mb ram, 20 gig hd, i81(0/5) graphics (8 megs), usb thumb drive, firewire (used Kino for DV editing), AC97 sound driver, & HCF/HSF linuxant modem driver.

PII 366Mhz, 128 Mb ram, no hd, Neomagic 4 meg video, can't remember the audio but it is better than the FX300, HCF/HSF linuxant modem driver, firewire (haven't used for any DV due to slow chip speed), usb thumb drive.

With the 2.6.2 kernel APM/APCI works great. I also have the SonyPI keys going so when I unplug I can slow down both CPU's with cpufreq, and also I can dim the screens. With the FX300 I can go about 4 hours unplugged doing only word processing (3000mAh batt). I will be getting a second batt for it. No battery in the F350 but I will be getting 1 or 2 for it as well.


02-22-2004, 04:12 AM
I have a Gateway M675XL and everything works great on it except the sound it uses the i810_audio with the ac97_codec and the only way I can get sound is if I plug speakers or headphones into the microphone jack.

02-23-2004, 03:27 PM
Fujitsu c-series lifebook and the n-series, might I add it is a lot easier than debian .0121 to install.

02-24-2004, 08:10 PM
Wow working on a Presario 1722EU

Not only is everything working my wireless g pcmcia card (SMC) is working with the last release 2-16.... How cool is this! :lol:

03-04-2004, 11:01 PM
Dell Inspiron 8200
P4-M 2.0GHz
Intel 845MP
Crystal CS4205 audio controller
15" UXGA screen
GeForce4 440 Go video controller
512 MB RAM

Everything works great! I just use screen=1600x1200.

(please note, so far, the bios for this model does not support boot from usb or firewire. hopefully a future update will address this.)

03-04-2004, 11:55 PM
Dell Latitude D600
Intel Centrino 1.6 GHz CPU
Intel PRO/Wireless LAN 2100 802.11b card (still not working)
14.1" SXGA+ Display
8-24-24-24X SWDVD/CDRW Combo Drive
Internal 56k modem (Untested)

Everything I want works great EXCEPT the Intel Centrino-based 2100 wireless networking card.

Any suggestions on how to get that going, would be appreciated.

03-07-2004, 01:58 PM
i have got Knoppix working in a compaq 5150 (p1 100Mhz 74Mb ram) and a Acer Aspire 1302, both work well (the compaq is slow in X but...). wish the Acer was mine :sigh:.

03-16-2004, 10:43 PM
IBM Thinkpad 600. Sound needed some tweaking but works using the OSS cs4232 driver.

IBM Thinkpad 600E. Again sound didn't work out of the box. CS46XX driver, not tried yet though.

Acer Travelmate 212TX. Sound works without any tweeking

Keyboard/Video/Mouse works fine on all the above.

Acer Aspire 1705SMi
Boots. Video defaults to 1024x768 rather than the correct 1280x1024.
Synaptics Mousepad & keyboard worked fine.
Onboard Eth detected but would not initialise
Didn't get the onboard wlan or sound working (but didn't try too hard)

03-20-2004, 12:57 AM
Itronix IX-260

Needed to use noagp at boot up and celluar and WiFi adaptors don't work along with battery not being detected but everything else seems to work.

03-26-2004, 10:32 PM
Vobis Power 2000+ XI
Mitac 8375
Xterasys CX-8375
similar to
Acer Aspire 1310 Series
Acer Aspire 1312LC

fb1024x768 xmodule=vesa xvrefresh=60

everything but the modem is working since September 2003

with knoppix 3.2 and with 3.3 installed on harddisk

03-27-2004, 12:09 AM
Acer Aspire 1353 with Maxtor 160GB external Harddisk everything worked fine.

Dlink blue tooth dongle didnt work.

Durand Hicks
03-27-2004, 04:35 PM
IBM Thinkpad T21 2647-4AU
512 RAM
Intel Etherexpress Pro 10/100 ethernet card.
20 GB hd
DVD-ROM drive
PS/2 mouse (Usb port broke)
Linksys WPC11v.3 802.11b pcmcia wireless card
Knoppix installed to hard drive.
2.4.24 custom kernel with cpufreq, lowlatency, preempt, and secacl patches, no xfs.

Everything works and with the custom kernel I built, I get the best of 2.4. and 2.6 kernels. Suspend, cpufreq, and watching DVD movies all work great. Wireless works without having to remove the modules before suspending. Captive-ntfs works great for reading/writing to ntfs drives. Default window manager is Enlightenment DR16 with KDE support.

Haven't tested infrared or the modem, but both aren't high priority items at the moment.

03-28-2004, 12:09 PM
i just installed knoppix in my AOPEN 1545...

all seem to be in order... but only time will tell :lol:

04-01-2004, 04:31 PM
IBM thinkpad A20p worked perfectly: dual boot XP and Knoppix. Everything in knoppix works (video, sound, network, wireless connection). No complaints from me. Great job everyone who has played and continues to play a role in this project.

04-10-2004, 12:31 PM
Knoppix3.3 is working via cd but when perfroming HD install screen comes up with to large settings, not sure how to solve this. Tried XF86Config-4 file but no luck, will perform new HD install

04-10-2004, 02:09 PM
I got Knoppix 3.3 and many other remasters (Overclockix, Danix, STD, ect.) working on my Alienware Area 51-m.

P4 2.8 Ghz
ATI Radeon Mobility 9800
Realtek WLAN card (Atheros based, I had to do a ton of messing around to get it to work, ended up with the Linuxant Driver Loader because madwifi and NDISwrapper didn't work.)
20 GB Harddrive
1 GB or RAM
Knoppix installed to Harddrive
2.6.5 Kernel Recompile, i love the newer features.
DVD-RW Drive, (haven't tested yet, I don't really have a need for it right now.

It also auto-detects and installs drivers for my Remote Control that comes with the system that works through infrared.

04-10-2004, 11:51 PM
knoppix 3.4 works nice on my Laptop which is HP Pavilion ze5375us. It uses VESA mode(1024X768) for X since my laptop has a Radeon IGP 340M graphics chipset.
Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller which worked right out of the box.(Mine is a DSL connection)
Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device works wonderfully well. Far better than the existing Windows XP home installation.
Soft keys for Num pad, LCD brightness works excellent in 3.4.
The onboard Wireless LAN(Harris Semiconductor Prism 2.5 Wavelan chipset) works well to. Not sure about the onboard Modem which is a ALi Corporation Intel 537 [M5457 AC-Link Modem]

Overall a very excited Knoppix user. I have recommended that to a number of my friends.
Good luck.

04-12-2004, 03:44 PM
I took a Knoppix 3.3 CD and a Kanotix Bug Hunter CD down to the local Circuit City on Friday. After deciding which laptop I was interested in (HP Pavilion zv5120us), I convinced the sales associate to let me reboot it with the Knoppix CD in it. Knoppix booted up flawlessly. :D The sales associate was quite impressed and started asking questions. He even jotted www.knoppix.net down on his hand!

Long story short, I repartitioned the HD to give WinXP 20G and Linux 20G, did a HD install from the Kanotix CD, and am currently running apt-get upgrade. The only issues I've had so far are:

1. Sound worked fine when running from the Kanotix CD, but didn't work after the HD install. After about 20 minutes of tweaking, I've got sound working.

2. X is running at 1024x768. I suspect I'll need to install drivers for the ATI Mobility™ Radeon™ 9000 IGP video card to get the preferred 1280x800 resolution out of it.

3. Need to be able to play DVD's in the DVD-ROM/CD-RW combo drive. I haven't investigated this one much.

I haven't tested the built-in wireless, but the onboard LAN card is working fine.



04-20-2004, 01:56 AM
Knoppix 3.3 with HD install on a Sony Vaio PCG-GRT100

Intel P4 2.8
NIVIDA gforce4 420 Go Sony onboard video card
512 megs RAM
SigmaTel Major-C onboard sound card
Linksys WPC54G Wireless Card
USB Floppy Drive

NIVIDA drivers installed for graphics card 1024x768 24 bit color

ndiswrapper 0.6 installed for WPC54G Linksys Wireless Card

Sound doesen't work... Still trying to figure that one out. Locks up
knoppix when sound is played.

Cheatcodes at startup: noapic nosound

So far so good.... Love it !!!!! 8)

04-20-2004, 07:04 PM
HOORAY I have been able to get the latest Knoppix 3.4 running on my Compaq Presario 2170CA using the following:

linux26 acpi=off noscsi
I am left with two problems.
1 - I must use the power button to turn off the machine. ( further reading indicates adding noacpi to the startup line will fix this)
2 - My USR 5410 wirless network card is not supported. (not a laptop issue but just though I'd mention it.)


I have run 3.2 and 3.3 on my Compaq Presario 2170CA.
It has an AMD Athlon 2200XP running at 1.8Ghz.
Everything works now however I did have problems as follows.
Compaq has chosen to encapsulate power management inside the Windows XP supplied with the machine. As a result, when initially running 3.2, my laptop got very hot. This was because the fan speed control was missing and on power-up the fan speed is set to slow or off.
Compaq was very evasive about the problem until I noticed the same thing happened if I put a blank floppy in and turned the unit on.
A subsequent email to compaq generated a request to update the bios.
The updated bios now causes the machine to start with the fan on medium/high speed which is good but now the 3.2 would not boot.
I then tried 3.3 which did boot almost perfectly. The exception was with the ethernet adapter. It was necessary to restart network support to get it to work whereas previously, it came up during boot.
The latest version 3.4CT of Knoppix has resolved this issue when the 2.4x kernel is booted.
The Knoppix26 option (or any 2.6kernel option) does not boot but then this isn't the official release any.

04-24-2004, 12:30 PM
Knoppix worked so well from CD that I installed it on the hard drive on my Thinkpad T-22 along with my XP Home Edition. I also installed it to the hard drive on my PC. I boot it from floppy because it was already dual boot running XP and RedHat. I find myself booting from the floppy a lot of the time.

user unknown
05-03-2004, 06:17 PM
sony vaio fx601
knoppix 3.4
kernel 2.6.4

modem worked for kernel 2.5, but stopped working with the new kernel-module-handling (linuxant würg-modem) .
I stopped investigating on this because I changed to adsl, which was a very easy install!

Using sound and modem has been problematic with 2.5.0-kernel. Since I seldom use sound I didn't configure it with the new kernel.

APM and ACPI don't work as expected, but this might be an issue of lazy manual reading.
On Page 6, a vaio-user claims to use it successful - well I might ask him what he did.

Due to missing hardware I never tested the firewire-possibilities of this notebook.

Setting up my printer (canon bjc3000) has always been a problem with linux, since canon doesn't support linux. Together with turboprint it now works fine. (parallel-port and usb).

My main tasks are running eclipse ( -3.0.0-gtk-M8) which works fine, and java-1.5.beta (fine too).

dsl: arcor-dsl-speed-modem 100
logitech usb-optical-wheel-mouse
eth0: rtl-8139

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 1a)
00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 1a)
00:07.4 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
00:07.6 Communication controller: VIA Technologies, Inc. Intel 537 [AC97 Modem] (rev 30)
00:0a.0 CardBus bridge: Texas Instruments PCI1420
00:0a.1 CardBus bridge: Texas Instruments PCI1420
00:0e.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64)

05-03-2004, 06:36 PM
Realtek WLAN card (Atheros based, I had to do a ton of messing around to get it to work, ended up with the Linuxant Driver Loader because madwifi and NDISwrapper didn't work.)

I have been able to get Knoppix 3.3 working on a Dell Inspiron 8000, but the wireless card (d-Link) does not work. Is there anywhere I can get a copy of Knoppix with Linuxant Driver Loader? (I don't know how to remaster a cd, linux newbie).


05-05-2004, 10:56 AM
Benq Joybook 8100

- Runs Knoppix 3.3
- Runs Knoppix 3.4 (using the cheatcode knoppix acpi=off)

I still have yet to get my Centrino wireless running with either versions. If anyone is having any better luck, mail me at headshot_001@hotpop.com. It would be apprecited.

James Brooks
05-06-2004, 04:01 AM
Successful CD boot:


Compaq Presario 2100 Series
1.4G AMD Athlon XP-M
256M Ram (shared with vga to 192M)
30G HD, built in floppy, usb, firewire, etc

With no command line the screen goes blank immeadiately after the initail boot screen.
To boot properly, use one of the following command lines:

knoppix acpi=off noscsi
knoppix26 acpi=off noscsi

acpi causes initial blank screen/no boot.
scsi probe must be disabled to avoid is seg faulting.



05-06-2004, 10:57 PM
Working setup
IBM ThinkPad R40 2897 - Pentium M 1.4 GHz - RAM 256 MB - HD 20 GB - CD-RW / DVD - Mdm - LAN EN, Fast EN, 802.11b - 14.1" TFT

It has the builtin centrino 802.11b wireless. It worked perfectly. All I had to do to get it to work was type in

iwconfing eth0 essid "myessid"

and then run the network card configuration

05-07-2004, 08:31 PM
Toshiba Satellite 5200 series (PS520C-31P0EP)
Mobile Intel Pentium 4 - 2G, 512MB RAM, 40G HD


Boot up with Knopppix 3.4:
Linux 2.4 - no problem (just hit the return key)
Linux 2.6 - requires "linux26 noscsi"

With both Linux 2.4 & 2.6, the Hotkey "Fn" function is not working. One result is that on bootup, the display brightness is set at minimum and it cannot be adjusted any brighter. So the 15" UXGA display is quite dim.

The default display resolution on bootup is 1,600x1,200 (it's native resolution, I believe). However, it can be changed to 800x600 at the bootup command line with

05-14-2004, 09:15 AM
Doesn't boot on an IBM Thinkpad X31. It hangs on when mounting filesystem...

Any idea? Mandrake Move starts fine!!

05-14-2004, 07:58 PM
Knoppix 3.4 5-10-2004 boots wonderfully on my Inspiron 5100.

Performed HDD install, both the 2.4 and 2.6 kernels run wonderfully on it :)

Laptop dual-botos Winblows XP Home and Knoppix

Thank you Knoppix!

05-19-2004, 07:22 PM
Compaq/HP nx5000 (1.4ghz Centrino, all new stuff)

Knoppix 3.4 booted great - detected (via lspci) my Broacom 10/100/1000 BCM5705M but didn't load drivers for it... also detected the INtel IPW2100 WLAN adapter, but again, nothing loaded for it...

Have to try in 2.6 (that was 2.4)

05-20-2004, 02:56 AM
Everything seems to work on my Toshiba A45-S1202. Atheros Wireless and sound works. I used "clusterKNOPPIX 3.4-2004-05-10"

05-20-2004, 09:52 PM
I got 3.4 working on my Sony Vaio FX220 laptop with CPU Pentium 750 Mhz and 120MB RAM. It detected my school network easily and I could configure my external USB mouse and USB thumbdrive. I have not tested the modem yet though. Some of the websites say that my comp has a winmodem. I will resolve that when I have some free time.

Here are the summary of steps I took:
Used the knoppix-installler instead of knx-hdinstall script to do the install.
In the LILO dialog box I opted for Overwrite MBR (I was really scared that it will mess up my other OS.. but it did not)

Knoppix rocks!

05-24-2004, 10:53 AM
:D Persario 3000 /w the Huge Screen! Built-in Wifi 54g
I have my wifi working with 3.4 Knoppix, But no boot up config yet to give to everyone.
I'm just learning the knoppix script. Someone will beat me to it. But I did note this was not common knowledge or found in recent post. USE the NDISwrapper! Make it easy on yourself.

If you use the ndiswrapper you may get invalid module type when you try to modprobe ndiswrapper.

There is one step that may not be real clear an have been overlooked.
So everyone needs to note:

1) You must compile with gcc-2.95 not gcc-3.3!
a) cd /usr/bin
b) rm -f gcc
c) ln -s /usr/bin/gcc-2.95 gcc
d) goto the ndiswrapper dir
e) config, compile and install
f) cd /usr/bin --again
g) rm -f gcc
e) ln -s /usr/bin/gcc-3.3

2) This is under 2.6, haven't tried it under 2.4 kernel

3) Check the version or link to the gcc in your /usr/bin
a) whereis gcc

4) I tried to make a script but i'm really new at this.
+++++++ WUT is a Linux House Now!
I have dual booted all my windows systems and have changed the focus to more linux development at WUT. Microsoft is screwed and I attain better control over system designs, down to the kernel.
Thx to the Knoppix Development Team
from the CEO of We Understand Technology

# Change gcc compile tool from 3.3 to 2.95 to 3.3
# run the make install while 2.95
cd /usr/bin
rm -f gcc
ln -s /usr/bin/gcc-2.95 gcc
cd /usr/src/ndiswrapper
make clean
make install
cd /usr/bin
rm -f gcc
ln -s /usr/bin/gcc-3.3 gcc
cd /usr/src/ndiswrapper
# Update Info to Knoppix-autoconfig
# add these lines after the APM section
#*/ You'd better understand what your doing in this script!
# Let's Modprobe ndiswrapper for 54g wireless
echo " ${BLUE} Loading NDIS Wrapper as reqested.${NORMAL}"
modprobe ndiswrapper
iwconfig wlan0 essid ***Your SSID Here***
echo " ${GREEN} Setting ESSID as reqested.${NORMAL}"
iwconfig wlan0 mode Managed
echo " ${GREEN} Setting mode to Managed as reqested.${NORMAL}"
# You can also get to info from a file, Not shown here
# Add these lines after
# First: PCMCIA Check/Setup
# This needs to be done before other modules are being loaded by hwsetup
# Fat-Client-Version: DHCP Broadcast for Wireless IP address
if checkbootparam "nodhcp"; then
echo " ${BLUE}Skipping DHCP broadcast/network detection as requested on boot commandline.${NORMAL}"
#NETDEVICES="$(awk -F: '/eth.:|tr.:/{print $1}' /proc/net/dev 2>/dev/null)"
NETDEVICES="$(awk -F: '/wlan.:|tr.:/{print $1}' /proc/net/dev 2>/dev/null)"
echo -n " ${GREEN}Wireless Network device ${MAGENTA}$DEVICE${GREEN} detected, DHCP broadcasting for IP.${NORMAL}"
trap 2 3 11
pump -i $DEVICE >/dev/null 2>&1 &
trap "" 2 3 11
sleep 1
echo " ${BLUE}(Backgrounding)${NORMAL}"
### Now your 54g or 11b card is ready to roll.

05-24-2004, 10:36 PM
Vaio PCG-N505SN
All hardware without exception works perfectly under Knoppix:
Bootable external PCMCIA CD-ROM
Infrared IRDA
Screen Brightness Control
Video with xv accelleration
Wireless LAN with Orinoco Gold card
PCMCIA modem
Standby to RAM

The only thing is that I couldn't get it to hibernate to disk yet.

05-25-2004, 12:49 AM
Averatec 3150P:

Has problems with the Synaptic Touchpad in kernel 2.4
Everything works flawlessly in 2.6

Also, my DLINK DWL 650 wireless works too... so the one that comes with the 3150H should work fine because it is a prism2 as well

05-26-2004, 10:11 AM
I have Knoppix running on a Toshiba 2410, sd card not working, linmodem not working, Nvidia Graphics just fine, sound just fine, I used a pcmcia modem, do not care about the sd card.

Still haven't figured out how to get the xscreen savers to work in kde, but as soon as I found how to access my files on the ntfs system, I backed them up and booted windows right out the door.

Linux is happier without pushy windows.
And I am happier without any more crashes into windows.

06-04-2004, 03:37 PM
so someone please help a noob get this daammmnned piece o crap wifi card going in linux on this laptop will u

i to do not know how to compile cd or do much so any help appreciated.. i really need this wifi card working...

it does not work in knoppix or red hat 9

i am not sure how to install and use the ndiswrapper for either..

thanks really appreciated as i need it to work


06-04-2004, 06:01 PM
My IBM Thinkpad R40e works, sort of.

To boot, I had to use this:

knoppix26 nodma noapic acpi=off

DMA causes it to not see the CDROM. APIC and ACPI make it lock during hardware detection.

Ethernet works with the 2.6 tg3 driver, but not the 2.4 driver.

Sound worked on boot.

Graphics are unaccelerated, I think (glxgears gives 225 fps).

Yeah. I can't test the other stuff, so I'll say this is "sort of working"

06-04-2004, 06:09 PM
Fujistu-Siemens E Series lLifebook 700Mhz 256Mb RAM, Knoppix works just fine from the CD and on a HDD install. Picked up all the hardware, graphics, sound, ACPI etc apart from (surprise, surprise!) the winmodem. Problem solved by buying a Hayes 56K external on eBay for a fiver plus postage (lots quicker than a winmodem too!). Oh, and the machine seems to run cooler, as does my brain and my temper! :wink:

06-05-2004, 12:44 AM
oh yea its a dell inspiron 5100 and the true mobile 1300 wifi.. the other lan not working in red hat either, really dont know what im doing so plz help...

06-18-2004, 02:26 AM
My Fujitsu C 2210 running just fine :D

06-18-2004, 11:21 AM
My Acer Travelmate 801LCi (1.4Ghz centrino) is working very nicey with Knoppix3.4 with kernel 2.4.

One thing I cannot figure out is how to use power mangement in KLaptop -how do I access the ACPI panel to switch it on?

Anyone know? Thanks.

06-24-2004, 06:36 PM
Dell Latitude D600

DOES NOT WORK. Boot sequence gets to the X11 drivers and then the screen goes dark and machine is unresponsive. Any ideas how to get pass that point? :?


07-10-2004, 03:19 AM
Dell Inspiron 8600
Centrino 1.6
Works great, except wireless Dell true mobile 1300 wifi which is basically Broadcom... Not detected. I read ndiswrapper or linuxant are needed, but have no idea how to use either of those. From what I read, RedHat had ndiswrapper built in already? *Knoppix revision? hint hint*

07-12-2004, 02:27 PM
I got my sony vaio pcg-grt100 notebook to work with knoppix with ease. Just burned the ISO image and booted it up.

Although haven't installed my WL-103B PCMCIA wi-fi card... (no driver available) geez... hope these hardware manufacturers start supporting linux.

Anyway, just wanted to say that knoppix is great.. if not it rocks!

07-24-2004, 10:40 PM
Dell Inspiron 8600
Centrino 1.6
Works great, except wireless Dell true mobile 1300 wifi which is basically Broadcom... Not detected. I read ndiswrapper or linuxant are needed, but have no idea how to use either of those. From what I read, RedHat had ndiswrapper built in already? *Knoppix revision? hint hint*

IBM T40 works great with Kanotix

Get Kanotix, http://kanotix.com/info/index.php
NDISwrapper built in and will run perfectly from the cd boot.

07-31-2004, 05:51 PM
got presario 2100 to go .. using latest knoppix but i mus use the following cheat code

knoppix26 acpi=off noscsi

i still cant get knoppix to find my wireless card it is the following...

any help i would appreciate it

08-05-2004, 11:38 AM
Knoppix 3.4 works fine with Acer TM290 (ATI): both kernel 2.4 and 2.6
Knoppix 3.6 does not work well; it often freezes.


RMS rev 2 30 Aug 2004

08-05-2004, 07:01 PM
HEllo Knoppix 3.4 (linuxTag only) is working in:

NEC VERSA m300!!!!

there is a sound problem with trident module.. USE ALSA!!!! works great!!!

I have aproblem!!! I compiled by myself kernel 2.6.2 I installed it and always after checkbios OK appears a blank screen and nothing happends!!!!!

somebody knows about this problem??? I didn;r find anything around!!!


goyoantifa ---- goyo@okupaweb.com

08-25-2004, 06:54 PM

Dual booting Knoppix 3.3 & crappy-Windows XP on:
IBM Thinkpad T30 (Pentium 4m) 512MB, 40Gb HD

Works fine with HD install and CD but I havent 'played' with it properly yet ;)

08-29-2004, 04:54 AM
I have a Presario 2100US.It works well with KNOPPIX_V3.6-2004-08-16 with the following cheatcode:
knoppix26 nolapic noscsi
The nolapic option lets acpi work,something that didn't with earlier
The noscsi option is necessary for knoppix to set up the nic properly.
The built-in wireless nic works with ndiswrapper.
I have successfully used a netgear wg511 wireless card with this version.
If I had thought to take a Knoppix cd to the store,I'd have never bought this laptop.On the otherhand,it's forced me to learn alot.I've installed debian,knoppix and mandrake successfully on it.
I recently used Knoppix to "ghost" the hard drive in this laptop to a faster one.
Great tool.

09-04-2004, 05:45 AM
I've got Damn Small Linux running on a TI Extensa-450.

486 DX4/75
540MB Hard Drive (about 160 of that is DOS 6.22 / WfW 3.11)
Datastor parallel port 8X CD-ROM Drive

Since the floppy drive is defective and can only read 720K disks despite being a 1.44MB drive, I had to stick the hard drive in another computer, the one I use as my hardware testing station, to actually do the Linux install (that's one of the things I love about Knoppix and Knoppix derivatives, unlike Windows, it is portable. No need to have to do a fresh reinstall every time you do any major hardware changes). Also, due to the limited amount of RAM for now, I am relegated to console mode. However, I do have a nice set of text-only packages installed. I just wish I could find a console-based text editor that can handle RTF formatted files.

Once I can get a bigger hard drive (say somewhere between 3 and 5GB), and get a pair of 16MB 72-Pin laptop DIMMs, I should be able to run X with a lightweight WM like Fluxbox.

Almost forgot. I just added another PCMCIA card to the collection that I scored at Goodwill today (too bad this computer only has one card slot, but for $5.00, I couldn't pass up a good 16 bit PCMCIA card). This one is a Lucent Orinoco Silver Wireless LAN adapter. I was very pleased to see DSL autoprobe the card and load the drivers, whereas, I am now on a frustrating hunt for WfW drivers for it. I'll be giving it a full test tomorrow. I found out our local library has a free wireless access hot spot, so I will be heading down that way tomorrow.

09-05-2004, 01:14 PM
Tried the T41 with 3.4 (both kernels) and it boots fine, but screen resolution never better than 1024x768 regardless of cheat codes. Also failed to detect Intel wireless pro 2100, and refused to load module.

D/L'd the 3.6 version and used the 2.6.7 kernel -- detected the wireless pro 2100 immediately! :lol: No joy on the screen at first, but after experimenting, found that all I needed was:
knoppix26 screen=1400x1050 (I also use home=scan myprofile=scan) and it is perfect!

09-05-2004, 06:03 PM
I'm using 3.6 on a Toshiba Satellite CDT 4030 - Celeron 300MHz, 192MB RAM, 4GB harddisk, so really nothing special, but it works flawlessly with the 2.4.x kernel.

On my other notebook, an assembled Centrino 1.7MHz with 512MB RAM, I had 3.6 up and running, but that's no surprise - Knoppix doesn't seem to like the Intel Pro 2200, though. When they fixed some minor defect, they replaced the Intel Pro 2100 by the 2200 - nice kind of service, but since then WLAN support is gone, so I'm lost (unless I use the PC card from the other notebook, but that's not the idea behind having a Centrino, is it...)

The driver for that seems to be in the making... http://ipw2200.sourceforge.net/ I'm going to install 3.6 on the new notebook using a 2.6.x kernel, so I'll be able to try the driver.

And there's also hope for one wlan PC card I haven't been able to use, either: The 3com 802.11a/b/g 3CRPAG175 using the Atheros chip set: http://www.atheros.com/news/linux.html - the linux project doesn't have any files published except cvs snapshots, so I'll have to wait...

09-15-2004, 07:20 AM
Knoppix 3.6 seems to work pretty well on my Dell Inspiron 5100 so far. I'm just starting to play with it. This is like learning a different language after using windows. The only gripe i have so far is the touch pad, I would like to disable the tap to click function but haven't discovered how yet.

09-17-2004, 01:17 AM
HP Pavilion zv5200
Knoppix 3.6 (release 2004-08-16) seems to be OK.
Needed to boot: knoppix nodma

Ethernet works
Sound doesn't work out of the box

09-27-2004, 09:57 PM
works great.
i've tried both 3.4 and 3.6 hdinstalls and both work fine.

the wireless card is not detected.. and i have not tried the modem, but the 10/100 Nic works fine.

also, to get full use of the wide screen, you have to add "1280x800" to each of the /etc/X11/XF86Config-4 resolution lines ...

after a simple reboot, i have full wide-screen with full resolution!!

ohh yeah :)

09-28-2004, 12:22 AM
I am running knoppix 3.4 c't edition on an Acer Travelmate alpha 550 and like it a lot! It works best with the following cheatcodes:

knoppix nopcmcia screen=1400x1050 xmodule=savage

* with pcmcia autodetection it will not start and since I do not use any pcmcia hardware it works fine without...
* I bought the travelmate with high resolution 15 inch display, thats why I need the screen=1400x1050 option
* using xmodule=savage gives the final display boost so divx movies don't shake while beeing played
* sound only plays on very low volume level compared to windows output... putting alsa cheatcode doesn't help... anyone knows how to fix this?
*I never tried the built-in modem using linux nor my usb-adsl modem "octal a360" which supposedly works if you know how
* my firewire disk works fine if I conect it before starting knoppix

10-02-2004, 12:11 PM
Everything works on Compaq Presario 2100 using at boot:
knoppix acpi=off
knoppix26 acpi=off

Wireless and modem not tested!!

knoppix@ttyp0[knoppix]$ cat /etc/knoppix-version
3.6 2004-08-16

02-06-2005, 11:40 PM
Gateway SOLO 1450
Knoppix 1.7
I'm using the cheat codes: knoppix nodma vga=normal

At first I wasn't able to boot. I was getting some errors with the video. When I used vga=normal that got rid of the error, but then the screen when blank. I refreshed my screen with the FN & LCD/CRT button and I got a bunch of text saying errors with the IO and loads of other stuff. Then I tried using noapictd with the same result. Then I tried using nodma and wala! It worked. Hope this helps anyone out here with the same problem.

02-10-2005, 06:39 PM
hey , i'm new to linux, even tho I run debian redhat 9.0 and 7.3 on my servers ( I pay a guy to help out)

I finally got knoppix installed on my latop and got the wireless working with and acx100 netopia wireless card


02-10-2005, 08:13 PM
i have a aston didital passport 2100 and it boots off the CD just fine.

02-17-2005, 08:54 AM
It works with Knoppix 3.7/HDD install. Please see my message on this page:



03-07-2005, 09:51 PM
I tried knoppix 3.7 successful on an ibm x20. I used the 2.6 kernel.
everything worked out of the box including WLAN.

greetings, gerhard

03-12-2005, 04:53 PM
The gateway M275 boots from disk but so far hasnt detected the wireless card.

03-13-2005, 08:21 PM
Emachines M5410 works fine in most cases... so far, i haven't got the widescreen support fully working.. sound doesn't work, it would be my next target :D wireless isn't working either.. other than that, everything else works fine :D

03-22-2005, 09:35 PM
IBM TP 770 works (except for the soundcard). Even my pcmcia 56k winmodem works!

04-06-2005, 01:34 PM
knoppix 3.7 works on Compaq Armada M700 with no modifications needed.:D Also works after HD install

Not tested modem as I'm using LAN connection.

04-06-2005, 09:43 PM
Gateway 3520 with all the bells and whistles(new) Knoppix 3.8 on HD dual boot with XP
wireless, ethernet, modem ok.
Gives a sound/kernel error but sound OK!

04-07-2005, 11:43 AM
Knoppix 3.6 works well on my laptop...had a few issues getting the wireless card and usb flash card to function though, but got that squared away. Works beautifully... Sometimes it's nice being a newbie :)

06-12-2005, 08:12 PM
I am having a problem with the battry of my new Fujistu Siemens Amilo 7405 lab top. Every few minutes it shows that the time lift is 0 and restart X. This happens with Knoppix 3.8 and Kanotix 2005-2 while using IWP2200 wireless. However, It runs fine with WinXP. Any idea how to fix it?

07-01-2005, 12:38 PM
RoverBook Nautilus E410W is just fine with Knoppix 3.9

Have not tried to run modem or WiFi.

07-16-2005, 06:40 AM
I try to install Knoppix version 3.9 EN to my Fujistu-Siemens E Series Lifebook E4010.
It's fine,can detect my sound card and I'm happy with working on screen resolution at
1024 x 768, and wireless connection is seems fine (It's can be detect but I can't access to any website ^^;; , anybody know how to config it ?, I already set the proxy server and with that proxy server my WindowXP can work well )
I also have some problem about my modem it's not detect and I can't find any modem driver too, anybody know how should I config or find the driver online ? :?:

Thank you :)

07-21-2005, 08:17 AM
About my Knoppix, it's perfect right now !

Iceclover =)

07-22-2005, 10:00 AM
Hi there, just a quick post here. I am running knoppix on a Fujitsu-Siemens Amilo k7600 and it runs just fine.

10-10-2005, 12:23 AM
I just posted in a couple of forums I frequent using an old Panasonic ToughBook with no h/d and little ram. I saved some configuration files from my Debian install on my Toshiba, booted Knoppix 3.7 on the ToughBook, copied the files to the correct directories and plugged in my cell phone. "pppd call verizon", started elinks and I was online. Knoppix is great!

10-18-2005, 04:16 PM
I installed Knoppix 4.0.2 on my IBM Thinkpad T22, 256 MB RAM, 900 MHz PIII processor. The only snag was the video settings. You have to specify 1400x1050 resolution, or else it auto-detects 1024x768 and the graphics will be blocky.

10-22-2005, 11:38 AM
I installed Knoppix 4.0.2 on my IBM Thinkpad T22, 256 MB RAM, 900 MHz PIII processor. The only snag was the video settings. You have to specify 1400x1050 resolution, or else it auto-detects 1024x768 and the graphics will be blocky.
That's the same with mine.
I have a Compaq Presario 2825EA: P4-M (1,9Ghz), 512DDR-RAM, 40GB HDD and a graphic-card with ATI Mobitility Radeon 7500.
You must do following to set the resolution: knoppix screen=1400x1050. Then you save your configuration on a partition with fat32 and restart the laptop.
Now you can type in: knoppix myconfig=/mnt/hda6 for example and it should work. :)

I've used Knoppix 3.9, 4.0 & 4.0.2 (CD & DVD Version) and it worked fine ^-^

11-12-2005, 08:09 PM
succesfully worked on Compaq Presario 2500
512 RAM, 40 GB HDD, 2,8Ghz
ATI Technologies Inc Radeon IGP 340M

12-22-2005, 01:39 AM
Running excellent on an hp nx9010

Capt. Cautious
12-23-2005, 07:39 PM
My machine is an HP Pavilion ze4500 w AMD 2400CPU and 1024 Ram After three tries I finally got the 4.2DVD to load to the HD. With the exception of a couple of programs and the dratted winmodem So far it all seemsto work. had one mysterious crash early on but nothing since. Oh, QParted did not work so I did the partitioning w/sfdisk Good tool. :-)

In my hand, I Remain~
Captain Cautious.

12-24-2005, 02:04 AM
LiveCD detects everything ... wireless card ... LAN ... touchpad ...

The only problem I have is that I am unable to change the resolution to a widescreen resolution (1280*800), not even with the cheatcodes ... the max resolution I can use is 1024*768

oh yah ... my display doesnot come back if I close the lid and reopen it ... any advice??

Havent installed to hard disk ...


P.S. How do I access another CD while booting from the LiveCD??

Harry Kuhman
12-24-2005, 03:37 AM
P.S. How do I access another CD while booting from the LiveCD??
Multiple CD/DVD drives (not an option most laptop users have)


With enough RAM memory, use the toram cheat code to load the entire CD into memory. (Again not an option everyone has).

12-26-2005, 07:41 AM
P.S. How do I access another CD while booting from the LiveCD??
or you boot from the ISO cd image file stored in your hdd, cf:
http://www.knoppix.net/forum/viewtopic.php?t=11796 & http://www.knoppix.net/wiki/Win_Partition
Cheers, Gilles

12-28-2005, 01:14 AM
My Compal DL70 works in KNOPPIX 4.0.1 with its Mobility Radeon X600, but I get 1024x768 instead of 1680x1050. That's probably due to the xfree86 Radeon driver not supporting my card. I'm typing this in KANOTIX 2005.4 RC3 Full, where xorg's ati driver supports my resolution.

01-15-2006, 10:53 PM
Knoppix runs just fine straight from the DVD, which is a relief as I have tried 3 other distros and had no joy at all.

Tom Tiger
01-16-2006, 12:38 PM
Yep, no problem on the Equim M50, Mandriva 2005/2006 also no problems

Knoppix runs just fine straight from the DVD, which is a relief as I have tried 3 other distros and had no joy at all.

02-21-2006, 08:33 PM
I can add the Compaq M2105US to the list of ones Knoppix runs well on. It booted right up with the cd in about the same time XP takes. Of course it is faster than XP since it is running in a ramdrive. And I have access to the ntfs drive. Great so far. :P

Wireless Broadcom 802.11g was not activated. I got a test load of linuxant drloaderdriver program and that brought the wireless online. All in "live" mode. I expect of course that the wireless linuxant will go away when I reboot without a persistent hard drive installed. I did save configuration to an Ipod as a USB drive.

Now, I also tried the ndiswrapper configuration but it did not recognize the bcmwl5.inf file but the linuxant did. Any ideas why not? I expect I could use that for the wireless without the linuxant if I could get ndiswrapper to recognize the .inf file.

Only current issue besides that is a key bounce issue which I expect is the key select speed that is too sensitive so it is duplicating keys too quickly and easily.

02-23-2006, 06:02 PM
I'm using iAcer Aspire 3002NCLi I have no problem booting to knoppix 4.0.2 The only that's not working is;

1.WIFI is not working
2.Batttery Meter

I try to boot using knopppix 3.72, unsuccessful due to the SIS chipset.

03-08-2006, 03:08 AM
i have a japanese oem nec versapro va90j 900mhz piii laptop that's been pretty cranky with letting anything install.

so far i have only been able to get minimal functionality from knoppix (i can get online and browse), but sound, usb ports, and the integrated nic don't work (among other things). of note, however, is that if i perform a tohd, i am able to burn cd's ... which proved to be a priceless commodity.

i tried slackware 10.2 (which failed to allow the pkgtool to work. midnight commander worked but it's a bit too powerful for an idiot like myself to dink with), debian 3.1 (which won't boot after install), and fedora core 4 (which fails even to initialize the install).

the only distribution i've installed so far which worked was breezy badger ubuntu (5.10). of note however, is that upon installing kubuntu-desktop it broke. too bad gnome's 1024x768 res looks like 800x600.

my laptop doesn't like kde, and i have a huge stack of install cd's to prove it ... lol

03-11-2006, 10:08 AM
ive got a corp Dell Latitude D600 with winxp - and so far knoppix is running fine, network is good, picked up my devices, lovin it......

also ..battery meter works, as well as wifi -

03-16-2006, 02:28 PM
Booted with no codes. Surfed the Net and access my LAN, straight out of the box. Amazing :shock:

03-17-2006, 05:53 AM
I have absolutely no problem running Knoppix on my brand new Gateway laptop. I can also mount/dismount the flash USB drive with no problem.
GATEWAY CX2608 Convertible Tablet Notebook -

Intel Pentium M Processor 740, 1.73GHz, with Centrino Technology, 512MB RAM, 60GB Hard Drive, 14-inch Widescreen WXGA TFT Display, DVD/CD-RW Combo Drive, Integrated Wireless, 5 in 1 Card Reader, Windows XP Tablet 2005
Processor Brand: Intel
Processor Class: Pentium M Processor
Processor Number: 740
Processor Speed: 1.73 GHz
Bus Speed: 533 MHz
Mobile Technology: Centrino
L2 Cache Size: 2 MB
Memory Speed: PC2-4200 (533MHz)
Memory Technology: DDR2-SDRAM
Installed Memory: 512 MB
Maximum Memory: 2 GB
Hard Drive Capacity: 60 GB
Drive Controllers: IDE (Ultra ATA/DMA)
Rotational Speed: 5400 RPM
CD-RW Write Speed: 24 X
CD-RW Rewrite Speed: 24 X
CD-RW Read Speed: 24 X
DVD Read Speed: 8 X
Additional Drives: DVD/CD-RW Combo
Sound Support: Digital Audio (16-bit)
Video Chipset Brand: Intel
Video Chipset: Graphics Media Accelerator (GMA) 900
Shared Video RAM (Max): 128 MB
Resolution: 1280 x 768
Display Size: 14.0 in
Display Type: Active Matrix LCD (TFT)
Port Connectors: • 3 USB 2.0 Ports
• 1 VGA External Connector
• 1 IEEE 1394 port
• Audio - Microphone In
• Audio - Headphone / Audio Out
• 1 RJ-11 Modem
• 1 RJ-45 Ethernet LAN
• 1 Port Replicator Connector
Card Slots: Memory Stick
Memory Stick Pro
Secure Digital(SD)/MMC
xD-Picture Card
(1) Type II / Type I CardBus
Network Support: Gigabit Ethernet (1000 Mbps)
Wireless Protocol: 802.11g
Modem Speed: 56 Kbps
Input Devices: Keyboard
Number of Batteries: 1
Installed Operating System: Windows XP Tablet PC Edition 2005
Included Software: Productivuty Software:
• Microsoft® OneNote 2003
• Microsoft® Works 8.0
• Microsoft® Money 2005
• Microsoft® Encarta Online
• Adobe® Acrobat® ReaderTM 7
• Microsoft® Experience Pack for Tablet PC
• Microsoft® Education Pack for Tablet PC
Digital Media Software:
• Microsoft Windows Media Player 10
• Microsoft® Digital Image Starter Edition 2006 (with 60-day Digital Image Standard 2006 Trial)
• CyberLink® PowerDVD
• Nero 6 Suite
• RealNetworks RealPlayer®
• Quicktime
Gateway Internet Security Shield:
• Norton Internet SecurityTM 2005 (90-day complimentary trial)
• McAfee Anti-SpyWare 2005 (30-day complimentary trial)
• Gateway BigFix®: Identifies and resolves problems that affect the system before they occur
Height: 1.4 in
Width: 13.6 in
Depth: 11.1 in
Weight: 6.9 lbs

04-02-2006, 05:34 PM
I have succesfully booted knoppix 4.0 CD-LIVE on my

Centrino 1,73 GHz, 512 Ram, 80 giga HDD.

Just have to type failsafe before booting.

Thanks Tom :D
in failsafe mode you won't be able to see your HDD nor your Usb devices.
So i tried the following command before boot:
knoppix noapic nopcmcia noagpi noscsi
to limit the number of drivers thus limiting the chances of failing boot,
now, i see my HDD,my Usb, the touchpad doesn't work but i can use a usb mouse :)
I still cannot access the datas on my Hdd called /mnt/hda1.
If anybody has suggestions... ;D




:D :D :D :D :D :D :D :D

You don't believe how happy I am !
I spent hours and hours trying UbuntuLive 5.10 with the help of the italian forum but didn't make it to run Xorg so i had to do everything through command line. And that didn't work either.
I've to rescue some datas from my Windoz crash.... :(


Tom Tiger
04-02-2006, 05:43 PM
Nice work :D

I have succesfully booted knoppix 4.0 CD-LIVE on my

Centrino 1,73 GHz, 512 Ram, 80 giga HDD.

Just have to type failsafe before booting.



:D :D :D :D :D :D :D :D

You don't believe how happy I am !
I spent hours and hours trying UbuntuLive 5.10 with the help of the italian forum but didn't make it to run Xorg so i had to do everything through command line. And that didn't work either.
I've to rescue some datas from my Windoz crash.... :(

F. :D

08-08-2006, 10:52 AM
Acer Aspire 1693WLMi http://www.knoppix.net/forum/viewtopic.php?p=106477#106477

08-09-2006, 03:36 PM
I've got Knoppix 4.0.x (hd install) running on this super old Gateway 200STM laptop. Everything is good to go. Including wireless (several profiles) and multimedia (especially all my tunes). xmms kills WMP and iTunes.

I also just got the 5.0.1 DVD and it runs live perfectly on said machine.

I just found a dinosaur of a laptop. A Micron ZX and the install of 5.0.1 from DVD is a little rough. The HD is only like 6GB. I may pass an ignore command or something.

I wish everyone could understand the joy I get from using Knoppix. *sighs*

11-06-2006, 03:38 PM
Knoppix 5.0.1
1G USB drive w/PDI

Knoppix runs fairly stable but I have the following issues.
Maybe one/some of you nice folks can come up with
some ideas on how to get my laptop running a bit

1. The PDI works fine but loads very s l o w. Sometimes
it takes up to 8 minutes to boot.

2. I got the wireless to work but it's slow to load web pages and
email. Not sure if it needs some sort of tweak or if there's a
hardware conflict that slowing things down. http://jumi.lut.fi/~junousia/hymiot/think/vaikeapaatos.gif

3. I'd also like to disable the tap/click option from the touchpad
so only the the buttons are used to select items. This is very
irritating for me but can't figure out how to make the changes.

I figured I'm not doing too bad for a newb but any help would
be greatly appreciated.


Harry Kuhman
11-06-2006, 08:37 PM
1. The PDI works fine but loads very s l o w. Sometimes it takes up to 8 minutes to boot.
I have no idea what PDI is, so this may not apply, but a high speed burn is frequently the cause of slow booting problems, see this thread (http://www.knoppix.net/forum/viewtopic.php?p=78583#78583) for just one of many examples. That you used the word sometimes reinforces my guess that this is the issue.

11-07-2006, 10:56 PM
I can get Knoppix 5.0.1 LiveDVD to boot on my MacBook Intel Core Duo, specs at the bottom.

I have to use this cheat code to get it to boot:
knoppix acpi=off pnpbios=off noapic noapm -- Otherwise I press Enter to boot Knoppix and it just hangs.

It SEEMS to be working okay, loading basic programs and such, but I haven't tried too much because the keyboard and mouse (built-in or USB compact mouse) are EXTREMELY sluggish. I can use the arrow and Enter keys to navigate the menus fairly well, no problems there, but when I try to move the cursor or type something, they take forever to respond. The mouse seems unresponsive (it waits two or three seconds before responding, then moves in a jerky, slo-mo motion), and pressing a key (especially if it's a capital letter) often makes the letter appear a number of times. Erasing those and typing again, however, works if I'm slow.

This problem is truly frustrating and I can't take the time to work for five minutes just to open a program, so I haven't been able to use Knoppix.

MacBook Specifications
Intel Core Duo 2GH processor
1G 667MH memory (two 512 sticks)
60G hard drive
DVD-R/CDRW Superdrive (plays and records both CDs and DVDs)

11-09-2006, 07:28 PM
I have no idea what PDI
Persistent Disk Image. I try to talk Nerd and am called out. :oops:

11-14-2006, 06:55 AM
Hi all. I am running 5.0.1 live CD on a dell inspiron 6000. I ahd to use the fb1280x1024 cheat to get it to show up on the wide screen, but now it is working great. I haven't set up the wlan yet, but lan is working fine. here my system specs. Dell inspiron 6000, intel pentuim m 1.6GHZ, 1 GB ram, 40 GB HD, CD/DVD burner, 3GB USB external drive.

I am new to this and have only been tinkering for 2 days, this forum is invaluable in helping out a newbie. Thanks.


12-02-2006, 12:11 AM
Yay successfully loaded.... The first couple of times I loaded it, it would hang o finding DVD in \hdc\hda or something like that. I use cheatcode "nodma" starts without any problems, my LAN works fine but haven't tested out the wireless yet, I think this is the best ditro to test out to see if you like Linux, I have used RH in the past and it is horrible to setup... Knoppix is great!!!
My system specs"
I have the Knoppix DVD
512MB Ram
AMD Turion 1.8
ATI radeon 200M

Bob Perron
01-01-2007, 06:42 AM
For the record. . .I have successfully booted Knoppix 5.0.1 on my Transnote. Once booted everything is fine, EXCEPT none of the transnote pad handwriting recognition will work. . .not surprising since only one person is working on the OTIS suite for transnote!
Please note the booting procedure for this IBM is extremely idiosyncratic:
It will generally only boot from a limited number of external CD-ROMS (It has no internal CD-ROM drive.) I was forced to use an IBM UltraBay using the PCMCIA card option. . .it will not boot from the USB option. The knoppix startup scripts however it will not find/recognize the Ultrabay after the initial boot screen and I do not know the correct switchest to allow it to find the CD image. . .so I also had connected a an IOMEGA USB CD-ROM Burner with ANOTHER copy of the Knoppix CD, which the boot scripts could find. . .very strange.!
To recap, the Transnote will only boot from the either an UltrBay using the PCMCIA card, or alternatively there is a procedure listed on the net to utilize a "PIXSY" boot process over a network. They used Knoppix but I'm not personally familiar with this process.

01-02-2007, 02:00 AM
5.01 working on the Toshiba 2775xDVD with 192 megs of RAM.
use fb1024x768
Linksys WPC11 wireless b card works.
Adaptec USB2 card works.

06-19-2007, 03:12 PM
After some fiddling managed to set-up the auto conf for knoppix on an Acer 5633WLMi .

used boot knoppix acpi=off pnpbios=off noapic noapm

tried it also with fb1280x1024

probably not necessary for the fb but running a nvidia card and does not have Linux drivers to hand. may give it ago later today.

no wlan just yet but eth0 ok and plugged into router ok.

will post wlan effort in wlan section of forum

07-22-2007, 04:12 PM
I have a Compaq V5201US that is Booting Knoppix ver 5.1.1 from a 2Gig SanDisk USB PenDrive and is working fine...so far.

Compaq V5201 Specs are:
Product Name Compaq Presario Laptop - V5201US
US Product Number EZ552UA#ABA
Microprocessor 2.0GHz Mobile AMD Sempron™ Processor 3300+
Microprocessor Cache 128KB L2 Cache
Memory 512MB 333MHz DDR System Memory (2 Dimm) (I upgraded to 1 Gig DDR)
Memory Max 2048MB
Video Memory 128MB DDR (shared)
Hard Drive 80GB 4200RPM (I upgraded to a 120 Gig Fujitsu)
Multimedia Drive Super Multi 8X DVD±R/RW with Double Layer Support
Display 15.4� WXGA High-Definition BrightView Widescreen (1280 x 800) Display
Fax/Modem High speed 56k modem
Network Card Integrated 10/100BASE-T Ethernet LAN (RJ-45 connector)
Wireless Connectivity 54g™ 802.11b/g WLAN with 125HSM / SpeedBooster support
Sound Altec Lansing
Keyboard 101-key compatible
Pointing Device Touch Pad with dedicated vertical and horizontal Scroll Up/Down pad
PC Card Slots 1 ExpressCard/54 Slot (also supports ExpressCard/34)

External Ports 2 Universal Serial Bus (USB) 2.0
1 headphone-out
1 microphone-in
1 VGA (15-pin)
1 TV-Out (S-video)
1 RJ-11 (modem)
1 RJ -45 (LAN)
1 notebook expansion port 2
1 Consumer IR

Dimensions 10.2"(L) x 14.1"(W) x 1.38"(min H) /1.77"(max H)
Weight 6.4 lbs
Security Kensington® MicroSaver lock slot
Power-on password
Accepts 3rd party security lock devices

Power 65W AC adapter
6-Cell Lithium-Ion