View Full Version : 5.0.1 usb-storage problem.

07-03-2006, 06:28 AM

I am using a HD install of 5.0.1 and am having difficulty with usb-storage when I attach my KonicaMinolta 7d to an usb port. The camera is detected and a hard disk icon appears on the screen indicating sda. When I try to mount the device, the mount fails with an error indicating all sorts of possibilities including wrong options. I look in /etc/fstab and see that the following line has been added:

/dev/sda /media/sda vfat noauto,users,exec,umask=000,shortname=winnt,uid=kn oppix,gid=knoppix 0 0

The uid and gid seem strange to me so I edited the line leaving instead:

/dev/sda /media/sda vfat noauto,users,exec,umask=000,shortname=winnt 0 0

and I can then mount the device /dev/sda and get access to my photos. I really hope that I don't have to manually change fstab every time I want access to my camera. Incidently, it all works fine when I boot from the CD.

I haven't found the code which causes the line to be added to /etc/fstab. I was looking for a shell script that does the trick. The closest code I can find is /usr/share/knoppix-installer/templates/etc/hotplug/usb/usb-storage but I don't see how that is called. Apparently, /lib/modules/2.6.17/kernel/drivers/usb/storage/usb-storage.ko
is executed.

Is there a reasonable way to correct the situation? Is there something tricky like moving the script from /usr/share/knoppix-installer to a different place?

By the way, I have read many of the injunctions against using a Knoppix hard disk install.

Thanks in Advance,

07-03-2006, 08:39 PM
humm, does knoppix ask for a usr name when you install it? maybe you are using a differnt usr name then knoppix. btw, fstab is initially built with the knoppix-autoconfig found in /ect/init.d. I had problems hot pluging my usb pendrive, i just boot with it pluged in and have no problems. also, how are you mounting this device? you just click on the desktop icon i would think and konqueror would do the rest. sry i'm not much more help.

07-04-2006, 02:36 AM
I think I found out how to get it working. My first attemp, which worked was to execute the following script after the icon appeared on the screen:

#! /bin/sh
# This is a small script to mount the camera and
# open emacs. When emacs is closed, the camera is
# unmounted.
sleep 1
echo "sleeping 4"
sleep 1
echo "sleeping 3"
sleep 1
echo "sleeping 2"
sleep 1
echo "sleeping 1"
sudo mount -t vfat /dev/sda /media/sda
sleep 1
emacs /media/sda/dcim
sudo umount /dev/sda
echo "camera is unmounted."

Then scouring around in /etc/ I found the file /etc/udev/knoppix.rules and modified it so that it used my user id and group rather than that of knoppix. It now works as I expected it to work.

07-05-2006, 04:28 AM
You might want to iterate like this,

for i in 5 4 3 2 1;do sleep 1; echo "sleep $i"; done
echo "you have now waited 6 seconds... Yippie!!"

# insert commands here :)

But the question remains... if you just wait for 6 secs, does clicking on the desktop icon that appears work? If not, I should find out why... could be the udev device management (which is cool and IBM supported so I don't mind looking into it ;) ) and KDE.

07-05-2006, 05:56 AM
If I change /etc/udev/knoppix.rules to use my userid and group, rather than "-u knoppix -g knoppix", then clicking on the icon works. Otherwise, the mount fails because of the userid and group of "knoppix".

When I am running from the Knoppix CD, it works because the user is "knoppix". I think that the knoppix-install script overlooked changing this the knoppix.rules file.

07-21-2006, 01:37 PM
Ok, good work finding out this /etc/udev/knoppix.rules thing. :-)

But what can i do when i want to have multi-user system...?

07-22-2006, 03:22 AM
wow posmanet, i read your 11 posts and i don't see where I talked to you... but whatever, udev rules run as root. You could make rules which call script that either su to a lower permission level or check for current user in the case of new device after init boot. Is that what you are asking?

07-23-2006, 07:56 PM
Hello Zrebel,

sorry if You were irritated by my direct entrance in this discussion - i just wanted to say something like:
"Oh, wow, yes, i've had the same problem and already tried to solve it myself - now i searched on this forum for it and promptly found the solution here, and i'm happy about this!" :roll:

...for the multiuser thing: Yes, calling a script sounds plausible for me and its new to me that this is possible with the udev stuff. (I'm the classical fixed-fstab guy and didnt read much yet about udev.). Thanks for the tip.