View Full Version : Can't mount NTFS hard drive under 5.0.1

07-10-2006, 12:16 AM

I've just done a PMI of 5.0.1, and can't now mount my Windows XP NTFS partitions (I only want read access, which I could do with 4.0.2).

When I click on the drive icon, I get the following error message:

Could not mount device.
The reported error was:
fuse: failed to exec fusermount: Permission denied
fuse_mount failed.
Unmounting /dev/hda5

I'm assuming that fuse is a new package in 5.0.1 - any suggestions as to what I need to do to mount these NTFS partitions?



07-11-2006, 10:20 AM
OK, so I can mount the NTFS partition as root in the console, and then click on the desktop icon to open a directory viewer, but I wanted to be able to just click on the icon (as I could under 4.0.2 and still can for FAT partitions).

Is there anything I can do to set permissions, e.g., in /etc/fstab, so that each time I start Knoppix I can access the NTFS partition from the desktop?

Thanks in advance,


07-24-2006, 10:30 AM
This is the entry I created in my fstab:

/dev/hdb5 /media/hdb5 ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0

(obviously change hdb5 to wherever your ntfs partition is)

It seems to work for me. Click on icon = mount ntfs read only. Right-click gives an option to change to read/write mode.

Do let me know if it works for you.


07-27-2006, 08:46 AM
Hi Jacky,

This is essentially what I've already got in fstab, only difference being '/media/hda5' as opposed to '/mnt/hda5' (my partition is hda5).

Changed it, but got same error message.


07-27-2006, 04:53 PM

My ntfs click-and-read capability worked "right out of cd toaster" more or less. However, I have managed to replicate your error messages. The errors come when the user group (which in my case is called "knoppix" in group "fuse") does not have execute permission for the command /usr/bin/fusermount.

By default, fusermount needs these permissions:
owner(i.e. root)=r,w,x, setuid
group(fuse)=r, x

Something must have happened during your PMI, so if the permissions are not as above, try changing them back e.g. In a root console: chmod u=rwxs,g=rx /usr/bin/fusermount

Then check that the user knoppix is a member of the fuse group and if not add him to the group. You can do this with KUser from the System menu. Find user knoppix or whatever your user name is, click on the name and you can check which groups he is in. Leave the entries in fstab as they are since they look the same as my fstab which works.

I am also adding a link to this useful page with various ntfsmount error messages:

The examples on this webpage are not exactly the same as your error messages. I only managed to get the exact error message when I removed execute permission from group with e.g. chmod g=r /usr/bin/fusermount


07-28-2006, 10:57 PM

Your description of permissions and groups put me on the right track.

Looking at the permissions for /usr/bin/fusermount, I discovered that owner = root, but group = 128, a non-existent group (verified by KUser), and as knoppix is not a member of this group, this is why I was getting the error message. (Something must have got corrupted on install.)

Changing group to fuse (with chgrp) solved the problem.

Thanks for your help.


08-04-2006, 12:59 AM
I had the same problem. I fix it.
See this post, to know how I fix.

08-07-2006, 06:58 PM
My Windows XP machines crashed and won't boot and so I'm trying to use Knoppix 5.0.1 to salvage some files -(I don't need to write to my hard drive, just want to copy files over). But I'm also having problems mounting my hard drive --I keep getting this error message:

Failed to load $MFT: input/output error
Failed to startup volume: input/output error
Couldn't mount device '/dev/hda1': input/output error
Mount failed
Please check that the device is plugged correctly

I've confirmed that the drive is securely plugged into my motherboard. Any help is greatly appreciated.

Harry Kuhman
08-07-2006, 08:39 PM
Any help is greatly appreciated.
See answers #7 and #5 (http://www.knoppix.net/wiki/User:Harry_Kuhman).

08-07-2006, 09:05 PM
See answers #7 and #5 (http://www.knoppix.net/wiki/User:Harry_Kuhman).

If I understand correctly, answer #7 points to some issue with the subject line. If that's the case, I apologize for the confusion -- I posted under the original post title of "Can't mount NTFS hard drive under 5.0.1" and only added my own subtitle of "Total Newb Needs Your Help" as an addendum.

Answer #5 points me to the Rescue FAQ, which I actually did read already but did not mention that I did so. If it matters, I also read http://www.shockfamily.net/cedric/knoppix/ and http://www-128.ibm.com/developerworks/linux/library/l-knopx.html?ca=dgr-lnxw01-obg-SysRecover. They all provided useful information, but unless I completely missed it, none seemed to addressed my specific issue -- a failure to mount my NTFS drive with the specific error messages that I described.

Please let me know if there are other resources I've missed or further information I can provide in order for someone to give me a suggestion on what to do next. Thanks again.

Harry Kuhman
08-07-2006, 09:33 PM
answer #7 points to some issue with the subject line. If that's the case,
You are correct to an extent; the subject seemed apparent by the main thread topic. That's why I even tried to point you to the rescue faq, which I didn't know at the time that you had read, as otherwise a subject line like yours would cause me to not give an answer even if I knew it. But you seem to be posting your problem in a thread somewhat far away from where the people who might help you are likely to find it, being that this is a forum for those who think a hard disk install of Knoppix is a sane idea. I wasn't going to split it out and move it, however, with that subject line. If you search around in the forums you'll find other recent threads where the topic of trying to mount partitions that don't show up on the desktop or refuse to mount are covered in better detail.

08-08-2006, 06:17 AM

Try searching or asking at the forum on this site: http://www.linux-ntfs.org/. These are the people who are actually developing the Linux ntfs drivers and they seem a friendly lot and I have been quite impressed with the progress they have made with ntfs in just a few years. I think I have seen something like MFT problems on the posts there. Seems to me like you have a corrupt MFT (master file table). On some sites, the suggested solution is to boot with a Windows Recovery CD and do a chkdsk, but better check with the experts at linux-ntfs to be sure.


08-08-2006, 02:26 PM
Thanks for your reply, Jackey -- I will definitely check that site out. I suspect that my drive is hosed since I did try the Recovery Console and chkdsk earlier and it told me that the drive had one or more unrepairable problems, or something like that. Nonetheless, I'll keep fishing around for something that might allow me to retrieve those files. Thanks again.

08-08-2006, 04:24 PM
If all else fails and you just want to recover files, you can also try testdisk and photorec (both are on Knoppix). photorec in particular is good for recovering files. It ignores the underlying file system and scans disks for byte patterns which match the signature of common file formats. So it might still work even if the filesystem is damaged and the disk cannot be mounted.

Photorec is good for media files like digital images (what it was originally designed to rescue) but now can recover many different types of files. Try a google for photorec to look at the main home site. It might be useful to you. Unfortunately, the documentation and manual is quite brief.

09-18-2006, 07:54 PM
i had similar problems with permissions after doing a debian type install to hard drive. with live cd everything works fine, but after installing to hard drive i have problems running programs like kwrite and konqueror from root terminal and also i cannot mount hdb1 anymore, which is my ntfs partition. if i mount as root from terminal then its fine but this is no good for my xbox accessing over network.

after installing sux i can now run konqueror and kwrite from terminal (so i have root privelages). in konqueror i browsed to /dev directory and right clicked on hdb, set permissions for "others" to -can read and write- and did the same for hdb1. now when i click on desktop icon it mounts straight away.

i can appreciate that this may the wrong method , but it works so may put someone else onto the right track.