View Full Version : Need some help install ATI Drivers

07-16-2006, 08:27 PM
I wanted some linux because windows was driving me insane, so I installed a distro of linux that I had lying around.

The ISO is labeled as:


so apparently I have Knoppix Version 5.0.1

What I want to do is install the ATI Drivers at ati.com, here is the log file for the installation:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
Assuming default VMAP API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.17/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.17'
Makefile:266: /usr/src/linux-2.6.17/scripts/Kbuild.include: No such file or directory
Makefile:486: /usr/src/linux-2.6.17/arch/i386/Makefile: No such file or directory
make[1]: *** No rule to make target `/usr/src/linux-2.6.17/arch/i386/Makefile'. Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.17'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

anyone else get somthing similar, or know how to help me install these drivers?

Currently I'm using the ati driver that's included in the knoppix installation, but GLX Gears or any openGL Programs I try to run run extremely slowly.

Also, I want to be able to use a resolution of 1280x800, as that's the size of my LCD.

Any help is greately appreciated, thanks.

08-21-2006, 10:23 AM
The ATI drivers from ati.com don't have support for X.org 7.00 and that might be the problem. I also tried installing the drivers with my RADEON 9600 but with no success. I managed to install the kernel driver after removing the old driver with a "modprobe -r ati" but there was no 3D accel. The driver was not working.

However afer reinstalling knoppix (withoput installing any ati official driver) I tried to play something on CEDEGA (tm) and everything was fine. The X.org ati driver worked and I had OpenGL / Software 3D acceleration with default Mesa.

It seems that we have to wait for a ati release to support X.org 7.00 :(