View Full Version : Problems booting and starting X

09-02-2006, 03:30 PM
Hi, I can't seem to boot into X with Knoppix 5.0.1.

If I boot normally, the system just halts with a totally black screen and no DVD or HD activity, just after the boot screen. Typing "knoppix acpi=off" gets me a little further, but the kernel panics soon afterwards. I have tried typing the following commands, which halt right after the boot screen as before:

knoppix no{apic,agp,apm,audio,ddc}
knoppix no{dhcp,fstab,firewire}
knoppix no{pcmcia,scsi,swap,usb}

If I type "failsafe" it boots until X starts, at which point I get the "DVI: No Signal" message on my monitor. The system continues to boot though, because I hear "Initiating startup sequence" and the DVD and HD continue to be very active.

Along with typing "failsafe", I have tried adding the commands:

knoppix xmodule=ati¦fbdev¦i810¦mga
knoppix xmodule=nv¦radeon¦savage¦s3
knoppix xmodule=radeon¦svga¦i810
knoppix vga=normal
knoppix 2

The only command which gets me to any interactive point with a visible screen is "failsafe knoppix 2". At which point if I type "startx" the screen goes black and I hear "initiating startup sequence" again. I have tried plugging the monitor into the second DVI out on the video card, but no difference.

Any suggestions? Any help would be very much appreciated. System spec posted below:

AMD 4600+ Dual Core 64bit AM2
Asus M2N32 SLI Deluxe
Sapphire Radeon X1900XT
Seagate 320GB SATA2
Viewsonic VP930 19"TFT
2GB Kingston 667 (2x1GB)
Creative SB Audigy Gamer
3com 10/100 NIC

09-02-2006, 09:20 PM
Well, I have made a breakthrough! (of sorts). My vid card only has DVI out but my monitor has DVI and VGA. Using an adaptor I used a VGA connector instead, and got video using only the "failsafe" command. However, I have no mouse control (plugged into PS2 port) and it's horrifically unstable.

Anyway, I'm off for a drink. Hope this info may be useful to someone else: black screen but sound - use VGA.

Harry Kuhman
09-02-2006, 09:28 PM
My vid card only has DVI out but my monitor has DVI and VGA. Using an adaptor I used a VGA connector ....... Hope this info may be useful to someone else: black screen but sound - use VGA.
This isn't making much sense to me at all. I know there are a lot of issues with some DVI cards. I had a friend who couldn't even get to his BIOS settings because the DVI out wasn't enabled until Windows booted and the BIOS was never seen! He had to change brands of video card vender to resolve it. But in your case you're not really switching between DVI and VGA, you're always using DVI out, just converting it to VGA with an adapter and then going in to the VGA in on the same monitor. If Knoppix produces viewable output this way than I don't understand why the monitor couldn't display that same video when it came in on the DVI input. I hope that as you learn more about this that you'll post it.

09-03-2006, 10:46 AM
I agree, I don't really understand how that can happen myself. I was pretty astounded the more I thought about it, so I plugged in an old Daytek 15"CRT that I had lying around, and same deal, worked perfectly (at 800x600). Back into VGA on 19" TFT, same deal. Onto DVI, no video after X Starts.

There is of course the possibility that this is a prob with my monitor. If I have time I'll try playing around with "knoppix xvrefresh" and "xhrefresh" and see if I get anywhere.

The other prob I'll have to track down is why "failsafe" works, but none of the "knoppix xmodule" commands work. When I find out what piece of hardware it is that's holding me back I can isolate it and switch it off. Should make more progress then.

09-03-2006, 08:35 PM
Well, I have booted to the prompt before Xwindows starts and taken note of the refresh frequencies. I then started in failsafe mode again, but this time with the "knoppix vsync" and "hsync" operators set the same as they were at bootup screen, but no joy.

I'm no linux expert, but I'd say that Xwindows in Knoppix doesn't know how to drive a Radeon X1900XT's DVI port properly. Just a wild guess though.

09-03-2006, 08:39 PM
Sorry, hit submit too soon.

Either that or Viewsonic VP930 monitors are expecting something more through their DVI inputs than their VGA ones, and hence it thinks there is no signal through DVI - even when it's getting the same information as the VGA port is.