View Full Version : problems with knx-hdinstall

05-18-2003, 05:17 PM
Hi all,

has anyone else had problems with this script? I did a verify on
my Knoppix 3.2 disc - bought from CheapBytes 'cause I have a modem
connection - and it verified fine. But the install script dies
during the copying of files (about 10% through). Several times I
tried. No luck.

So I have a ~4gig partition for Knoppix and a 300mb swap partition
defined. I tried copying the Knoppix installation to the /dev/hda2
partition (my 4 gig) and then editing the knx-hdinstall shell script
to run from my home directory rather than the CD. Darn difficult
for a beginning bash shell scripter I must say.

Got most of the way through but am hung up in the lilo.conf section.
My lilo.conf doesn't look quite right (way more minimalist than the
example) and it won't write to the MBR. Nor will it properly burn
a boot floppy (yet).

I'm about ready to give up and go back to installing Mandrake 9.1
but I thought maybe somebody would have an idea why the script
is dying on me (and a simple fix).

I've got a Sony PCG-505F laptop with external floppy and CDROM
drive. 20gig hard drive, Pentium 233Mhz chip. Boot using
knoppix ide2=0x180 nopcmcia 'cause the Sony uses a very funky
PCMCIA external CDROM and this was the only way I could get it
to boot off the CD.

This install script is just killing me..

thanks much,

ps. love Knoppix so far (running from CD). Just hope it is much
faster off the hard drive (I expect it will be).

05-18-2003, 06:13 PM
Try here (http://www.itm.tu-clausthal.de/~perle/knx/) for a different version of the script it may help. What errors if any are there in the console when this happens?

05-18-2003, 08:53 PM
Well, it's a bit difficult giving you the exact text since (1) it varies every time (script dies at a slightly different point) and (2) using the PCMCIA cdrom I can't connect to the Internet easily at the same time (only one
PCMCIA slot in my laptop).

Anyway, the errors all seem to be I/O errors (probably hardware-specific) in the copy process.

Thanks for the pointers to the script but wouldn't I have to burn a new
CDROM to make use of them? I thought the script was on the CD so
it's read-only? This, in fact, is the source of my problems. Even with the
new scripts (I'm using Knoppix 3.2) I will still have to "port" it to run
off the hd rather than the CD if it is going to be any use to me.

I'm not really sure that the problem lies in the script - it's probably more
of a timing error in the transfer between my PCMCIA CDROM and the hard disk.

My strategy was/is to port the script to run off the hard drive, comment
out the copy section and do a manual copy (which works, btw) and go from there. Of course, thinking about it, wouldn't that imply that there IS
a problem with the script if the manual copy works (as it does)?

(trying really hard to do away with Winblows).

09-11-2003, 05:29 AM
I have the same problem. Except I have about four machines that I am running Knoppix on, and all of these I have installed using the script. Basically, if I run it in text mode then I have a much higher chance of sucess, but generally the script will fail some where between 10% and 60%, of copying the files.
On one of the machines I had to re-try 8 times before the install actually worked. Needless to say, this is quite time consuming.

Considering that the command within the script to copy across the files is a simple 'cp', then I am guessing that the script just doesn't have proper error checking. It appears to me that there is no easy way around this.

I am currently using the knoppix 3.2 released in march. I seriously think that there is a problem with how knoppix is using the cdrom. I know on my CD at home after a couple of days of uptime I will no longer be able to access the CD, it will compain that "file system not recongised", and it will require me to reboot the system.

Has anyone else experienced anything like this? Is there any work around that I could do that would fix this up?