View Full Version : Knoppix: "Looking for CD"

10-31-2006, 10:17 PM
I have this problem when I try to start Knoppix up.

It first loads my two harddrives:


and then it skips a partition that came with the computer (it's a rental), which contains recovery stuff for the computer.

so it tries to load from the knoppix-CD at /dec/hdc, but afaik, this is where the partition is at.

How can I fix so Knoppix tries to load from the knoppix-CD at /dev/hdd, which is where it should be at?

I've tried "knoppix nodma" at start-up and it gives me the "few options shell" or whatever, due to an I/O error, and the exact same thing happens with "failsafe".

Any ideas what to do?

11-02-2006, 03:32 PM
Have you tried the other Knoppix cheat codes like...

knoppix fromhd=/dev/hdd
knoppix boot=/dev/hdd
knoppix bootfrom=/dev/hdd
knoppix atapicd

Hope they help!

11-02-2006, 03:52 PM
Was actually a far more stupid reason.

When I started the download, it got interrupted, but this was weeks before I burned it. So I didnt notice that the size of the .iso was just 288mb.

So I downloaded it again and burned it on another CS and voila, it works.

It still gets stuck on the DMA part though, but it works with "knoppix nodma"

11-04-2006, 10:34 PM
if it's working, fine

/dev/hdc would be your secondary master
/dev/hdd would be your secondary slave

don't confuse the hdd - hard disc drive with
/dev/hdd being the next sequence from
/hda /hdb /hdc /hdd etc

12-02-2006, 02:22 AM
I have a Pentium-IV - 3.08 Ghz PC with GGC-101 mother board and 512MB memory. I have SATA hard disk80GB and IDE hard disk850MB. 1 LG cd rom frive and one HP 9500 cd writer. the problem is, when I run the Knoppix cd from any of the cd drives, it hangs up after the following sequence. also I can see 2 Penguines on the top left hand corner of the screen where as I see only one Penguine the other machines. I am using the linux for the very first time on my machine and have no knowledge about linux. I had been using Windows system all these years.

The screen reports while booting are:-
1) Welcom to Knoppix live Linux on CD
2) Scanning for USB/Firewire Devices.......done
3) Enabling DMA Acceleration for : hda [Quantum TRB850A]
4) Enabling DMA Acceleration for : hdc [GCR-852B]
5) Enabling DMA Acceleration for : hdd [HP CD Writer +9500b]
6) Looking for CD in: /dev/hda

at the 6th line the whole system hangs up.

The program loads and works ok from my friends laptop PC and my office desktop pentium -IV PC without any problem. It is apparent that the CD is ok.

I assume that the CD should be running from hdc or hdd and why is the linux system looking for the CD in the hda?
I would appreciate any help to solve this problem and get the system running on my PC.
Thanks in advance.

12-03-2006, 12:23 AM
the number of penguins is the number of cpus you have
the Piv would be a dual core, either real or HT
my dual xeon shows four penguins

it should be trying to find the media in a cd- device
so would be interesting to find why it thinks your quantum is a cd device, let me re-read ....

guessing the ide hard disk is the Quantum
is the LG cd the GCR-852b ?
I'd try some of the no-this or no-that cheat codes ....
and also, try your own thread ....
while it is similar to the up the top thread, it will get confusing when people start replying to your bit apart from the orig bit.

12-05-2006, 01:58 AM
Yes. LG CD Rom is the GCR 8521B. I have tried disconnecting all the other hard disk and CD Rom leaving only the LG and swapping primary Master and Slave for the 850 Mb HDD and the LG and got the correct hdc for the CD ROM. but still it stops at :- Looking for CD in :/dev/hdc....... and freezes there. Since I have no idea about knoppix, I don't know how to solve this problem and proceed further.

The CPU is a hyperthreading one.I have confirmed that the Knoppix CD is ok.